Hummingbird says "gzip is not working properly", how to fix it?

Hi there,

I’ve recently changed a few things on my Apache Server (WHM), basically implementing OPCache and FPM (FastCGI-Page-Manager) among other small things… And now the Hummingbird gives me this message. As there’s a link for you at the end, here I am:

“gzip is not working properly:

– Your server may not have the “deflate” module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)

– Another plugin may be interfering with the configuration

If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.”

I’ve granted support access so maybe you guys can help me to find out what is going on. Thank you very much and have a good one!

  • Luís
    • Support

    Hi Fabio Fava ,

    Hope you’re doing well today!

    From what I checked in your website, the GZIP compression is not enable to “text/HTML”, it was enabled to “text/javascript” and “text/css”.

    I would like to suggest the following:

    1) check if there’s a Vserver side cache on your server (i.e Varnish Cache); if it is, make sure to purge/empty its caches;

    2) It’s possible the “mod_deflate” module are not configured to handle with all required MIME types, so, can you please contact your host provider to double check if it supports “text/HTML”?

    3) make sure that PHP is configured to support zlib library and that zlib output support is enabled; there’s a php.ini setting for this that should be set to “on”:

    zlib.output_compression = On

    Cheers, Luís

  • Fabio Fava
    • WordPress DevOps

    Thanks Luís, I’ve already contacted my hostmaster, but you know it may take some time.

    I’ve attempted the php.ini command but doesn’t change anything on the server. I’l waiting for my hostmaster to answer me (and pray for him to look at).

    Anyway if is there anything else we could do, please let me know.

    Thank you very much and best regards!

  • Fabio Fava
    • WordPress DevOps

    Hi Luís (como está amigo?),

    I’m fine thanks, hope you’re doing well either! About GZIP and my Hostmaster:

    My Hostmaster is my partner on this new business and he has a main job, so he will take a bit to solve that for me. I think I’ve messed up something when I’ve used the WHM on root mode for a while. I have no experience with WHM so I’ve screwed up something there.

    He also needs to enable PHP7-FPM (FastCGI Page-Manager) and OPCache (Apache-Side) and fix a couple of other things: we’re just starting our new business and this may take some time no matter how simple it may be. But please, if you know about Apace Configuration, don’t hesitate to help us on solving that with soma tips and links.

    I’ll keep this topic updated as we solve that, thank you very much and best regards!

  • Luís
    • Support

    Hi Fabio Fava ,

    Hope you’re doing well today!

    Do you had any update regarding to the GZIP compression issue?

    Honestly, I don’t have too much experience in the Apache configuration, I made some research and I think this articles may interest you:

    http://www.hostingadvice.com/how-to/enable-php-5-5-opcache-ubuntu-14-04/

    https://www.howtoforge.com/tutorial/apache-with-php-fpm-on-ubuntu-16-04/

    If you had any issue in the configuration, you can post it here on the Support Forum, we will try to help you. Just keep the issues in separate topics, so we can focus in each one and to avoid spread and lose information.

    https://premium.wpmudev.org/forums/#question

    Cheers, Luís

  • Fabio Fava
    • WordPress DevOps

    Thanks Luís!

    The problem was my partner, he has a job and have no time to do that simple thing. I’ve got another partner (not a friend this time, it’s a true business partner) and we’re moving everything to a new server that he will setup properly.

    We may have the Server and the Application running on the next week, then it will be gone.

    Thank you once more, I post here as we have any news!

  • Fabio Fava
    • WordPress DevOps

    Hi folks!

    I’ve setup a Local OSX-AMP Development Server. When I try to activate Humingbird’s GZIP Compression, I receive that red alert about mod_deflate not being enabled. I’ve uncommented the line for it on my Apache httpd.conf.

    I assume I’ll need some extra setup: I’ve been trying to add lines to my .htaccess files, also on httpd-vhosts.conf file, also at httpd.conf file, but not working. I would love to make it work on my Local Development Environment, to learn how-to and get it faster.

    Any clue, buddies? Thanks and cheers!

  • James Morris
    • WordPress Enthusiast

    Hello Fabio Fava,

    I’m afraid I’m not a Mac user, but the configuration for Apache is pretty consistent across platforms. The following article goes through what you will need to do to enable Gzip on Linux, which is similar. The biggest issue is ensuring that you have the correct directives and paths set.

    https://knackforge.com/blog/karalmax/how-enable-gzip-compression-apache

    I hope this clarifies a bit.

    Best regards,

    James Morris

  • Fabio Fava
    • WordPress DevOps

    Hi James Morris !

    I’ve tried it all, no results. Attempted to place the code (but with my path instead /var/www that is something like /Users/myuser/Sites/mysitefolder.

    Tried to add the final lines at httpd.conf and the others in my httpd-vhosts.conf and .htaccess (on site’s root folder), no luck either.

    I’ll keep looking forward to some sort of solution to that. As it’s a local Server, there’s no need for real compression, and it normally works on any cheap shared host. But I would like to learn how to make this work, anyway.

    Thank you all guys for helping me so hard on that! Cheers!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.