Hummingbird showing different score

Google Page Speed is listing a score of 29, and Hummingbird, on the other hand, is showing 78 score.

Please advise what needs to be done to get correct results.

  • Neel Gajjar
    • Staff

    Hello Anders,

    Thank you for proving your backend access.

    As I can see there are many plugins installed on your site and few of them are related to caching.
    Out of which WP Super Cache & Autoptimize plugin does a similar job as Hummingbird. Could you please disable these two plugins activate Hummingbird caching and check again?

    And also Google has updated its API of PageSpeed Insights to V5. And we are still running API v4.
    This is already a known issue and has been reported to our developers and work is in progress, a new version of Hummingbird with updated API will fix that.

    Apart from this, you need to improve your score for that you should optimize & minify your files.
    You should activate Asset Optimization in HummingBird it will list all the CSS and JS file. The goal is to combine and move the files to footer.
    You can find a detailed blog regarding Asset Optimization & minification in the given link :
    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#minification

    Note this is a trial and error process, sometimes shifting or combining few important files might break the site. So it is advisable to first perform it in a staging environment.
    Eliminate render-blocking resources issue will increase your score significantly.
    You can find a detailed guide on it is given below link:
    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    Hope this helps, we'll be looking forward to hearing back from you.

    Kind regards,
    Neel Gajjar

  • Neel Gajjar
    • Staff

    Hello Anders,

    Hummingbird Pro 2.0 is released which has updated the API of Google PageSpeed Insights to V5 and there are many more performance fixes which will definitely increase your score.
    I would request you to please deactivate Autoptimize and WP Fastest Cache and activate Hummingbird Pro latest version, and follow the above instructions to eliminate Render Blocking issue.

    Hope this helps, we'll be looking forward to hearing back from you.

    Kind regards,
    Neel Gajjar

  • Neel Gajjar
    • Staff

    Hello Anders,

    Thanks for updating the Hummingbird Pro to its new version.
    I can see still WP Fastest Cache is still activated. Even though you have not enabled it from its settings page it still might create a conflict with Hummingbird Pro.

    All plugins which are not in use should be deactivated and deleted. It increases the speed of the website and overall Google PageSpeed Insights score :slight_smile:

    Coming back to your score I checked your score at Google PageSpeedInsights these are the result what I got.

    Please take FULL BACKUP before applying any of the changes.
    If this is a live website with traffic, I'd rather advise creating a staging environment, meaning a complete and exact copy of this installation into another location/folder in the same server, using a separate database, and perform the test in there instead without worrying about the live site. Reference: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    When I visited Hummingbird Pro > Caching > Browser Caching. Browser caching for media is disabled, please contact your host to update the nginx.conf to enable the caching.

    Now let us tackle your score issues

    1. Eliminate render-blocking resources & Remove unused CSS :
    Please visit WP-admin dashboard > Hummingbird Pro > Asset Optimization > Switch to advance mode for more control > Got it.

    Over here all the JS and CSS files are listed, you can combine, minify or moving them to footer.
    We do have a detailed guide on how to eliminate render blocking resources.
    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    The best practice is to load as many scripts as possible in the footer of your site, so slow-loading scripts won’t prevent vital parts of your site from loading quickly.
    However, it is important to remember that it's not always possible to eliminate all the files as it might break your site, the ultimate goal is to lower the number of files.

    Now for the next issues, we need to install one more plugin Smush Pro

    2. Defer offscreen images, Serve images in next-gen formats, Properly size images :
    Visit Smush Pro dashboard WP-Admin > Smush Pro
    Activate the following if not activated
    - Automatically smush my images on upload
    - Super-smush
    - Metadata
    - Image resizing
    - PNG to JPEG conversion
    - Click on Bulk Smush
    Scroll to the bottom > Click on Save changes.

    Now visit CDN and enable the following options
    - Activate
    - Automatic Resizing
    - WebP conversion
    Scroll to the bottom > Click on Save changes.

    Now visit Lazy Load and enable the following options
    - Click on Activate
    Scroll to the bottom > Click on Save changes.
    We have a detailed guide for Smush Pro please read it once for better understanding
    https://premium.wpmudev.org/project/wp-smush-pro/#wpmud-hg-project-documentation

    Once done. Clear all your cache and recheck the score :slight_smile:

    Hope this helps. Please feel free to ask more questions if you have any.

    Kind regards,
    Neel Gajjar

  • Neel Gajjar
    • Staff

    Hello Anders,

    I forgot to mention one thing, If you plan to use Smush Pro CDN then there is no need to configure anything in Bulk Smush section as images will be loaded directly via Smush Pro CDN network they would be already optimized.
    Bulk Smush section is used to optimize images which are locally stored on your server.

    Hope this helps. Please feel free to ask more questions if you have any.

    Kind regards,
    Neel Gajjar

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.