[Hummingbird] Slow site issue

I enabled Page Caching but my hosting provider is telling me that caching is still disabled on the sitel. Because of that, I’m getting long response times, as the cache is being skipped.

  • Nithin
    • Support Wizard

    Hi mubeenmulla,

    I could notice Hummingbird cache is also not being served when checking the site headers. However, it seems like your website is hosted in WP Engine, which out of the box caches pages too, which is similar to the Cache feature in Hummingbird. There isn’t any need to enabled Hummingbird Page Cache separately since WE Engine should be caching pages out of the box.

    On checking your website further via Pingdom:

    https://tools.pingdom.com/#5b1bd2e67fc00000

    I could notice the Lingotek Translation plugin is what’s taking slowing down the site. The plugin is also adding a 302 redirect, and then loading the /en site, and it takes around 3.1 seconds.

    The 302 redirects might be causing the server-side cache to work too. Is it possible to test the website with the mentioned Lingotek Translation disabled, and see how the website loads?

    This would give a better idea regarding what exactly could be causing the issue. Please do let us know.

    Kind Regards,

    Nithin

  • mubeenmulla
    • WPMU DEV Initiate

    Speed Index

    100%/1%

    Speed Index is an index measured in milliseconds which represents the average time it takes for the above the fold content to become visible. The index also takes into account the progressive loading of your content, which means the sooner the content starts to render, the better your speed index. Note that this metric is highly dependant on the device and screen size being used to view the site.

  • Nithin
    • Support Wizard

    Hi mubeenmulla,

    Seems like the Lingotek Translation plugin is now disabled, and could notice the redirections are not present anymore after that. However, the server cache still doesn’t seem to work when I checked the Cache headers.

    I’m afraid, this could be still due to conflict within the website or something specific within the server-side. As the cache isn’t working at the moment that would be one of the factors that contribute to the website to slow down.

    Is it okay, if we could troubleshoot your website further by disabling all the plugins except WPMU DEV Dashboard, and switching to a default theme like TwentyNinteen?

    This would help in checking how the website loads with minimal configuration, and what exactly could be causing the issue. Please do let us know whether you are comfortable with us running further test as mentioned above.

    Looking forward to your response. Have a nice day ahead.

    Best Regards,

    Nithin

  • mubeenmulla
    • WPMU DEV Initiate

    yes, this is the error: 3 PHP Fatal error: Uncaught Error: Call to a member function write() on null in /nas/content/live/ectuae/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache.php:1553nStack trace:n#0 /nas/content/live/ectuae/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache.php(281): WP_Hummingbird_Module_Page_Cache::log_msg(‘[12:54:52] Load…’:wink:n#1 /nas/content/live/ectuae/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache.php(933): WP_Hummingbird_Module_Page_Cache::load_config()n#2 /nas/content/live/ectuae/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache.php(1357): WP_Hummingbird_Module_Page_Cache::should_cache_request(‘/wp-admin/’:wink:n#3 /nas/content/live/ectuae/wp-content/advanced-cache.php(32): WP_Hummingbird_Module_Page_Cache::serve_cache()n#4 /nas/content/live/ectuae/wp-settings.php(95): include(‘/nas/content/li…’:wink:n#5 /nas/content/live/ectuae/wp-config.php(129): require_once(‘/nas/content/li…’:wink:n#6 /nas/content/live/ectuae/wp-load.php(37): require_once(‘/nas in /nas/content/live/ectuae/wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache.php on line 1553

  • Nithin
    • Support Wizard

    Hi mubeenmulla,

    The above-shared error might occur if the Hummingbird advanced-cache.php file was still being called even when the Page Cache was disabled.

    However, when I check your website now, Hummingbird is no longer installed on your website. I checked the server cache of your website and I could still notice the cache from your server isn’t working still.

    As mentioned in my previous reply, is it possible to disable all the plugins except WPMU DEV Dashboard, and also by switching to a default WP theme to see how the server behaves in terms of serving a cached page? This would give a better idea regarding what could be causing the issue.

    Please do let us know whether you are comfortable with us running further test as mentioned above.

    Kind Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.