Hummingbird speed advice - improve server response time

Hi everyone, I'd like to thank anyone for any assistance provided.

I've been looking into a few issues with a new-ish website that was dormant for a while. It's since been put onto a 4GB VPS server and had an Alpha and MySQL optimisation service and I've added WP super catch.

The attached image shows a pretty good overall score with the one element focusing on server response time which is really poor and is leaving the back end and website incredibly slow. I'd like to know if it's my website or the Go Daddy Server that is the problem.

There are a few other concerns but one problem at a time :smiley:.

  • Nithin

    Hi Frazer369,

    Hope you are doing good today. :slight_smile:

    From your given screenshot, only the server response score looks to be low, rest all the scores are above 80 which is pretty good. I checked your website, in pingdom, and the test did show a wait time of 5.3 seconds:
    https://tools.pingdom.com/#!/czCNJx/http://brownbear.co/

    It seems like you are redirecting your website, and that is lagging the loading time to around 3.4 seconds. If cleaning up the redirect doesn't help much, would recommend you to get in touch with the host, and see whether they could help improve this.

    For a faster website, please mak sure you have caching plugins installed:
    https://wordpress.org/plugins/w3-total-cache/
    https://wordpress.org/plugins/wp-super-cache/

    You might find the following article helpful:
    https://varvy.com/pagespeed/improve-server-response.html

    Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Frazer369

    Thank you Nithin,

    I 've just run the test myself and can see that it goes to http//Browner.co then 3.2 seconds later goes to https//brownbearm.co. This clearly slowes the transfer down significantly.

    How would I go about getting the Https as the default route? When typing in the secure Url the website loads so much quicker...

    Again thank you for your message, I'm very well thanks hope you're well also. :slight_smile:

  • Frazer369

    Hi Nithin,

    Thanks again for your response, I've looked into the issue a lot more and spoke to Go Daddy. I've since pushed my server onto PHP 5.6 the latest version they allow.

    The sites load time has been reduced but 16% of the resource time is redirecting through Zopim. It appears to be a widget that I should remove that hopefully will help my cause significantly, leaving only a fonts re-direct issue.

    Do you know of a way for me to remove it from the site, it's not a plug in. I think it's potentially inside the theme. It shows itself as a redirect on every page.

    The following resources are missing a cache validator. Resources that do not specify a cache validator cannot be refreshed efficiently. Specify a Last-Modified or ETag header to enable cache validation for the following resources:

    https://v2.zopim.com/bin/v/widget_v2.177.js
    https://www.zopim.com/product/

    I look forward to your thoughts and appreciate your help. :slight_smile:

  • Rupok

    Hi Frazer369,

    Do you know of a way for me to remove it from the site, it's not a plug in. I think it's potentially inside the theme. It shows itself as a redirect on every page.

    Thanks for sending all these details. As you said, the zopim functionality is added in your theme, it's pretty tough to say how to remove it without seeing your theme code. I checked the source code of your site and found the piece of code from zopim, but I'm not sure which file is calling that. Can you please send us a copy of your theme so we can check the code and try to find out from where it's being called? You can upload your theme zip file to any popular file sharing service like Dropbox, Google Drive etc. and provide us the download link.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Frazer369

    Good Evening Rupok,

    Thank you for your email, I've downloaded the theme using WP Downloader and popped the download on this link :slight_smile: BrownBear Theme - Atelier

    I hope that this is helpful and as expected. I really am looking forward to solving this as well. Many of the other initial problems are solved, this is like the final hurdle which is slowing the build down.

    Have a great night - Best!
    Frazer

  • Rupok

    Hi Frazer,

    Thanks for sending the theme. I've searched through all files, but could not find any existence of "zopim". So I think, something else on your site is adding that zopim code on your site.

    I could tell you better about the issue if I could check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska

    Hello Frazer,

    This is weird - I'm checking your site and I'm not able to find trace of that Zopim chat there. I checked most suspicious plugins but it's not there. Its not in widgets, it's not in custom JS part of theme, not in custom functions plugin and not it must use plugins.
    Tricky one to find. I can grep all your site files to look for Zopim text string but I would need to get FTP access. Could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you've send that message

    kind regards,
    Kasia

  • Nithin

    Hey Frazer369,

    Hope you are doing good today. :slight_smile:

    It seems like the FTP wasn't working, so I took the liberty to create a new FTP account(wpmudev), and I checked your files. I wasn't able to find your zopim script in your theme files, so this could be coming from one of your plugin. Since there are many plugins, it's pretty time consuming to grep each plugin folder, is this a live site? Could we try deactivating some plugins, in order to check from where the zopim script is being called from? It would be easier to rule out from the WP Dashboard, since it looks like a live site, I didn't deactivate any plugins.

    Could you please let us know whether it's possible, so that we could test this further. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Frazer369

    Hi Nithin,

    The site is live but not taking orders. The site is due to launch as soon as the website speed can be boosted from its current crawl :slight_smile:.

    You're safe to do what is nessasary in regards to plug ins. I have a database back up with Godaddy every 24 hours so if all else fails there is a restore point. I couldn't get the WPMU one to work.

    I'd like to thank you all for the time thus far, seemingly these links would definitely be beyond me and are proving challenging.

  • Frazer369

    Hi Nithin,

    Looking again at Pingdom, I'm not sure why it takes almost 5 seconds for the site to begin to load? I have been led to believe that it's the redirects from Zopin and Google fonts. I'm hoping that these changes will make all the difference and bring the site down to a more comfortable load speed from page to page. The back end as you may notice is just as slow as the website.

    I look forward to any findings you have and working towards a fix then I'll look to further integrate a few of your plugins into the site, (the fun bit). :slight_smile:

  • Nithin

    Hey Frazer369,

    Hope you are doing good today. :slight_smile:

    The Zopim is part of your theme options, you added the script under Theme Options > General Options > Tracking Code

    Please remove the Zopim code as mentioned above. I had to switch the theme, so you'll have to configure the homepage layout, sorry about that. Maybe it's under Settings > Reading, I wasn't sure, so I'm leaving that part for you. I had temporarily disabled the cache plugin, please do activate it, and also re-check Hummingbird Minification.

    Looking again at Pingdom, I'm not sure why it takes almost 5 seconds for the site to begin to load?

    I checked your website in Pingdom, and the website is taking 5 seconds to load, and and it was way slower than last time I logged in your system. It's not related to Zopim, or Google scripts, but more towards your server. Your server response time is way too slow. Would recommend you get in touch with your host. You might find the following link helpful:
    https://varvy.com/pagespeed/improve-server-response.html

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Frazer369

    Hello Nithin, thank you for your help.

    Those links have now been removed and the site is a little faster for it thank you, I've also removed the plug in that was causing the issue with Google Fonts.

    I have spoke to my Host GoDaddy and they recommend the use of a CDN, they did quote one which was quite expensive so I looked about and have started a Pro account on cloud flare.

    The website for some reason has now went to this log-in page http://www.brownbear.co which is quite strange? You won't be able to access the admin site as it produces a 404 error.

    I've double checked all the DNS settings for this on CloudFlare but no mistake was found following the guide. I can reverse this quite easily by pausing the Cloud Flare service and within an hour of clearing the catch the site is back to it's normal slow self :smiley:. I don't want to do that yet as I'd like you to see it and pass comment before doing so. We've got time as the site will now launch officially in January, a soft launch will be end of next week.

    Pausing the service clearly denies me access to the service, I look forward to your thoughts :slight_smile:

  • Kasia Swiderska

    Hello Frazer369,

    You won't be able to access the admin site as it produces a 404 error.

    Can you tell what type of 404 error page it was? I mean - was it WordPress 404 page or a server 404 page? Could you possibly enable CloudFlare so i could see this issue?

    I did a small research but only mention about 404 errors with CloudFlare was for other pages than wp-admin and that was resolved by flushing permalinks... So that would not help you.

    However you should check, to be sure if your htaccess entries are correct https://codex.wordpress.org/htaccess#Basic_WP

    kind regards,
    Kasia

  • Frazer369

    Hi Kasia,

    Thank you for the response, I'm very sorry for the delay. That issue was solved The DNS was incorrect on the domain so when it was redirected via name server it was trying to access the wrong Cpanel.

    In regards to the website speed, I'm still talking to GoDaddy about improving the speed and just pushed another £440 in for a managed VPS server. We had paid for the optimisation before but to no effect, we now wish we'd used a different service like' 1&1 but that's life.

    I may be back on the forums soon if GoDaddy can't solve this even with money being thrown at them.

    Have a great winter break :slight_smile:

  • Frazer369

    Hi Steven, long time!

    The issue was resolved at long last, the problem we were having was primarily the Host, since switching to a new host we've no longer had any major issues with our website, bar from one i'm going to create a new post for.

    I'd heavily recommend many people to steer clear of GoDaddy, they practically robbed us of £1,600 with advice and services that were over kill for our needs to solve a problem they seemingly didn't understand.

    The worst part is that when you raise this via email they don't have a complaints procedure or respond to your complaints, we must have emailed about 3-4 supervisor emails given to us by phone support.
    By the time we'd realized that this was a bad direction and after seeking additional advice from a different source we took the opportunity to move host! they are not responding to emails and are shifty on the phone about where we can go from here with Godaddy. They did in the previous email before the complaint put their hands up regarding a miss selling of a product, but failed to go anywhere with our request that was reasonable and that was credit the accounts back for the mis-sold VPS and developer platform.

    This is still ongoing unfortunately, anyway the sites much better :slight_smile:

    Thank you for your time!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.