[Hummingbird] Trying to configure Hummingbird. Having some issues.

Hummingbird and WP Smush Pro.
I am trying to configure Hummingbird, but the browser caching is giving me an issue. It said: "Browser Caching is not working properly:
- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us."
Plus, I ran a test in GTMetrix.com and it's showing me that numerous images don't appear to be optimized or set properly. But I ran Smush Pro, and Smush says everything is done, but I'm still seeing issues in GTMetrix. See: https://goo.gl/KwxcSy
Gary

  • Kasia Swiderska

    Hello Gary,

    When you see this message:

    "Browser Caching is not working properly:
    - Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
    - Another plugin may be interfering with the configuration
    If re-checking and restarting does not resolve, please check with your host or open a support ticket with us."

    the first step is to contact your hosting provider and ask if module mod_expires for Apache, (ngx_http_headers_module for NGINX) is enabled on your server. If not, then ask to enable it.

    Plus, I ran a test in GTMetrix.com and it's showing me that numerous images don't appear to be optimized or set properly.

    The message you are getting in GTMetrix is Serve scaled images: The following images are resized in HTML or CSS.
    It doesn't mean that images are not optimized, but that big size images are placed in a smaller container and they are shrunk with HTML or CSS to fit those containers

    Smush can't fix that (yet), but it has an option that will show you those images Detect and show incorrectly sized images

    To change that, you will need to place smaller images in those elements on your site.

    kind regards,
    Kasia

  • Patrick Freitas

    Hi Gary M. Gordon

    How are you today?

    If you enabled the mod_expires and added the codes on the .htaccess files, and it still warning the JavaScript and CSS, is possible that the server uses the NGINX as to handle those files and Apache the PHP and HTML, so you need to insert the directives on the NGINX config file too.

    1- Copy the generated code into your nginx.conf usually located at /etc/nginx/nginx.conf or /usr/local/nginx/conf/nginx.conf
    2- Add the code above to the http or inside server section in the file.
    3- Reload NGINX.

    The NGIX directives can be found on the plugin > Gzip > Server type > NGINX

    If you don't have access to this file, please, contact the hosting provider.

    Also, I thought I saw a place in Hummingbird to tell it to use your CDN for CSS, etc. script files. But I can't find this again. Can you tell me where it is?

    This feature is enabled on the Assets Optimization:

    ALSO IMPORTANT: You said I should create a ticket. But I thought that this was a ticket. No? Please explain how to create a ticket if it is different from this?

    Please, note, my teammate didn't say to create a ticket, she pasted the message that the plugin shows when the mod_expire is not enabled :wink:

    This message shows up:

    "Browser Caching is not working properly:
    - Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
    - Another plugin may be interfering with the configuration
    If re-checking and restarting does not resolve, please check with your host or open a support ticket with us."

    However, we do try to keep the threads separated by subjects, this can also help other members with the same issue, and working one issue per ticket, can make the fix faster :slight_smile:

    Let us know if you have any question on this.
    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.