[Hummingbird] Unable to clear cache in Hummingbird

Changes to the site aren't rendering in browsers e.g., Firefox, Opera, Chrome or Explorer even when their caches have been cleared and the site upon upload is refreshed so I'm unable to view changes immediately after making updates to the site. I've tried to clear Hummingbird's cache to see if that is where the issue lies, but there doesn't appear to be an option to allow this option. Can you provide assistance please. The web page in question is http://bcrft.com/privacy-policy

  • James Morris
    • WordPress Enthusiast

    Hello Kimberly Cohen

    I've checked your site and it appears that you do not have the Page Caching module enabled in Hummingbird. This is why you won't see the option in the Admin toolbar (top of the page) to clear the cache.

    I also see that you have WP Super Cache installed and enabled. Hummingbird and WP Super Cache cannot be run at the same time on your site. They conflict with each other. They both perform the same functions and therefore should never be used together.

    Finally, when I checked the HTTP Header responses for your site, I found the following:

    Server: Sucuri/Cloudproxy

    This indicates that you are using the Sucuri CDN service and it is performing caching on your behalf, which would explain what you're seeing.

    Please refer to the following Sucuri docs on how to manage caching with their service:

    https://kb.sucuri.net/firewall/Performance/caching-options
    https://kb.sucuri.net/firewall/Performance/clearing-cache

    Please refer to the following Docs on Hummingbird in order to get the most out of our plugin:

    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/

    Let us know if you have any further questions. We'll be more than happy to help! :slight_smile:

    Best regards,

    James Morris

  • Kimberly Cohen
    • The Incredible Code Injector

    Hi James,
    Thank you so very much for reviewing the situation and walking me through what's happening and what can be done about it. I'm a bit red faced, because I thought I'd enabled the Hummingbird cache feature, but hadn't and most likely I didn't because I would have received an error message advising that Hummingbird and WP Super Cache weren't compatible. But if memory serves, I believe I may have also received a message that stated that the WP Super Cache issue had been resolved.

    In any case, I've visited the Sucuri pages and have cleared the cache for which you provided me links and was able to clear the site's cache. Quick question for you...since Sucuri is continuously caching the pages, is it your recommendation that I deactivate the WP Super Cache plug-in and also not use the Hummingbird cache feature?

    I look forward to hearing from you soon.

    Sincerely,
    Kimberly

  • James Morris
    • WordPress Enthusiast

    Hello Kimberly Cohen

    since Sucuri is continuously caching the pages, is it your recommendation that I deactivate the WP Super Cache plug-in and also not use the Hummingbird cache feature?

    I don't see any conflict potential between running 1 on-site and 1 off-site caching solution since Hummingbird supports Cloudflare, which is similar to Sucuri's service. However, I would choose 1 on-site plugin and delete the other. Of course, since Hummingbird offers more and is our product, you can imagine what I recommend. :wink:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.