Hummingbird Update Caused 500 Internal Server Error on Admin

After updating hummingbird this morning we noticed a few sites that have both Smart Crawl and Hummingbird active are showing 500 internal server errors on admin when both plugins are active. Disabling one will fix the problem.

This isn't exclusive to all site, for example on our multisite network some sites are okay when going to wp-admin and others show a 500 error. Frontend of all sites are okay.

Disabling either Hummingbird or SmartCrawl fixes issue.

Any help will be great, for now Hummingbird has to be disabled which is a shame.

  • Vaughan

    Hi Lakewood,

    Hope you're well?

    This sounds possibly related to server resources.

    But could you check your servers error logs, you should be able to find them in your servers CPanel, or look for an error-log file in your /wp-admin folder, this might shed some light on the cause of the error.

    Could you grant support access from the dashboard plugin so we can take a closer look? See https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Thanks

    • Lakewood

      I'll pull the logs up and take a look. Unlikely to be resources on this server and also experienced on a few sites on different servers.

      Found this:

      [11-Jan-2017 21:22:52 UTC] WordPress database error Unknown table 'lakewood-wp-oEKoGGE9.lm_5_minification_chart' for query DROP TABLE lm_5_minification_chart made by require_once('wp-admin/admin.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('plugins_loaded'), WP_Hook->do_action, WP_Hook->apply_filters, wp_hummingbird, WP_Hummingbird::get_instance, WP_Hummingbird->__construct, WP_Hummingbird_Installer::maybe_upgrade_blog, WP_Hummingbird_Installer::upgrade_1_4
      [11-Jan-2017 21:22:52 UTC] PHP Warning:  implode(): Invalid arguments passed in ***/lakewood/public/wp-content/plugins/wp-hummingbird/core/modules/minify/class-minify-group.php on line 692
      [11-Jan-2017 21:22:52 UTC] PHP Warning:  implode(): Invalid arguments passed in ***/lakewood/public/wp-content/plugins/wp-hummingbird/core/modules/minify/class-minify-group.php on line 695
      [11-Jan-2017 21:22:52 UTC] PHP Fatal error:  Uncaught Error: Call to a member function get_page_permastruct() on null in ***/lakewood/public/wp-includes/link-template.php:357
      Stack trace:
      #0 ***/lakewood/public/wp-includes/link-template.php(320): _get_page_link(Object(WP_Post), false, false)
      #1 ***/lakewood/public/wp-includes/link-template.php(144): get_page_link(Object(WP_Post), false, false)
      #2 ***/lakewood/public/wp-content/plugins/wpmu-dev-seo/wds-files/wds-sitemaps/wds-sitemaps.php(345): get_permalink(Object(WP_Post))
      #3 ***/lakewood/public/wp-content/plugins/wpmu-dev-seo/wds-files/wds-sitemaps/wds-sitemaps.php(235): WDS_XML_Sitemap->_load_post_items()
      #4 ***/lakewood/public/wp-content/plugins/wpmu-dev-seo/wds-files/wds-sitemaps/wds-sitemaps.php(44): WDS_XML_Sitemap->_load_all_items()
      #5 ***/lakewood/public/wp-content/plugins/wpmu-dev-seo/wds-files/wds-sitemaps/wds-sitemaps.php(33):  in ***/lakewood/public/wp-includes/link-template.php on line 357
  • Vaughan

    Hi Guys,

    This was a hard bug to figure as many staff & the dev couldn't replicate it ourselves, but then 1 of our staff ended up with the same problem so the developer could look into it on the staffs server.

    We have released a fix for this earlier, so if you can update to the new release 1.4.1, that should fix these issues for you.

    Do let us know if you have any further issues.

    Hope this helps and apologies for the inconvenience this caused.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.