Hummingbird uptime monitoring error

When I try to enable uptime monitoring it gives me this error:

“Your domain does not appear to be publicly accessible on the Internet.”

What I found debugging on my own:

– The site is ‘publicly available on the internet’ (or at least you can type it in a browser and it shows up)

– Under WordPress General Settings, the site IS allowing access to search engines (not hiding)

– Is Hummingbird having trouble because it is a multisite installation?

  • Adam Czajczyk
    • Support Gorilla

    Hello Matthew,

    I hope you’re well today and thank you for your question!

    I’ve checked your site and it is available from outside however it seems there’s the nginx 301 redirect (“301 Moved Permanently”:wink: from http:// to https:// and it looks like Uptime is not able to follow it for some reason.

    I’ve asked Hummingbird developers for help here. Please keep an eye on this thread and I’ll update it as soon as I get a response.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Matthew!

    I just got a word from our devs and it seems that the solution may be pretty simple here. When I was testing your site trying to fetch it with PHP level cURL tool (similar to the way the Uptime service would) I noticed that if I don’t use protocol prefix (“https://”:wink: or use “http://” your server responds with aforementioned “301 Moved Permanently” error and doesn’t server the site. However, browser loads the page and Pingdom tools indicate that there’s a server-level redirect from “HTTP” to “HTTPS”.

    This means that you’re forcing HTTPS on the URL so your site should be also setup to go over HTTPS. That said, please got to your dashboard’s

    “Settings -> General” page

    and make sure that both “WordPress Address (URL)” and “Site Address (URL)” are also starting with “https://”. The site should work as it did but hopefully this should also fix the issue.

    Let me know please if it helped!

    Best regards,

    Adam

  • Maria
    • New Recruit

    I am having the exact same problem, and both “WordPress Address (URL)” and “Site Address (URL)” are also starting with “https://

    I have in my hub many other websites on the same server and no problems there.

    Please help

    thanks

  • Adam Czajczyk
    • Support Gorilla

    Hi Maria

    I hope you’re fine today!

    Since the solution from this ticket didn’t help, we’ll need to take a closer look at the site. Could you please start a separate ticket of your own about the issue? Make also sure, please that there’s support access to the site open so we could access it and check.

    In order to enable support access, go to the “WPMU DEV -> Support” page in your site’s back-end and click on “Grant support access” button there.

    To create your ticket, please go here:

    https://premium.wpmudev.org/hub/support/#get-support

    and select “Technical support”.

    We’ll then check your site and look for the way to fix the problem for you.

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.