[Hummingbird] Using Hummingbird Destroys my SSL

I have tried to configure this plugin on this site and several others but every time I do my SSL on the front end of the site breaks - throwing the warning site has mixed content. Trouble is, I have tried mixed content fixers in conjunction with Hummingbird but the bottom line is no matter what, I cannot have Hummingbird activated and have SSL. Any suggestions on how (if any) I can resolve this issue?

  • Adam Czajczyk

    Hello Kiley

    I hope you're well today and thank you for your question!

    I'm not sure how your sites are configured for SSL but on my end I can see that they are registered in The Hub (at least the one that you assigned to this post) as non-SSL - with http:// prefix. That suggests that the WP is not fully configured for SSL, usually that either "WordPress Address (URL)" or "Site Address (URL)" (or both) are not set to start with https:// protocol.

    Please make sure about it on "Settings -> General" page and if there's no https:// protocol prefix for both these options, adjust them, then clear HB cache (on "Hummingbird -> Dashboard" page as this will clear entire cache, including Asset Optimization's one). You might also need to re-check files on Asset Optimization to re-create them.

    If this aspect of configuration is the case, that should solve this as Hummingbird (and many other plugins) follow protocol defined in your WP settings.

    If that doesn't help or is not the case, try switching off WPMU DEV CDN in "Hummingbird -> Asset Optimization" settings.

    If that doesn't help either, I'd like to take a closer look so in such case please enable support access to the site for me by going to the "WPMU DEV -> Support" page in your site's back-end and clicking on "Grant support access" button there, then let me know here.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.