[Hummingbird] Website running slower since adding WPMU DEV

Hi there,

Newbie here, not sure if I'm set up correctly so thought best to ask. I've just gone pro and added Hummingbird to my site after previously using W3 Total Cache and Autoptimize (thought I'd test it out before rolling it out across my other sites).

Prior to the switch I was hitting:

2.249s

PageSpeed Grade
A (96%)

YSlow Grade
B (89%)

Now I'm getting (with Autoptimize still installed):

2.224s

PageSpeed Grade
C (78%)

YSlow Grade
C (77%)

Obviously I don't want to get hung up on the grades but ideally I'd like to hit the grades that I know I can achieve. Keen to learn my way around it but from what I can see so far I have done what I'm supposed to.

Things that jump out at me that are bad grades - Enable Compression F (0%). On my Hummingbird dashboard it says that this can be improved (currently at 60%) but when I go through to improve it it says "GZip compression is currently active. Good job!". Stumped on this one.

I'm also getting "Use a Content Delivery Network(CDN) - F (0%)" and "Make fewer HTTP Requests - F (0%)". In my asset optimisation it says - "WPMU DEV CDN is active" again I'm stumped. Hummingbird side is showing "Remove render blocking resources" - 69% - "Your page has 11 blocking script resources and 13 blocking CSS resources. This causes a delay in rendering your page." but fixing this is a little out of my league (I am a designer/front end guy).

Apologies for the long read but any help would be greatly appreciated. Thinking WPMU DEV will be a great asset across my sites so just want to get the best possible results. Keen to hear everyones thoughts.

Thanks so much,

Zak

  • Patrick Freitas
    • Staff

    Hi Zak

    Sorry to hear that you are having this problem, wouldn't please grant the support access and I can have a closer look.

    1. Log in to the WordPress Admin Panel for your site (go to the Network Admin dashboard if on Multisite), and then navigate to the “Support” page from the WPMU DEV menu item (WPMU DEV > Support).
    2. Click the “Grant Support Access” button in the Support Access panel.

    You can follow this chapter to know more about support access:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Let me know when support is granted.
    Best Regards,
    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi Zak

    Thank you for the support access, I re-check the Gzip and after this there was a warning that HML wasn't enable, so I enabled and re-check and now is fine.

    About CDN .JS and .CSS:
    Note that it can be very hard to get a perfect score for this rule. Some plugins and themes due to their design may not be able to handle their scripts deferred to the footer without breaking, so will have to be left in their original position. And often combining and minifying all CSS files will not completely remove their impact on your score. Just try multiple combinations to improve this score as much as possible.

    I can't see how the JS is configured on the functions.php but aways try to move the scripts as jQuery to footer.

    The WordPress documentation is:
    https://developer.wordpress.org/reference/functions/wp_enqueue_script/

    However you can use the Asset Optimisation to try to move the scripts to footer and create a inline for CSS and JS.

    But you can also check the report using Gtmetrix website, It shows that all css and js are fine, and you can see that almost all CDN warning is for .jpg and .png file.
    https://gtmetrix.com/reports/www.zaksingle.com/Sc7VGB7Z

    For this you can use Amazon, this is a nice article to read about:
    https://premium.wpmudev.org/blog/moving-wordpress-media-to-amazon-s3/

    The Hummingbird pro create the cache as the site is being accessed and will cache more pages and post as the page/post is loaded on front end.

    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.