[Hummingbird] wphb-critical not moved to footer - 0kb file ruins pagespeed 100 to 89

wphb-critical-css 0.0KB — critical.css - set to moved to footer. the new green round thing states it's been compressed. Cache cleared in hummingbird, cleared via cloudflare seperartely (just in case, even though humminbbird is connected to cloudflare) - still the call to this 0 byte file is in the head, ruining the 100 pagespeed score.
since the update erased the info I had in the critical box under tools - I just inlined it manually by editing the theme - please make an option to get rid of this buggy feature - just a check box to check to make it die.
thanks
Steve

  • James Morris

    Hello djsteve

    I hope you are well today.

    If you're wanting to exclude a file from being rendered on the front of your site, you can use the Exclude File toggle at the far right of the item row. The purpose of this is to give you the power to remove assets from the HTML rendering that are not necessary. See screenshot: https://i.imgur.com/iLjNeRI.png

    For more information on how to get the most out of Hummingbird's asset optimization, please see the docs at https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/

    Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

  • djsteve

    Thanks for the info.
    So I click the toggle to turn it off, click "clear cache" - and it refreshes the page, turning it back on.
    I turn the toggle off again, then click the hummingbid pro> dashboard - then return to the hummingpro-asset optmization screen - and it has turned itself back on again.

    So this setting... is buggy as all can be - or maybe it's my firefox browser or firewall preventing ajax for some reason, not sure at this moment.

    also the default for a plugin that is supposed to help with pagespeed and load time should not by default create an empty file that is inserted above the fold to slow down things imho.

    another issue, running the googe pagespeed shows that this resource is render blocking :https://camsyrup.com/wp-content/uploads/2018/05/01c7ec7d52fcd67d7404315c018cad8b.css

    which is full of css text.. but when I click on hummingpro -asssetoptimzation - tools - the file that is there is basically blank, (/* XXXX-1527627478-au */ ) and has been for at least 12 hours I think.. and I have clicked the clear cache buttons a lot, so I also wonder why googlebot is starting to show css in that resource when hummingbird backend shows it empty.

    maybe I am missing something else too, I will read the docs you posted.

    This whole pagespeed thing is extremely frustrating,
    for reference Version 1.9.0

    Steve

  • djsteve

    So I had to go in and deactivate page caching module - as it simply would not clear the cache any other way.

    Would be nice for someone to say they have seen this issue.

    It can be reproduced via screen shots I've made if you need.

    I've also deactivated the asset optimizing module, as it was causing serious issues. I would bet they will re-appear if you guys want to turn it back on. I have screen shots and such of these issues if you need also.

    At this moment, since I have done all the optimizing things manually, I'm not even sure I need to keep hummingbird activated, I don't think it's doing anything other than telling me some of the manually added settings are working such as browser caching. In it's current state is it doing anything to optimize the site or is it just slowing it down by having another plugin activated?

  • James Morris

    Hello djsteve

    This whole pagespeed thing is extremely frustrating

    I couldn't agree more. :wink:

    Please keep in mind that, when running Cloudflare, you're adding another layer of optimization, caching and compression. For example, if you have the CSS, JS minification options enabled in Cloudflare, this does the same basic thing as Hummingbird's asset optimization. They actually will conflict with each other.

    When I use Hummingbird in conjunction with Cloudflare, I only use Cloudflare for DNS caching and DDOS protection. Everything else gets handled in Hummingbird.

    If you would like, I'd be more than happy to take a look at your configuration and see if there's anything there that I can help clarify. If you would like that, please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - WordPress Admin login:
    Admin username
    Admin password
    Login url

    - Cloudflare Control Panel Login
    Admin username
    Admin password

    Best regards,

    James Morris

  • djsteve

    I appreciate the offer to look deeper into possible conflicts with cloudflare, perhaps we can go there. At this time you should be able to login to our wordpress and turn on and off config options right?

    you may be able to turn on the hummingbird caching and then the hummingbird asset optimiazation modules and perhaps see most of the issues I posted about, which have got to be bugs. I'm not sure if it will do all the things it was before, like inserting the whole style.css into inline and then adding a call to wphbcritical.css to the header even when turned off, but it might - and if it does, there is definitely a problem with hummingbird, regardless if there is an issue with cloudlfare or the assumed ability of hbird clearing any caches properly.

    Ihave had enough bad experiences to know that sometimes one needs to go into cloudflare and "purge everything" and enable "development mode" - and sometimes even need to clear firefox but opening history and forget site.. but these issues I am pretty sure are aside from the glaring problems that have been caused by hbird with the most recent update.

    I can try to recreate and make a video of the screens it takes to get to these issues if it would be helpful. My concern is that I am using hbird on multiple sites, and most of those have not updated to the latest version - I'd like to get this thing working better - and if the issues can not be seen and officially noted, then it would be in my current best interest to simply remove the hbird from the other sites and move over to something with less bugs or manually add the compression and such that is needed.

    This plugin could be really great with a few more addins, but not handling the basics well makes the cure worse than the disease currently.

  • djsteve

    okay I re-enabled support access for a couple sites..
    I just had the same kind of thing happen with camsalt - after the update to 1.9 - clicking the clear cache button would not work.

    Of course it's not so easy to see this if you are logged in, as it only shows the caches to non logged in users I think. I could or your could see a similar experiment with the other site I opened for support access with tipc in it... it's hbirs is still 1.8 something.. if you upgrade it to 1.9, clicking cache clear will likely not work.

  • James Morris

    Hello djsteve

    I've logged into cam*****.com and enabled the Caching module and Asset Optimization module. I changed dashicons.css, admin-bar.css, cam-style.css and admin-bar
    .js to load from the footer. I set cam-style.css to be compressed. And I disabled rendering of wphb-critical-css.css entirely. I saved and cleared all cache. Everything stayed as I configured it.

    I then ran the site through Google PageSpeed and there were no render-blocking resource issues listed and the site scored 86 / 100 on mobile and 64 / 100 on Desktop with only these minor changes.

    I also checked the source code of the rendered page, wphb-critical-css.css is not present in the source code.

    I've left everything in place so that you can confirm my work.

    From what I'm seeing, I cannot replicate the symptoms you are describing. Everything seems to be working as expected.

    I'm not sure if this is a regional cache issue but this is the first time I've accessed your sites and I'm not seeing what you're seeing, I'm afraid. :disappointed:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.