hummingbird>uptime monitoring

Hi guys,

First question here, so apologies for its simplicity (it's Sunday after all)

Got this when trying to activate hummingbird>uptime monitoring for our multisite:

Get this error:
It appears that your home_url setting is trying to redirect to another domain. This often happens when you are forcing https but haven\'t updated your site setting for that. Please verify that the home_url option of your WP install is correct, then click refresh updates in the Dashboard plugin.

Can someone point me in the right direction? Thanks in advance,
Derek

  • Adam Czajczyk

    Hello Derek,

    I hope you're well today and thank you for your question!

    The URL set in WordPress configuration must be consistent with the one that's actually used to access your site. If those don't much (and there's a redirect) Hummingbird is not able to track uptime status of the site.

    I checked the site that's assigned to this thread and it indeed is using SSL connection (https) that is forced. This means that if you put an URL (of your site) starting with "https://" in a browser's address bar you'll be immediately taken to the site but if you put an URL starting with just "http://" there'll be a redirect performed from "http://" to "https://".

    That being said, let's start with a simplest solution (that's already suggested by Hummingbird) :slight_smile:

    1. Please login to your site's dashboard and go to the "Settings -> General" page.
    2. Check the values of "WordPress Address (URL)" and "Site Address (URL)"
    3. If any of these values start with "http://" instead of "https://" correct them to start with "https://".

    Once you save this settings you'll most likely be logged out of the dashboard so you'll want to login again and then give uptime monitoring another try.

    Let me know if it worked for you, please!

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Derek,

    Thank you for your response!

    I should have noticed that you're using a Multisite install since it's listed with your account. I apologize for bringing you to confusion on this.

    In case of Multisite this goes a little bit different way and you'll want to edit site's database. To do this you'd need to access the db using phpMyAdmin (which should be available from your server's control panel such as cPanel) and then browse the "wp_options" table where "wp_" is a table prefix defined in "wp-config.php" file. Please be careful not to confuse "wp_options" table with "wp_X_options" table (where X is a number = ID of the site).

    The fields ("option_name") you'd be looking for would be "siteurl" and "home".

    Please make sure that you took a full backup of the database prior to these changes so you'd be able to restore it in case anything went wrong.

    Let me know if this helped, please!
    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.