Hummmingbird GZIP & Browser Caching not working properly

I have tried adding code for GZIP & Browser Caching manually to the htaccess file & I still get the error:
" - Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration"

I have contacted my hosting provider and they confirm that the above module is enabled.
I have the same plugins on other sites as are on this one, and do not have this problem with GZIP & browser caching.
I have enabled support access.

Thanks for the help!
Debbie

  • James Morris
    • WordPress Enthusiast

    Hello Debbie,

    I hope you are well today.

    I've just accessed your site via Support Staff Login and I see your settings are good. I tried to re-check gzip. I also tried disabling it and re-enabling it. No change.

    In order to help you better with your issue, would you please grant me access to your server and site?

    Please visit the Contact page and complete the form with the following information:

    Select "I have a different question" from the drop-down box.

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    - link back to this thread for reference
    - any other relevant urls

    Best regards,

    James Morris

  • James Morris
    • WordPress Enthusiast

    Hello Debbie,

    I've taken a thorough look at your site and ran some tests. I've found that mod_deflate is enabled and active in Apache, however, your PHP configuration is set to CGI/FastCGI. In this environment, PHP needs to have zlib.output_compression = On, but your server does not. I tried to manually override this via a php.ini file, but your hosting account does not support user php.ini files.

    This configuration setting is what is preventing Hummingbird from recognizing Gzip.

    Could you contact your hosting provider and have them add zlib.output_compression = On to your PHP configuration?

    Best regards,

    James Morris

  • Debbie
    • Webb Weaver

    Hi James Morris ,

    Thank you for the thorough investigation & testing, I appreciate it.

    I contacted my hosting provider & they explained that the way the server is set up, the changes to the .htaccess file should override the php settings. After researching, they found the solution was to deactivate all the plugins except Hummingbird, enable caching and Gzip, then reactivate the other plugins. And voila, problem solved.

    Thanks again for your help!
    Debbie

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.