Hustle bug when saving

Hi

I've encountered a bug with Hustle, if you turn on "shortcode" on the main opt-in overview screen, then later edit the opt-in, it unticks "shortcode". There is no way to keep it ticked you have to keep re-enabling it.

It seems a bit weird, shouldn't this option always be on anyway? If you don't want the shortcode you just don't need to put it on the page?

Regards
Shaun