Hustle fails to connect with mailchimp

Hi guys,

have just installed hustle and made my first opt-in, but when i try to connect the plugin to my mailchimp account (have just made a new API key to seeif that helped, but no) all I get is an errer... "Something went wrong. Please try again."

But have tried many times now and still does not want to connect. It is on a local test site for development.
I have tried to disable the headway framework (running on standard twnty sixteen) as well as disabling all other plugins, to see if that helped, but nope.
Have also tried with another MailChimp account I have, but same problem.

Please help

This is the system info I have:

### Begin System Info ###

Child Theme: designlabCPH

Multi-site: No

SITE_URL: http://designlabcph.dev
HOME_URL: http://designlabcph.dev

Headway Version: 3.8.8
WordPress Version: 4.6

PHP Version: 5.5.24
MySQL Version: 5.6.24
Web Server Info: Apache/2.4.12 (Unix) OpenSSL/1.0.1m PHP/5.5.24 mod_perl/2.0.8-dev Perl/v5.16.3
GD Support: Yes

PHP Memory Limit: 256M
PHP Post Max Size: 128M

WP_DEBUG: Disabled
SCRIPT_DEBUG: Disabled
Debug Mode: Disabled

Show On Front: page
Page On Front: 4
Page For Posts: 0

Number of Posts: ~16
Number of Pages: ~18
Number of Blocks: ~23

Snapshots: 21 snapshots taking up 1.53MB of disk space.

Responsive Grid: Enabled

Caching Allowed: Yes
Caching Enabled: Yes
Caching Plugin: No caching plugin active

SEO Plugin: No SEO plugin active

Operating System: Mac
Browser: Mozilla Firefox
Browser Version: 48.0

Full User Agent:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0

WEB FONTS IN USE:
google: Roboto

ACTIVE PLUGINS:
Hustle 1.0
https://premium.wpmudev.org/project/hustle/

WPMU DEV Dashboard 4.1.2
https://premium.wpmudev.org/project/wpmu-dev-dashboard/

### End System Info ###

    Nithin

    Hi Clairre,

    Hope you are doing good today.

    The plugin has been tested in localhost, and It seems to work fine in my localhost too, since it's a localhost it's pretty tough to debug what maybe causing this, this could be an issue with the server configuration.

    Enabling the debug mode might help in understanding the issue better, to enable it, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    You can find more details about debugging here.

    Please let us know how that goes, have a nice day.

    Kind Regards,
    Nithin

    Clairre

    Ahh... but have s*** loads of deadlines so...
    I have now installed the development site on a live testserver and now I can connect to mailChimp but my form does not get saved

    Also, I restored the site from the local server to live test on one.com using Snapshot which worked (yay!) BUT.. The Hustle Opt-in I created on the local site did not come over.
    (The rest of the site and plugins are fine it seems)

    So I tried to create it manually again on the live, but every time I hit the "Next" under display settings, it simply jumps back to the Hustle frontpage and says I have no opt-ins...

    I have granted access to the site through the support function in the WPMU Dev dashboard plugin

    Please help again?

    Rupok

    Hi Clairre, so sorry to hear the inconvenience you are having.

    Thanks for granting Support Access. I logged in and tried to regenerate the issue on your site and I could. So I'm confirming that there is some issue on your site.

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let us know the result. I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

    Clairre

    Hi Rupok

    I have already done that (both on my local server where I develop, as well as on the live test server), but for the sake of practicality, I hereby confirm that I have already deactivated all other plugins and activated the official twenty fifteen theme and the problem persists.

    I have left the officlial theme on (instead of my custom) and all other plugins deactivated for the sake of your troubleshooting - apart from the WPMU DEV dashboard and Snapshot (Which keep erroring on my one.com server too - have opened separate ticket on that one) although maybe the problems are somehow related? Maybe to the server?

    Have enabled debugging and logging in the wp-config but do not receive error logs either, which makes it really hard.
    And the support on one.com is not really helpful in this matter (and have no access to the php.ini file either, even if I knwo i have 1GB ram availabe)
    That would be a shame, as all users on one.com would not be able to use your plugins )

    Hope you can help

    Rupok

    Hi Clairre,

    Have enabled debugging and logging in the wp-config but do not receive error logs either, which makes it really hard.

    Can you please login to your server with any FTP Application, then go to "wp-content" folder? There you will see a "debug.log" file, download that file to your computer. Then open that file, copy the content inside that file, paste in a text file, and attach that text file with your reply.

    If you see no log files there, can you send me message with cPanel access credentials through our secure contact form here: https://premium.wpmudev.org/contact/ so we can try to resolve this issue by ourselves?

    Subject: "Attn: Rupok"
    - cPanel Username
    - cPanel Password
    - cPanel Login URL
    - Link back to this thread for reference
    - Any other relevant URLs

    Select "I have a different question" for your topic. This and the subject line ensure that it gets assigned to me.

    Please confirm here when you are done sending.

    Have a nice day. Cheers!
    Rupok

    Ash

    Hello Clairre

    Looks like your database table is not created for Hustle plugin. Could you please check in phpmyadmins if you have table called "wp_optins" (not wp_options), where wp_ can vary as it is the db prefix.

    The above statement is not confirmed though, but it looks like that. As when final next is clicked it returns zero where it should return the new optin ID. It returns zero when the table is not there.

    Another thing, for now, could you please keep testing on changing the site language into English?

    And last thing, the debug still not attached, we need the debug file - it's important to check. Could you please paste the debug information into http://pastebin.com and send us the link? You could replace the username in the error log to something else before sending.

    Have a good day!

    Cheers
    Ash