Hustle e-mail opt-in pop up not working

Hustle e-mail opt-in popup not working. On submit it is giving following error in the console.

jquery.js?ver=1.12.4:2 Uncaught Error: Syntax error, unrecognized expression: .inc_optin_*|FNAME|*_error
at Function.fa.error (jquery.js?ver=1.12.4:2)
at fa.tokenize (jquery.js?ver=1.12.4:2)
at fa.select (jquery.js?ver=1.12.4:2)
at Function.fa (jquery.js?ver=1.12.4:2)
at Function.a.find (jquery-migrate.min.js?ver=1.4.1:2)
at n.fn.init.find (jquery.js?ver=1.12.4:2)
at n.fn.init.a.fn.find (jquery-migrate.min.js?ver=1.4.1:2)
at a.fn.init.n.fn.init (jquery.js?ver=1.12.4:2)
at new a.fn.init (jquery-migrate.min.js?ver=1.4.1:2)
at n (jquery.js?ver=1.12.4:2)

  • Nastia

    Hello Orsi

    Welcome to WPMU DEV Community!

    Current Hustle version that is installed on your site is coming from WordPress.org. Please remove this version and install Hustle Pro from WPMU DEV > Plugins.

    Current opt-in is not working because of the field name *|FNAME|*, please replace it with first_name. The MailChimp's tags format is not accepted by the plugin. Please, repeat the same for other fields; use last_name, email fields' names.

    Let us know if you have any further questions!

    Kind regards,
    Nastia

  • Orsi

    Hi Nastia,
    Thanks a lot for your help. I changed the field name and now the registration went through, however I still have a few issues;
    -I did a test to opt in and the e-mail address didn't show up on my Mail Chimp subscribers list
    -I can't find the information I captured in the registration form anywhere, and I also haven't received any notification or anything that someone opted in. There is no sign of this anywhere.
    -Your colleague helped me earlier and fixed something, however since then the design looks different. The entry fields used to be one column but now there are 2 columns with really short entry fields.

    Could you please help?

    Thank you!

  • Orsi

    Hi Oguz,
    Thanks a lot for your help. I did a test signup with one of my email addresses and it's now showing up on my MailChimp list. I still have the issues remaining;
    -I can't find the information I captured in the registration form anywhere, and I also haven't received any notification or anything that someone opted in. There is no sign of this anywhere.
    -Your colleague helped me earlier and fixed something, however since then the design looks different. The entry fields used to be one column but now there are 2 columns with really short entry fields.

    Could you please help?

    Thank you!

  • Oguz

    Hey Orsi ,

    Hope you're well.

    For the registered user information, if you are using MailChimp integration you should check only from MailChimp. But if you enable saving locally option, you can find local savings from opt-in listing page by clicking "View Email List" button;

    There is no notification for Hustle side when someone registered for your newsletter. But there is an option for this at MailChimp side, you can check from this URL: https://kb.mailchimp.com/lists/manage-contacts/change-subscribe-and-unsubscribe-notifications

    For your design related question, it looks like structure changed. Can you try different structures from editing opt-in Structure option;

    I hope that helps!

    Cheers,
    Oguz

  • Oguz

    Hey Orsi ,

    Hope you're well.

    When I check on your site, I can see the View Email List Button;

    When no one on the list you can't see the button, but when someone registered you should see the button.

    Also when I check error logs, it says your fields are not matching with MailChimp sides. So you should check all fields and compare with MailChimp sides like Nastia told at first comment.

    Cheers,
    Oguz

  • Dimitris

    Hello there Orsi,

    hope you're doing good and don't mind me chim in here! :slight_smile:

    Error log of this opt-in indicates:

    Something went wrong, please compare your Opt-in fields with MailChimp fields and add any missing fields.

    Here's the settings I've used testing this in a local site of mine (which worked with no issues).
    In there you can see the three default fields (email, first and last name) and a additional field (city).
    Hustle -> Edit opt-in -> Content & Design

    Mailchimp -> Edit list -> Settings -> List fields and *|MERGE|* tags

    Please use the default values in both ends for 3 default fields (email, first and last name), then add any additional fields like I did in my example and you should be good. :wink:

    Let us know how that goes!
    Take care,
    Dimitris

  • Orsi

    Hi Dimitris,

    Thank you so much for your help.

    I left e-mail, first name and last name as default and added in the extra fields and now the signup worked. I can now also see the signup list in Hassle, however the new email address didn't show up on my MailChimp mailing list, and again it changed the structure of the layout. It's not a different layout from the options, still the same, just instead of all fields being under each other in one column, now they are in 2 columns. Can you please help?

    Cheers,
    Orsi

  • Dimitris

    Hello Orsi

    the new email address didn't show up on my MailChimp mailing list

    This is happening because there's a 2-step authentication that should be made from member that registers in the emailing list. I just tested that again and I got an email to confirm my subscription, you should be seeing my testing email now in your list in Mailchimp. :wink:
    Please keep in mind that forthcoming Hustle update will also provide a way to surpass that and member could be added in Mailchimp list without this second opt-in.

    it changed the structure of the layout

    That's pretty strange... I've added some rules in the Custom CSS section of this opt-in in order to surpass that and have again all form inputs in separate rows.

    form > .wpoi-element.wpoi-grouped-element > .wpoi-container { display: block; }
    form > .wpoi-element.wpoi-grouped-element > .wpoi-container > .wpoi-element.wpoi-grouped-element {
      width: 100%;
      border: 1px solid lightgray;
    }
    .wpoi-hustle .wpoi-fields-joined.wpoi-col > .wpoi-element { margin-bottom: 0 !important; }
    .wpoi-button { border-top: 1px solid lightgray; }

    Hope that was some help! :slight_smile:

    Warm regards,
    Dimitris

  • Orsi

    Hi Dimitris,

    Thank you so much for looking into this.

    It sounds very strange, I disabled the double opt-in, and I haven't received the confirmation e-mail either. I can see your e-mail on the list now, so it should be good :slight_smile:

    Thanks for adding in the custom CSS, it's only one column now, but I still have an issue, because now only the first 4 fields are shown, and the remaining 4 are gone. Can you please check?

    Cheers,
    Orsi

  • Dimitris

    Hello again Orsi!

    Thanks for adding in the custom CSS, it's only one column now, but I still have an issue, because now only the first 4 fields are shown, and the remaining 4 are gone. Can you please check?

    You were right, I was testing that only with Firefox, so I just edited custom CSS again:

    form > .wpoi-element.wpoi-grouped-element > .wpoi-container { display: block; }
    .wpoi-button { border-top: 1px solid lightgray; }
    form > .wpoi-element.wpoi-grouped-element > .wpoi-container > .wpoi-element.wpoi-grouped-element {
      width: 100%;
      border: 1px solid lightgray;
    }
    .wpoi-hustle .wpoi-fields-joined.wpoi-col > .wpoi-element {
      margin-bottom: 0 !important;
      display: table;
      width: 100%;
    }

    which performs well also in Chrome. :wink:

    Warm regards,
    Dimitris