Hustle form input labels not showing.

I'm working with a Hustle embed form and it currently shows the placeholder in the input boxes, but it doesn't display the actual input label. Is there any way to get the label and the placeholder to display?

  • viobru

    Hi, Thomas!

    Hope you’re doing great :slight_smile:

    As my teammate Luís mentioned during the chat, he has passed this to our SLS team so they can have a closer look at this. You’ll be notified by email as soon as they post on to this ticket.

    Please note that SLS response can take more time than usual staff response, so we appreciate your patience on this :slight_smile:

    Kind regards,

    Violeta

  • Adam Czajczyk

    Hello Thomas Tejeda

    I hope you're fine today!

    The Hustle by default is using placeholders. Furthermore, those placeholders are actually "label" HTML tags. The simplest way to overcome this to just add "custom labels" to fields would be to use CSS. These rules should add "Name" and "Email" labels to the fields of the form on your site (robinson....jeda.com):

    .module_id_5 .hustle-modal .hustle-modal-optin_field input[name='name'] + label:before {
    	content:'Name:';
    	color:#FFF;
    	position:absolute;
    	top:-22px;
    	left:0px;
    }
    .module_id_5 .hustle-modal .hustle-modal-optin_field input[name='email'] + label:before {
    	content:'Email:';
    	color:#FFF;
    	position:absolute;
    	top:-22px;
    	left:0px;
    }

    To apply them to the site, please add them either via "Appearance -> Customize -> Additional CSS" or via some "custom CSS" option of your theme (if there is such option).

    GIve it a try and let me know, please, if that worked for you.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.