Hustle GDPR Checkbox

I've added GDPR Checkboxes to my Hustle pop-ups, but they get duplicated in all pop-ups on my homepage, so pop-ups look weird now. On the backend, everything looks fine.
Could you help me?

  • James Morris

    Hello Alex

    I hope you are well today.

    This issue has been flagged for our SLS Team (code experts) so that they can dig into this issue further for you.

    Can you please provide the following information so our SLS Team can assist you better? Here's the information they need:

    Please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    FTP credentials
    - host
    - username
    - password
    - (and port if required)

    An update will be posted here as soon as more information is available. Thank you for your patience while we sort through this issue.

    Best regards,

    James Morris

  • Ivan

    Hi Alex !

    Thank you, it's already known issue. It will be fixed in 3.0.5 version. I fixed it on your site but note - you will lose these changes after updating the plugin. If you have the same issue on another site you can:
    1. open {wordpress_folder}/wp-content/plugins/hustle/views/general/modals/optin-true.php file via FTP and replace this code (approximately line 268)

    <div class="hustle-gdpr-box">
    	<label for="hustle-modal-gdpr" class="hustle-gdpr-checkbox">
    		<input type="checkbox" id="hustle-modal-gdpr" class="hustle-modal-gdpr">
    		<span aria-hidden="true"></span>
    	</label>
    	<div for="hustle-modal-gdpr" class="hustle-gdpr-content">{{{content.gdpr_message}}}</div>
    </div>

    to this one

    <div class="hustle-gdpr-box">
    	<label for="hustle-modal-gdpr-{{{module_id}}}" class="hustle-gdpr-checkbox">
    		<input type="checkbox" id="hustle-modal-gdpr-{{{module_id}}}" class="hustle-modal-gdpr">
    		<span aria-hidden="true"></span>
    	</label>
    	<div for="hustle-modal-gdpr-{{{module_id}}}" class="hustle-gdpr-content">{{{content.gdpr_message}}}</div>
    </div>

    2. Open {wordpress_folder}/wp-content/plugins/hustle/views/general/modals/optin-false.php file via FTP and replace this code (approximately line 93)

    <div class="hustle-gdpr-box">
    	<label for="hustle-modal-gdpr" class="hustle-gdpr-checkbox">
    		<input type="checkbox" id="hustle-modal-gdpr" class="hustle-modal-gdpr">
    		<span aria-hidden="true"></span>
    	</label>
    	<div for="hustle-modal-gdpr" class="hustle-gdpr-content">{{{content.gdpr_message}}}</div>
    </div>

    to this one

    <div class="hustle-gdpr-box">
    	<label for="hustle-modal-gdpr-{{{module_id}}}" class="hustle-gdpr-checkbox">
    		<input type="checkbox" id="hustle-modal-gdpr-{{{module_id}}}" class="hustle-modal-gdpr">
    		<span aria-hidden="true"></span>
    	</label>
    	<div for="hustle-modal-gdpr-{{{module_id}}}" class="hustle-gdpr-content">{{{content.gdpr_message}}}</div>
    </div>

    3. Open {wordpress_folder}/wp-content/plugins/hustle/assets/css/front.min.css file and replace each
    .hustle-gdpr-checkbox span
    to this one
    .hustle-gdpr-checkbox span[aria-hidden=true]
    (two or three times in this file)
    Don't forget to clear browser cache.

    Best,
    Ivan.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.