[Hustle] Hustle 3.0.6.1 PHP Fatal error in TheLib3_Wrap

Hi,

unfortunately, the Hustle periodically causes the white screen of death on my multisite.

Right now – in version 3.0.6.1 – it cries with following stack-trace

PHP Fatal error: Uncaught Error: Call to undefined method TheLib3_Wrap::get_version() in /var/www/html/wp-content/plugins/hustle/lib/wpmu-lib/inc/class-thelib-ui.php:342

Stack trace:

#0 /var/www/html/wp-includes/class-wp-hook.php(286): TheLib_Ui->_enqueue_style_callback('post.php':wink:

#1 /var/www/html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)

#2 /var/www/html/wp-includes/plugin.php(453): WP_Hook->do_action(Array)

#3 /var/www/html/wp-admin/admin-header.php(97): do_action('admin_enqueue_s…', 'post.php':wink:

#4 /var/www/html/wp-admin/edit-form-advanced.php(483): require_once('/var/www/html/w…':wink:

#5 /var/www/html/wp-admin/post.php(174): include('/var/www/html/w…':wink:

#6 {main}

thrown in /var/www/html/wp-content/plugins/hustle/lib/wpmu-lib/inc/class-thelib-ui.php on line 342

  • Patrick Freitas
    • Staff

    Hi Frantisek

    Sorry to hear that you are having this problem.

    If the plugin keeps failing on the website, it is possible that another plugin is conflicting with Hustle. Wouldn’t you mind, please, run a plugin conflict test?

    Remember, is essential that you run this test in a staging site, if you can’t do it you must create a full backup.

    Please deactivate all plug-ins keep the reported one, and check if the problem is gone. If so, then enable all plugins one by one and find which one is creating the issue.

    If you still having this issue, could you do a theme test, much the same as the plugin test, but now you’re testing themes!

    Activate one of the default WordPress themes, like Twenty Sixteen or Twenty Seventeen.

    Here you will find more information on https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Let me know the results that you get,

    Best Regards,

    Patrick Freitas

  • Rupok
    • Support Ninja

    Hi Frantisek,

    I’m so sorry to hear the inconvenience. I enabled both Hustle Pro latest version and Google Maps Pro latest version on my multisite but I could not replicate the issue. I’m not getting any Fatal Error while both plugins are activated. Are there any specific steps for replicating the issue? If yes, can you please provide us the exact steps to replicate this? We will then test that and report to our developers if necessary.

    I’m looking forward to hearing from you and resolving this issue as soon as possible.

    Regards,

    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.