[Hustle] Hustle Pro Plugin Pop Up not working

The popup for Hustle Pro is not working correctly. When the user submits the information in the popup they receive an error message stating "Something went wrong, please try again"

It seems like this error has been going on since January this year, but I didnt notice it until now.

Can you please investigate and see what could be wrong?

Best Regards

Aimi Hioki

  • Kasia Swiderska

    Hello Aimi,

    I'm sorry that Hustle is not working correctly on your site.

    We have similar reports with this error when it was caused by another form on the same page with the same IDs for form fields - but I have checked source of your site and there is no other forms there with similar construction like Hustle form.

    This error can be also result of plugin/theme conflict - if this is possible please try to run plugin/theme conflict test. You can check standard debugging guide on the flowchart here https://premium.wpmudev.org/docs/getting-started/getting-support/, click on "troubleshooting flowchart" .
    Please make sure you have backup of your site before doing any changes - best option would be to run this on the staging site if you have available one.

    If there will be no positive results of the test can you grant support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please respond in this ticket once access is granted.

    kind regards,
    Kasia

  • Adam Czajczyk

    Hello Aimi

    I have checked your site and when a user tries to submit the form, a "500 Internal Server Error" is returned by an ajax call.

    The "500" error is one of the most "undefined" errors and it may be caused by very different reasons but most often it's related either to resource limits (which, in case of WP, is usually just a WP memory limit) or to some conflicts - which Kasia already mentioned in her response.

    That being said, let's try some tweaks/tests. Please apply them "one by one" as listed below (if one doesn't work, do not "revert" it, just add-up the next one), checking the site for the issue after each one:

    1. Access your WP install via FTP or cPanel "File Manager" and edit its "wp-config.php" file, adding this right above the "/* That's all, stop editing! */" line:

    define( 'WP_MEMORY_LIMIT', '256M');

    2. Go to "Network Admin -> Performance" page and at the end of it you should see an option to export current W3 Total Cache settings; export them then disable all the optimization and caching options in W3 Total Cache settings (note: simply disabling the plugin will not work; plugin can be kept enabled but you must use its configuration options to disable those features);

    3. Disable Autoptimize plugin

    4. Go to "Divi -> Theme Options" on site and in General setting disable both "Minify and Combine" options.

    Let me know about results, please, and we'll then see what to do next.

    Kind regards,
    Adam

  • Aimi

    Hi Adam,

    My apologies for the late reply.

    I applied all the changes, one by one, without reverting any of the previous settings. None of the changes worked. Im still receiving the same error message on the Hustle Popup.

    I have now reverted all the changes, except define( 'WP_MEMORY_LIMIT', '256M');

    Could you take a look again and see if you can find any other solutions?

    Thank you very much.

    Best Regards

    Aimi Hioki

  • Kasia Swiderska

    Hello Aimi,

    In this case we need to enable debug.log on the site. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    If you open wp-config.php and that define statement is not there, you can add it right before this line:

    /* That's all, stop editing! Happy blogging. */

    After that please try subscribe to the form again, so the error will show (try 2-3 times, so error will be triggered for sure).
    After that debug.log in /wp-content should be generated - we will need to see it - upload it to dropbox type of service and leave here a link.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.