Hustle installed and failing

Hi, I have already installed the Hustle plugin and when I try to access to the dashboard or any other site in the wordpress menu I get an HTTP 500 error,

Any advice?
Thanks

  • Predrag Dubajic

    Hi DMO Global Media,

    Sorry to hear you're having issues with Hustle plugin

    500 error usually means that there's fatal error going on somewhere.

    Can you enable debug log in your wp-config.php by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Try to visit dashboard again this should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    Also, could you tell me which PHP version you're using and if you're on 5.2 or older try updating to at least 5.3 and see if it works after that.

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello DMO Global Media!

    my wordpress start failing when I setup WP_DEBUG to true. I think it should be something related to my hosting.

    Did you add lines that enable debugging or they were already there and you just changed "false" to "true"? I'm asking because that issue is often sing that there's an error in wp-config.php file, for example:

    - there's an empty line at the beginning of the file above this php opening tag

    <?php

    - the define() lines are located below the "/* That's all, stop editing...*/" lines

    Could you double check your "wp-config.php" file against these, please?

    I think there is a problem betwee Avada and the plugin. Have you be noticed about any similar issue?

    I didn't find any reports in our internal system related to Hustle + Asana "combo" but there's always a chance that it'd be either something new or something that reveals itself only in specific configuration/environment. The simplest test for this would be to try to switch to Twenty Sixteen or Twenty Seventeen theme temporarily. It would be great if you could perform such test and see if the issue is gone then.

    Before doing that however, please also make sure that your WordPress memory is not limited too much. To do this, please go to the "WPMU DEV -> Support" page in your site's backend, click on "System info" button and switch to "WordPress" tab, then scroll it all the way down. Check the value in "WP_MEMORY_LIMIT" (do not confuse it with "WP_MAX_MEMORY_LIMIT" please) and if it's anything less than 128M, add this line to the "wp-config.php" file

    define('WP_MEMORY_LIMIT', '256M');

    Make sure that the line is located above the "/* That's all, stop editing */".

    If that doesn't help, proceed with theme test mentioned above, please.

    Let me know about results

    Best regards,
    Adam