Hustle Opt-in Appearing on Pages, Set to Do Not Show

I have set up one opt-in using Hustle. It's still in Test Mode, but it is appearing on every page, although I set it to Do Not Show on All Pages.

  • Rupok

    Hi Clyde Sebastian,

    Thanks for granting Support Access. I checked your site configuration and found the issue. This is very weird. The PopUp is firing in every situation. I tried to regenerate the issue on my test site but I could not. So this is your site specific issue.

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To get more idea about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/
    I'm not sure but I've a feeling that it could be related to your Maintenance Mode plugin. Can you please disable that for a moment and check if everything is working as they should?

    Can you also activate any default WordPress theme instead of your current theme and check if the issue is gone. If yes, then this is your theme specific issue.

    Please let us know your findings. If you can't find any plugin or theme behind this, please let us know. We will be very glad to investigate further.

    Have a nice day. Cheers!
    Rupok

  • Clyde W.

    Thank you for your detailed reply, Rupok!

    Here is what I've tried/tested and my findings:
    • With only the WPMU DEV Dashboard and Hustle plugins active (i.e. all the rest deactivated), the issue was still present.
    • With WP Maintenance Mode disabled and everything else as it was, still present.
    • Tried a different theme (Fullbase), which interestingly did not show Hustle at all!
    • I also tried disabling Popup and using After Content instead, but it yielded the same result of being present everywhere, despite display settings set to not show on all pages.
    • I don't know if it is supposed to or not, but Hustle did not show up when opening my site's About page in Upfront. As soon as I exited Upfront, there it was again.
    • I also tried changing the display setting for Hustle from All Pages to just the About page, and it still showed in the About page.
    • I found it peculiar that when the display settings for After Content and Pop Up (and I assume, but did not test Slide In as well) are set to Do not show for All pages, in the Opt-Ins list the Display Environments are show as depicted in the attached screenshot. It says it will be show in "ALL PAGES except" and then there is a space, comma, ALL POSTS. When I had it set to not show on the About page instead of All Pages, it showed "ALL PAGES except About".

    So I don't think a plugin or theme issue is at play here, unless I missed something. Please let me know if I tried everything you suggested in your last reply.

    Otherwise, yes—I would greatly appreciate you investigating further!

    Thank you so much!
    Clyde Sebastian

  • Ash

    Hello Clyde Sebastian

    I am sorry for the confusion, I can replicate the following that you mentioned:
    1. When you select "Except all pages", it's still showing
    2. When you select "Only in X page", it's still showing in all pages
    Looks like it's ignoring the page rules.

    I am marking this as a bug and reporting to the developer. I hope very soon the developer will fix this issue. We really appreciate your patience on this.

    I don't know if it is supposed to or not, but Hustle did not show up when opening my site's About page in Upfront. As soon as I exited Upfront, there it was again.

    You mean in upfront editor? If so, then this is default behavior. Are you using slide or pop or after content? Though if you use widget, it should still show.

    Have a good day!

    Cheers
    Ash

  • Clyde W.

    Great, thank you Ash! Is there a workaround I can use in the mean time? Or another opt-in plugin you would recommend (from WPMU DEV or elsewhere)?

    You mean in upfront editor? If so, then this is default behavior. Are you using slide or pop or after content? Though if you use widget, it should still show.

    Yes, Upfront editor. I thought it might be default behavior, but figured I'd ask nonetheless. And yes, with the widget it still shows. Thank you for the clarification!

    Please just let me know about my opt-in options.

    Regards,
    Clyde

  • Ash

    Hi clyde

    I am afraid, there is no quick workaround for this bug, the developer will take a look asap - I hope. You can try to use shortcode inside content for now.

    As an alternative, you can try our Popover and Slide In plugin, though Hustle is more user friendly and a combination of both plugins. Also, in popover and slide in, it's little bit complex to configure with mailchimp, aweber etc :slight_frown:

    We really appreciate your patience on this.

    Have a good day!

    Cheers
    Ash

  • Rupok

    Hi Clyde Sebastian,

    Thanks for confirming. I'm forwarding this to our developer. Either we or our developer will respond to this thread as soon as we have any workaround for this.

    Please keep in mind, our developers work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and provide a workaround.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.