Hustle Opt-in creation not working

After installing Hustle I am attempting to create my first opt-in. As soon as I load the Add New Opt-in page I get a javascript error in the console as follows:

mailchimp.js:120 Uncaught TypeError: Optin.step.services.provider_args.isEmpty is not a function

at Object.c (mailchimp.js:120)

at f (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578)

at Object.trigger (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578)

at s.render_preview (design-tab.js:193)

at s.render (design-tab.js:95)

at s.initialize (design-tab.js:79)

at s.e.View (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578)

at new s (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578)

at s (router.js:22)

at s.execute (router.js:57)

c @ mailchimp.js:120

f @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578

trigger @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578

render_preview @ design-tab.js:193

render @ design-tab.js:95

initialize @ design-tab.js:79

e.View @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578

s @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578

s @ router.js:22

execute @ router.js:57

(anonymous) @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578

(anonymous) @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578

j.some.j.any @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:575

loadUrl @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578

start @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,thickb…:578

(anonymous) @ router.js:101

This is before I attempt to fill in any fields but when I have populated the necessary fields and added my Mailchimp API clicking the next button does nothing. Nor is it possible to click select media for the Opt-in image.

I have tried disabling all plugins but the problem persists

Any ideas?