Hustle popup always shows

The pop up is working correctly, however it is not following one of the Display Conditions I have set. I have set it to only show to each user once, but it keeps showing up when I test it out on different pages.

To test just click around to different pages. I believe I have it set up so that each user should only see the pop up once during a 14 day interval. It is showing up on every page after the user scrolls down, which can be extremely frustrating from a user point of view. I just want to make sure people aren't leaving our site because the pop up shows up too many times.

Support access is active for five days.

  • Foundry

    Hey Tyler,

    Thanks for the response! I went and enabled tracking, but the pop up is still not following all of the Opt-In Display Conditions I have set. It is still showing the pop up more than one time, even though I have it set to only show once. Along with that, the pop up is showing up on a specific URL that I have told it not to show on. Lastly, I have set the close button to act as the 'Never see this message again' link, but it still shows when I exit out of the form.

    However, it is following the condition preventing it from showing on mobile.

    I've changed every setting I can think of and nothing is working. Let me know if you have any ideas on how we could fix this.

    Cheers,
    Luke

  • Majid

    Hey Luke,

    When activating the tracking option, make sure it's on by refreshing the page. sometimes it happens to be not saved for the first time, this will make the popup follow the conditions you set (Pop-up shown less than & Shows the Pop-up if the user is not on a certain URL.) Options, also make sure that the url for the URL condition doesn't contain 'http:// or https://'.

    However regarding the close button not acting as 'Never see again', I was actually able to replicate that on my site as well, so it has been reported to the developer as a bug. and it will be fixed within the next update.

    If you still can't see the popup acting as the conditions, please let us know, and make sure you enable the Support Access too
    WPMU DEV > Support and click enable Support Access
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Cheers,
    Majid