Hustle Pro and Mailchimp Integration Not working

I have Mailchimp integration setup for my popup on Hustle but after making several test submissions, my lists are not getting updated.

  • Nithin
    • Support Wizard

    Hi Steve McGough ,

    I imported the mentioned form in my system and tested further to see whether I could replicate the same in my system, but it works fine without any issue.

    Could we know whether the form was working fine before in Mailchimp, and started showing issues after a while? or it didn’t work at all? It looks more like a setting is misconfigured in the MailChimp side.

    Could you please try creating a new list in MailChimp, and see whether you could still replicate the same issue with the Popup? THis would give a better idea of where to look further in order to troubleshoot the issue further.

    Looking forward to your response. Have a nice day ahead.

    Kind Regards,
    Nithin

  • Steve McGough
    • Site Builder, Child of Zeus

    Unfortunately, the client’s account only allows for one Audience (List).

    I’m not sure if it was ever working properly. It did seem to work on occasion. When testing, I would be able to create an account with a newly-created test email account. Then I would remove that address from the list and test again … did not work. Then MC said that will not work as they would have to sign up using one of their forms instead of an integrated form. Then it looks like I can’t even sign up using the same domain URL. So testing has been close to impossible.
    You have the log in info for MC. Is there a way you can look at the settings?
    Steve

  • Steve McGough
    • Site Builder, Child of Zeus

    Question – Does the Hustle Pro integration with Mailchimp allow you to apply a MC “tag” to the subscriber based on what popup or form is used? I don’t think it does, but wanted to triple check with you. If not apply a “tag” can it assign a subscriber to a “group?”

    So I created a test List (Audience) with one of my other client’s paid accounts. It did work properly. So that error we’re seeing at MC seems to be the issue…

    Account nameWebsite Popup (5d83b7e3dab987.49727134)
    InfoBad RequestSomething went wrong. {“type”:”http://developer.mailchimp.com/documentation/mailchimp/guides/error-glossary/”,”title”:”Invalid Resource”,”status”:400,”detail”:”Invalid interest ID: ‘8e33c2bfd0’.”,”instance”:”84be6209-0fdb-410a-94e1-4864762a3ef7″}
    Member statusMember could not be subscribed.
    List nameWet Noses Pet Sitting General Newsletter (1bf4aece2e)
    Special IdentifiersStandard

    I’m going to ask MC for support on this next.

  • Steve McGough
    • Site Builder, Child of Zeus

    Well, it sort of worked and might be working again. This is very difficult to troubleshoot.

    This is the information they provided… ” if you tell them that it is making a GET to the list memebers/member ID endpoint but adding a query to include the API key in the call which appears to break it”

  • Nithin
    • Support Wizard

    Hi Steve McGough ,

    In general, there aren’t any specific settings required, and the interaction should have worked out of the box. It’s odd that the issue occurs on the MC side.

    Unfortunately, the client’s account only allows for one Audience (List).

    You could delete the existing Audience list if possible, and create a new one to rule out any specific settings would be causing this in MC side.

    Question – Does the Hustle Pro integration with Mailchimp allow you to apply a MC “tag” to the subscriber based on what popup or form is used? I don’t think it does but wanted to triple check with you. If not apply a “tag” can it assign a subscriber to a “group?”

    The next release of Hustle ie version 2.0.3 would support Mailchimp Tags in Hustle. Regarding “Group”, yes, Hustle does support it, and the created groups should be listed once you select the Audience list which has groups.

    Well, it sort of worked and might be working again. This is very difficult to troubleshoot.

    This is the information they provided… ” if you tell them that it is making a GET to the list memebers/member ID endpoint but adding a query to include the API key in the call which appears to break it”

    That’s odd. So it’s working fine now? Or you still face issues regarding this? I’m passing the observations you have shared from the Mailchimp supportoo to our developers to see whether they could point out anything specific.

    If possible please do check whether deleting the existing Audience list, and creating a new one makes any difference or not.

    Please do let us know how that goes, and will keep you posted once I get further feedback from the developers asap.

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Steve McGough ,

    Sorry for the delay in getting back. Are you still facing the mentioned issue? Have you created any MailChimp interests? I got an update from the team regarding this, and the issue could also occur if you had MailChimp interest created while connecting with the MailChimp module, and then the interest was later removed.
    https://mailchimp.com/developer/reference/lists/interest-categories/interests/

    Could you please check the MailChimp settings regarding this? If you aren’t sure, and still facing the mentioned issue, then please do share the MailChimp login credentials, so that we could double-check whether that’s what’s causing it.

    You can share Login credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -username
    -password
    -login URL
    -link back to this thread for reference
    -any other relevant URLs

    Please do follow up on the ticket once you have sent the above credentials. Have a nice day.

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.