Hustle Pro pop-up not working

I have a video pop-up I created using Hustle Pro that has stopped popping up with the latest update.

The site is influence********.com and it's supposed to pop up when you click on the triangle on the home page, triggered by the class .videoclick

  • Lindeni Mahlalela

    Hello Robin

    I hope you are doing great today. I am sorry for the delayed response from our side and thank you for your patience while we were still looking into this issue.

    I have checked your website and found that the most important thing that makes the popup not show up is that it is contained in a '<section>' element whose height is not specified, the height for this element is not explicitly set but instead there is the:

    max-height: 100%

    In order to make sure the popup is shown properly with the video on it, I have set the following CSS in the page "Select Options > General" in the "Custom CSS" box:

    .hustle-modal.hustle-modal-simple .hustle-modal-body .hustle-modal-content section {
        height: 400px;
    }

    This makes sure the video container to have a defined height so that the when the popup shows up the video will be clearly visible.

    There is also an issue relating to Insecure Content on the theme, there is a lot of files being loaded insecurely and the browser is blocking them, this could be another reason why there are because when a JavaScript file is blocked the website's functionality will be impacted negatively. What confuses me is that the website is not set to use SSL but when checking it on this tool it says there is a valid certificate and lists all the files loaded insecurely but then if I turn on https on the site, the browser says the certificate was revoked.

    Have you used SSL on this site before?

    The insecure content that may potentially break functionality is caused by the active theme, I tried the same on my own test website and encountered the same errors. This can be resolved by your developer for the child theme and or the theme author for the parent theme.

    There was also some undefined JavaScript variables relating to Google Maps, this was due to Google Maps Api Key not defined/provided so I solved this by entering the Temparary API key provided by the theme on the settings page "Select Option > General > Google API", the API key is provided in the "Google Maps Api Key" section.

    For now, I have patched your website and it seems to be working as it should, I tried to replicate the same setup on my website and it works as well there. I hope it continues to work for you as well.

    Please let us know if you have any further issues and we will be happy to assist you in anyway possible.

    Have a nice day.
    Lindeni

  • Lindeni Mahlalela

    Hello Robin ,

    I hope you are great today. Thank you for the feedback and for the confirmation.

    Well, if the site does not have a valid SSl certificate then it is ok to ignore that part, I only suggested you check it because the browser reports insecure content served over an https connections, this usually means that the website is served over https but some parts of it are served over http which results in the insecure content warning, but if there is no valid certificate then you may ignore this, but in case something stops working then check the browser console for Errors and if there are error then try to resolve those first and it should work.

    Thank you so much.

    Have a nice day.
    Lindeni