Hustle Pro popup not displaying

I had a Hustle exit intent popup working on a single page but observed it was also appearing on other pages. I disabled/re-enabled, tried to use the URL (did not work at all), created a new popup, disabled cache, deactivated all plugins (and then brought back Avada plugins first before re-activating all), switched to 2019 theme to try to fix all to no avail. At the end, the exit intent popup did not display at all no matter what I did. Copying did not work, exporting/importing did not work.

So I started from scratch with a new popup and it sure enough worked on my page but now it also appears on other pages again. In fact, I can reliably get the exit intent popup to display on the first blog page I visit on every new session even though the only page it is supposed to display on is this one: https://www.hprnj.com/ahomeyoulove/

For now I have the popup off so readers will not experience the odd behavior on the blog.

  • Dimitris
    • Support Star

    Hello there Jonathan,

    hope you're doing well and thanks for reaching us!

    I tried to replicate this in a local testing site, without any caching or any other plugin activated apart from Hustle Pro and WPMUDEV Dashboard plugin and a default theme like TwentyNineteen.

    Both functionalities are working good in my tests, both assigning the popup to a single page and the exit-intent trigger.

    In fact, I can reliably get the exit intent popup to display on the first blog page I visit on every new session

    Are you maybe using the "Trigger once per session only" option, as highlighted in my screenshot below with the setting I used during tests?

    First things first, we'll need to troubleshoot the display options, so the popup is being shown in only the single selected page. Then we check the exit-intent functionality. :slight_smile:

    In order to better assist you here, could you please grant temporary support access via WPMUDEV Dashboard plugin? No need to share any WP admin credentials, just navigate in WP admin area under WPMU DEV -> Support page and click on the "grant support access" button. You can find detailed information about it here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please do reply back here when access is granted because we don't get any notifications about it.

    Thank you,

    Dimitris

  • Nastia
    • Support Rock Star

    Hello Jonathan

    Hope you are doing well!

    Thank you for granting access to your site. I've edited the pop-up and added additional conditions to make sure the Pop-up will be shown only in on page. Please see this screenshot:

    For other Posts, Projects, Category an option "Only These …" is selected. This way the pop-up is not showing up on other pages

    Please let us know if the issue is still there!

    Kind regards,

    Nastia

  • Nahid
    • Tech Support

    Hey there Jonathan !

    Hope you are doing well today!

    Thank you for your query. That is actually intended behavior. By default, Hustle Pro shows a module on every pages/posts in the site. If you wish to display it on a single page only, it is necessary to set it to not show in other locations as well.

    Hope this helps. Please let us know if you need any further assistance regarding this. Thanks!

    Kind regards,

    Nahid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.