[Hustle] Problem integrating Hustle with Mail Chimp

I've set up Hustle to collect email newsletter subscriptions. Everything appears to be working - except whenever an email address is entered, it says the user is already subscribed... even when they're not.

I've tried subscribing three times. I grabbed a screenshot of the log but there's no way to share it with you... so here's what I copied from the "Last 24 hours of API calls " in my MailChimp dashboard:

2018-06-25 17:55:49 GMT nope 192.196.156.167 GET /lists/.../interest-catego php 0.012s DrewM/MailChimp-API/3.0 (github.com/drewm/mailchimp-api) 3.0 The requested resource could not be found.

2018-06-25 17:55:49 GMT nope 192.196.156.167 GET /lists/ php 0.027s DrewM/MailChimp-API/3.0 (github.com/drewm/mailchimp-api) 3.0 n/a

2018-06-25 17:55:49 GMT nope 192.196.156.167 GET /lists/ php 0.333s DrewM/MailChimp-API/3.0 (github.com/drewm/mailchimp-api) 3.0 n/a

  • Nahid

    Hey divva !
    Hope you are having a great day!

    I'm sorry to hear about the issue that you're encountering. I tried to replicate the issue on my test site but couldn't. The MailChimp integration within Hustle seems to be working as expected.

    Moreover, I went to your site and tried subscribing to the slide-in opt-in in the homepage header, which seemed to work as expected as well. It showed me a success message. Here's a screenshot for reference:

    I also received an email regarding confirmation of the subscription. Here's another screenshot for reference:

    Are you still able to replicate the issue on your end? Am I looking into the wrong slide-in opt-in?

    We'll be looking forward to hearing back from you. Thanks!

    Kind regards,
    Nahid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.