Hustle Social Sharing doesn't work in Divi

We are using Hustle on our website but the Social Sharing is not loading in the front end. It's working with the default theme. We are using Divi.

  • Pawel
    • Staff

    Hello Linda!

    Sorry to hear about the issue you are having.

    I installed the same theme (Divi + the child theme you have on that site) on my local test site and faced the same issue. I managed to get it fixed by editing the child theme's functions.php file and changing two lines.

    Line 13:

    array( $parent_style, "hustle_front" ),

    And line 18:

    //add_action( 'wp_print_styles',     'my_deregister_styles', 100 );

    First one added back the Hustle stylesheet and the second one disabled a function that removed dashicons styles (a default WordPress stylesheet), on which Hustle depends.

    This change made both the widget and floating social sharing appear correctly.

    Unfortunately, after applying the same changes on your site, only the widget got fixed, but the floating element did not appear. I'm guessing that the caching plugins may have something to do with it. Please disable them for the time being and check if that helps. This would include any caching plugin (Performance, SG Optimizer) and also Divi Theme Settings related to minifying JS and CSS (in Divi->Theme Options).

    best regards,
    Pawel

  • Pawel
    • Staff

    Hello Linda and Nicolas!

    Linda : have you tried my suggestions? Did they work?

    nicolas : if you are having issues with Divi, we can also help with that. For this please open a separate support ticket and explain your issues there so one of our supporters can answer you or go to our LiveChat and talk directly about your issue. We will try to find a solution for you.

    best regards,
    Pawel

  • Linda
    • WPMU DEV Initiate

    Hi Pawel,

    Thank you for your feedback.

    I have tried to clear and disable everything - Autoptimize, Divi Minify, W3, SG Optimiser - it didn't help - still with all of thise disabled site shows only widget, not the floating share. So I have turned everything back on.

    Thanks

  • Pawel
    • Staff

    Hello Linda!

    Did you also clear all of the caches and forced a refresh of the page in the browser? To do this you'll have to press following keys, depending on the browser you are using:

    Hold the Ctrl key and press the F5 key.
    Hold the ? Shift key and click the Reload button on the navigation toolbar.
    Hold the Ctrl key and click the Reload button on the navigation toolbar.
    Hold the ? Shift key and press the F5 key.

    On Mac it's Command key instead of Control.

    I tested your theme on my site, and the floating widget is showing up without any issues.

    best regards,
    Pawel

  • Pawel
    • Staff

    Hello Linda!

    Thank you for your response. It's not usual that disabling caching did not help. I can't replicate the issue using the same theme you are using on my test sites. I also logged in to check again if I can make it work, but still no idea there, unless I'm able to see the site without any caching and asset minification enabled. I think the cause is hidden somewhere in there.

    Please disable all caching and asset minifications on your site so I can log in and see if I can fix this.

    kind regards,
    Pawel

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.