[Hustle] Widget not going away after opt-in

We are using a Hustle embed module widget in our sidebar. We have chosen the module to not show up anymore after opt-in. After the opt-in, the embed disappears, but the widget still stays in place. Screenshots have been attached on the ticket notes. Please advice.

  • Nastia
    • Support Rock Star

    Hello Alex

    I trust you’re doing well!

    I’ve flagged here our second level support developers so they could provide some feedback. Would you please send to us your site’s credentials?

    You can send credentials by using our secure contact form

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: “Attn: Nastia”

    – WordPress admin username

    – WordPress admin password

    – Login URL

    – FTP credentials (host/username/password)

    – Link back to this thread for reference

    – Any other relevant URLs

    Thank you! Have a good day and take care!

    Kind regards,

    Nastia

  • Rupok
    • Support Ninja

    Hi Alex,

    Can you please create a directory named “mu-plugins” inside the “wp-content” directory? Then download the attached zip file and extract. You will get a PHP file. Please upload that PHP file inside that “mu-plugins” directory.

    I believe that should resolve the issue. If not, please provide the credentials Nastia requested above. We will then investigate further and try to resolve this.

    Regards,

    Rupok

  • Alex
    • New Recruit

    I Rupok,

    thank you for your support. The issue in this case is solved, since you address exactly the regarding widget on homepage.

    I have an different widget id on the blog side and of course it is not working there, as long as I do not change or add the exact widget ids there.

    Thanks again for your work, but I will solve it differently.

    Generally I do not get the setting “no longer show this module across the site” if the only change is, to switch all content colors of the module to background color. I mean, obviously you can identify the exact module – so you can change the colours. And obviously there is actual code to hide it, as you presented to me. So why is this not combined? Adress the module and hide it instead of camouflage it?

    Regards,

    Alex

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.