[Hustle] Will older Hustle version (2.1.5.1) be compatible with PHP 7.2

I know its an old version, but we haven't managed to migrate the popups to a never version. So we are keeping this as long as it goes. But will it die on PHP 7.2 or has it been compatible for longer than this version :slight_smile:

  • Adam Czajczyk

    Hi Benjamin_Creative

    I hope you're well today!

    Yes, 2.1.5.1 is indeed quite an old version. I just installed it on a fresh WP setup on PHP 7.2.11 to check it and it should be working fine. I only created a simple popup but on the other hand 7.2 was already around when this version was released so I'd assume compatibility.

    Since nothing changes with time in already released established version of both PHP and the plugin, it should keep working. But please note that while this shouldn't change, we cannot provide future compatibility of this version with other updates like e.g. future WordPress updates or prevent and fix possible conflicts with future versions of other (especially 3rd-party) plugins.

    We do our best to maintain both PHP and WP compatibility as well as as universal compatibility with other plugins and themes as possible but that means keeping the plugin up to date. My point is: for now it should be working fine but there most likely be a time sooner or later when upgrade will become unavoidable. I hope that makes sense :slight_smile:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.