Hustle - won't save state.

Hey there,

Unfortunately I have encountered another problem, this time with Hustle.

On Chrome, I can't create an opt-in, when I get to the 'Display Settings' tab and go to click next, nothing happens.

Well, not nothing... in the console there is a script loading error 520. (screenshot a attached)

This doesn't occur on firefox however, which reminded me of my other issue.

However on both Firefox and Chrome, when I get to the final screen (created opt in with firefox, tested the toggle in Chrome to see if matched firefox bug) and try to activate the Shortcode from the 'manage your opt-ins' screen, I get nothing...

Well, again not nothing... in the console of both firefox and chrome I am getting error with loading the scripts, error 500. (screenshot 1 & 2 attached)

The toggle visually toggles, but doesn't save, and the shortcode doesn't function on the page.

While I was testing it, I also noticed that all the toggles stop working after turning on and off.

I also noticed that there is a discrepancy between the jquery scripts that have been succesfully loaded and the ones that hustle is trying to load on the swtich activation. (Screenshots 3 & 4 attached)

I seem to be having no luck :slight_frown:

Best

Jeff

  • Sajid

    Hello jeff,

    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access. I checked the system information and noticed that you are set very low limit for post_max_size (16M), upload_max_filesize (8M) and also the execution time is 30 seconds. The memory limit is fine.

    Please increase these values by following this article and check if makes any difference.

    After making changes also check if these settings actually take effect and it actually increased values in WPMU DEV -> Support -> System Info -> PHP.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

  • jeff

    Hey Sajid

    I increased these via my cpanel PHP settings

    max_execution_time = 180
    post_max_size = 128M (max allowed via dropdown - perhaps can increase via php.ini or .htaccess if necessary?)
    upload_max_filesize = 128M (can be further increased to 1G if necessary?)

    The problem is persisting.

    If you could try and save the hustle opt-in settings, preferably for the shortcode for me, and confirm that you are also having this problem, that would be great.

    Thanks

    Jeff

  • Nastia

    Hello jeff , I trust you are doing well today!

    Would you please for a quick test deactivate the cache plugin and remove the WP_CACHE constant that is added to wp-config.php file?

    Once you do please try to save changes. If the changes are saved then it must be a cache that is conflicting with the Hustle plugin.

    At the current time, the Hustle plugin is not working well with when a cache is activated. Our developers are working to fix it.

    It should be fixed in the next plugin's updates.

    Let me know if you have any further questions!

    Kind regards,
    Nastia

  • jeff

    Hey Nastia,

    I saw you had been having a look inside my site and testing some adjustments.

    Unfortunately, when you made some adjustments and deactivated wp-supercache it has had a knock on effect with hummingbird and now none of my css or js are loading from the humminbird cache.

    I was actually reloading the site when the styling collapsed, I was initially a little shocked but after checking the audit and support logs, figured out what was up.

    It's midnight 1am here, I need this site looking as was before work tomorrow, can you run through what has happened please?

    Best

    Jeff

  • jeff

    Since none of the minified .js or .css were loading from the hummingbird cache. The browser was trying to load files that didn't exist, the cache folder had differently named files.

    I have disabled hummingbird (again) and things are working (again)

    Unfortunately it's a bit slow, but I need the site operational for tomorrow. I am going to use Cloudflare minification instead for now.

    I will adjust the wp-config and everything tomorrow, and report back if I get hustle up and running.

    Cheers :slight_smile:

    Jeff

  • jeff

    Hey Nastia,

    I deactivated WP-Super-Cache, and removed it's additions to my WP-Config, but the error persists.

    I have hustle running on another virtually identical (cosmetic differences) WP Install, both are running on Genesis, with
    the same plugins. Both Domains are on the same hosting.

    With the other site http://daeliens.com hustle is working without a problem.

    This is a running thread. I have 3 sites, all on the same hosting, all with the wpmudev dashboard and the same set of plugins.

    The other two sites can both run snapshot pro managed backups, hummingbird, and one of them has no problem with hustle (the other doesn't have it installed). But for some reason this specific install has a problem with both Snapshot Pro and Hustle, and had a problem with Hummingbird (on Chrome)

    The site needs to be up for the next week or two, but if we don't manage to solve these issues I may resort to the nuclear option, wiping the entire install, DBs, removing the domain and folders from my cPanel and then reinstalling step by step.

    I really hope it doesn't come to that. lol

    Backdoor is open via the hub, and actually Predrag has full access via ftp and cpanel for the other ongoing thread.

    Cheers

    Jeff

  • Sajid

    Hello jeff,

    Hope you are doing good today!

    Thanks for keeping the support staff access open and sending FTP details to support team.

    I have done troubleshooting on your website by deactivating plugins and switching to default theme from Genesis framework (restored back after testing).

    But I still got the same error message.

    Then, I enabled debugging and go the following error message:
    [19-Oct-2016 10:02:03 UTC] PHP Fatal error: Call to a member function get_error_message() on integer in ../wp-content/plugins/hustle/inc/opt-in-admin-ajax.php on line 203

    I thought, may be some plugin core files got missed while installing/updating the plugin and installed a fresh copy of Hustle plugin via WPMU DEV Dashboard plugin by moving the existing copy to /wp-content folder.

    After that, I got the following error message instead of above:
    [19-Oct-2016 10:10:23 UTC] PHP Fatal error: Class 'Opt_In_Admin_Ajax' not found in ../wp-content/plugins/hustle/inc/opt-in-admin.php on line 66

    Which is strange and should not happened. I am forwarding this information to our developer to get his invaluable feedback on this matter.

    As soon, as I heard back from the developer, I will post back a reply here.

    Take care and have a nice day!

    Best Regards,
    Sajid

  • Sajid

    Hello jeff,

    Hope you are doing good today :slight_smile:

    I heard back from the developer and he said that we have released a new version of Hustle Optin. Please upgrade to version 1.1 and then check again.

    If the problem persists, then please send us FTP and WordPress admin details directly to further troubleshoot this problem.

    You can send this detail via our secure contact form in following format.

    Subject: "Attn: Sajid Javed”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference
    - link to the downloadable snapshot zip archive.

    See screenshot attached:

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.