[Hustle] Wrong share count

Dear support team,

I've finally released my new website after migrating it.
The share count on the Hustle Social share widget is wrong.

For instance : https://blog.defi-ecologique.com/compostage-urbain/
https://i.postimg.cc/9MGXbq7k/Capture.png

As you can see, it displays 2 facebook shares.
However, I know it is more. Last time I made a stat report, there were 195 shares in total and https://www.sharedcount.com/ tells me 198 shares in facebook alone.

How may we fix this, please ?
This is more than mere vanity, these stats matter in more than one way.

Regards,
Greg

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    I checked this and even if I use directly FB API url that Hustle is using to check this, it returns 198 shares currently. That would mean that Hustle is able to get - or is getting - proper share count but for some reason those are not displayed properly.

    That might be cache on site or server or a transient cache or there's something on site that's actually blocking connection to FB from it, thus not letting it retrieve proper values.

    That said, did you try to clear all possible caches on site and server and then check the site again? If not, please try it. If it doesn't help, I"ll need to check the site and since I'm not able to access it, I'll need direct access credentials.

    I have asked for it already in your other ticket so please just confirm here as well once you send them (or include link to both this and that other ticket in the message that you'll be sending me) and I'll check both issues: this social share count issue and the slow hustle form submission from that other ticket.

    Best regards,
    Adam

  • Greg
    • Syntax Hero

    Dear Adam,

    As this website is currently being modified (even though it is public), I did not enable any cache, so far.
    Neither on the serveur, neither on HummingBird and both CDNs are disabled at the moment.

    I've sent the credentials as you requested.

    Regards,
    Greg

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    I checked the site and the social sharing is currently set on your site to "Click" option for counters. That means that regardless of how many times the given URL has really been shared, the counter will only show how many times someone on your site did click the button to share it.

    To get real readings, that should be set to "Native" in social share "Name & Services" options page in "Counters" section.

    However, it seems that there's some sort of bug related to this. I did some more tests on my own setup and it looks like it's either not reading the data properly (even though the FB API URL in plugin's code is proper) or it's just not processing that right way.

    I've reported it to our developers as a bug so they would look into it. Please note: I'm not able to give you an ETA on a fix. They'll do what it takes to handle that as soon as possible though so please keep an eye on this ticket in case we had some "patch" for you or additional information but also make sure that you're keeping the plugin up to date.

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    Like I said previously, the setting should be "Native" instead of "Click" but while that should work, there seem to be a bug so it's not working currently as expected anyway. As I already reported it to our developers as a bug, I'm afraid we need to wait for an update to the plugin that would include a fix or at least some feedback from them that would provide some sort of workaround.

    We'll update you here as soon as we get to know more from our developers.

    Kind regards,
    Adam

    • Greg
      • Syntax Hero

      Dear Adam,

      Thank you. I understood that, but there is also something different about the Twitter account (well, at least it seems unrelated to me).

      I guess that this message would be there even if the share count was right, there would just be no share counts for Twitter.

      I wanted to get ahead and already register the website, but the link (anchor "ce service" ) sends to a 404 : http://newsharecounts.com/

      Regards,
      Greg

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    I think I caused small confusion here and I'm sorry for this. I just read my last response to you and realized that I actually didn't inform you that this is also reported to the developers as it's clearly a thing that needs to be updated as well. I'm sure I wanted to write this (I double-checked my report to developers to make sure that I reported this too) but somehow I missed it. Once again I apologize for confusion.

    To sum it up:
    - showing "real count" requires setting option to "native"
    - there's a bug regarding fetching these counts and it's reported to developers as a bug
    - fetching Twitter counts requires additional action but that too must be updated in the plugin and is also reported to our developers

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    Would it delete my settings if I de-activate and re-activate the plug-in ?

    No, de-/re-activating plugin should be perfectly safe and shouldn't cause any data loss. It's always better to keep backup as there's always some chance that something might go wrong (regardless of whatever plugin we're referring to) but "under normal conditions" nothing should be lost - and certainly nothing would be deleted "by design" :slight_smile:

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Greg

    Disabling and enabling plugin again wouldn't fix the wrong count. The count is not accurate and doesn't reflect "real count" due to the bug. There's really nothing you could try or do at the moment to fix that. We need to wait until the fix is released.

    As for the broken widget. It does indeed seem to be related to the SmushCDN. Would you please go to "Smush Pro -> CDN" page and temporarily deactivate the CDN. Clear the cache after that and site should get back to normal.

    After that please wait a couple of hours and try enabling the CDN again. Apparently due to that release (it's a big change) we're experiencing some temporary overloads of the API. If it still doesn't work after you enable CDN in Smush again after a few hours, please create a separate ticket about that feature breaking the site and we'll check that with our sys-admins.

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Greg

    I hope you're fine today!

    Yes, you're right. Unfortunately this particular fix didn't make it to the 3.0.7 release do to some additional issues related to other fixes - it must not interfere with other fixes and improvements, that caused an unexpected delay. I apologize for not letting you know earlier.

    I just checked and it's been moved on to the next release and if everything goes fine (nothing else unexpected shows up meanwhile) it should be included in it.

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    The the ajax-calls should most likely "behave" in a bit more "civilized way" after the issue is patched, indeed. However:

    1) we'll only be able to really see this after it's released so I'm afraid we'll still need to wait a bit more; I'm sorry it takes that much time

    2) it's, indeed, quite surprising that these calls are even there...

    As you already mentioned, if the plugin is deactivated, there should be no such calls. Inactive plugin just "sits there" and its code is "left alone" so it's not really even executed, hence any calls triggered by plugin's code shouldn't be executed either. Unless, and while that would be quite surprising as well it could possibly happen in theory, the are because they are really not "disabled" because some parts of the code is actually "hardly" cached. There are solutions (server-side) that do cache already compiled PHP code - which itself should not "execute it" anyway but on the other hand, just theoretically, an "overlap" of different kind of caches could possibly cause the site to include and execute the code that should not be included and executed.

    That's quite difficult to diagnose and track down though. Maybe there is something wrong indeed in the plugin itself as well but still - I'm not able to replicate it in any way and all the "rules and theories", so to speak, confirm that this should not be happening at all, if the plugin is inactive.

    I'll give it some more tests meanwhile but the bottom line is, I think we should wait for that update and see how it will behave on our test sites and on your setup.

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    Thanks for additional explanation but I think we got slight misunderstanding here.

    With my last response I was under impression that Hustle is currently deactivated on the site - and by "site" I meant "WP install", the entire Multisite. But if it's active e.g. on one of the sites in network, it's perfectly valid and expected that its scripts will be used and that it might be making some ajax calls.

    Then, it's not a conflict and it's nothing unusual or wrong that two or more plugins are using "wp-ajax.php" and/or "admin-ajax.php". These are parts of WP core that are there handling AJAX (as in "Asynchronous JavaScript and XML ").

    What that means is that both these plugins do call e.g. admin-ajax.php file (which is WP core file) but what it does depends on what data plugin sent to it. So as per analogy you could imagine an office assistant when one manager asks this person "hey, bring me a report on sales" and the assistance gets back to this manager and hands sales reports over and then another manager asks the same assistant to set him up on a meeting with a client and the assistant calls the client, sets up a meeting and gets back to that other manager with details.

    So, one assistant, two different "bosses" with two different tasks.

    This doesn't create any conflicts. Those tasks are called "in the queue", preformed asynchronously and even though it's still the "admin-ajax.php" file call, they are different tasks. If WPDiscuz allows you to disable WP Ajax, you can try that. It will certainly lower the load but you need to see whether the plugin behavior for you will be acceptable after that or not as it may simply change the way it works.

    As for Hustle - the admin-ajax.php calls that it does - those shown on the screenshot that you previously provided are indeed related to social shares so in this case, we'll definitely need to wait for that "social shares fix" to be released and see if it helps for these calls as well or if there's yet another fix or tweak necessary for this.

    Kind regards,
    Adam

      • Greg
        • Syntax Hero

        Dear Adam Czajczyk ,

        I've just received WPX's answer :

        The uncached requests from 'wpDiscuz' are no longer being called but the ones from 'Hustle' run two times per page/post: https://take.ms/YYmoV

        Even if tracking is disabled: https://take.ms/aG3vr for Popups, Slide-Ins and Embeds those requests are just there but when the plugin is fully disabled they no longer appear.

        We can disable the admin-ajax.php for the front-end of the site and allow it only for your IP but at the moment I would advise you to ask the plugin developers or temporarily disable the plugin.

        Would you have anything to suggest, following their answer ?

        Regards,
        Greg

  • Adam Czajczyk
    • Support Gorilla

    Hello Greg

    These calls in Hustle - those reported by your host - are related to what we are discussing here from the beginning: share count. What you can try for now, apart from disabling the plugin entirely, is to actually disable/remove the "Social Share" that you got created there from it. That would also remove "Social Share" icons/module form site though.

    Any other way - like somehow blocking/disabling those calls - would most likely break the plugin (which might even result in unexpected behaviors of other aspects of the site). I really would hold on with this until update that will contain the fix for social shares and see then if it helps (especially that two ajax calls is not really much and is nothing unusual in case of WordPress). But still - this is strictly related to social shares so it's either disabling them or the plugin or waiting for the update and only if the update doesn't improve the situation, we can then investigate it further to see what else could be done to make it better.

    Best regards,
    Adam

    • Greg
      • Syntax Hero

      Dear Adam Czajczyk ,

      This issue is still unsolved.

      Today, I am updating this ticket because I've just enable a CDN service (a cloudfare-like feature from my hosting company, WPX : https://wpxhosting.com/page/wpx-cloud/ ).

      This breaks the sharebar completly. Ex : https://blog.defi-ecologique.com/mante/

      I've asked them how to solve this and here is what they say :

      I`ve enabled the Cloud back on so you can contact them and ask which resources we need to add rules for in order for caching to be disabled for them.

      I see an error in the log (not sure if it is coming from this feature), but it is regarding admin-ajax.php 403 error block from our end, but if we stop the caching for the file the entire Multi-SIte will not cache this file with all features that use it in this Network.

      Also, I am not sure that this error is referring to this specific issue.

      Could you please help me solve this ?

      Regards,
      Greg

  • Kasia Swiderska
    • Support nomad

    Hello Greg,

    I'm sorry for the delay - I have checked the status of this bug and it didn't pass previous rounds of the QA testing, that is why it was not included in the new releases.
    I can see now that it's good now and it should be part of the new version.
    So we need to wait for this new release to see if it will work with your hosting.

    kind regards,
    Kasia

  • Adam Czajczyk
    • Support Gorilla

    Hello Greg

    It does seem that the newest version of the fix is finally fine but I'm afraid I don't have an ETA. It's planned for the next release if everything goes fine so I'll keep my fingers crossed and hopefully it will make it there this time. However, it's better to assume that there might be slight delay (just in case it turned out that e.g. it still conflicts with some other fix) - but I hope there won't be :wink:

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    First, I apologize for the delayed response!

    As for the share counts. I think that needs a bit "different look" now.

    1) Facebook

    The actual number of shares, while still very different to what the plugin shows, isn't actually that high. If you click on a small down arrows next to each number in the SharedCount site, you'll see that this nice big number is actually breaking down to shares, likes, comments and reactions. While for one of the articles, shares are around 3,000 for the other one there's only slightly above 500:

    I'm pointing that out only so we could be sure that we're comparing relevant numbers.

    2) Twitter

    Have you registered for this service already?

    https://www.twitcount.com/

    it's now necessary for Twitter count to work as Twitter made changes to their API and the direct fetching of such data from Twitter is not possible. That's a workaround so the site must be registered with this service. However, there's a "catch":

    Counts will start appearing in approximately 1 hour. This is due to the API limitations. The API provides information only for the tweets in the last week or so. This means that old pages may show incomplete counts. Starting the day you add the new button, all new pages will have complete counts data.

    This is stated (in a very "fine print", unfortunately) on their website. It basically means that for any content that already existed on the site for longer than a week, you won't really get any real and relevant data. Only the new posts/publications should be counted properly. This is, I'm afraid, something that's more of a Twitter fault rather than anyone's else, due to the changes the platform made to their API

    3) Same numbers

    This is something that still points to an issue and I think that actually gets us back to the site itself. I remember that site's quite non-standard, there's been caches etc that were causing some issues in the past. The "wrong numbers" itself can point to some issue with the plugin but the fact they are the same for not only these two articles but also for other articles as well suggests that either
    - the data is heavily cached on sites/server end
    - or something's preventing the plugin from even fetching current data

    Have you tried to clear all possible caches after plugin update? Did you try to disable other plugins temporarily, then clear caches and see if the numbers get updated? If not, that would be worth testing.

    I know that the plugin was updated and is expected to solve the issue but if there are caches that affect stored data and/or other code that interferes with it, then it still needs to be identified because it might be breaking the feature even if a fix is included in the update.

    Best regards,
    Adam

    • Greg
      • Syntax Hero

      Dear Adam Czajczyk ,

      Thank you for your answer.

      1) Well, this is quite disapointing... thank you for pointing it out.

      2) Here is the code they give me :
      <script type='text/javascript'>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'http';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://static1.twitcount.com/js/twitcount.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitcount_plugins');</script>

      What should I do with it ?

      3) Actually, I cleared and changed caches and plug-in about a billion times.
      I first created the website under devblog.defi-ecologique.com, as a staging area for an old version of blog.defi-ecologique.com, where I used another plug-in for the sharebar.
      Then, I deleted the old one and renamed the staging area. Back then, I did not install any caching plug-in as I had many things to test before activating them.
      The share-bar was one of these things and it never worked, even before I updated caches.
      Back then, I created this ticket.

      If you have time to read it back (sorry for that), you might notice that there were some back and forth with my hosting company, WPX. If you would like to, I could ask them a bunch of things about scripts and APIs that might be blocked or cached.

      Regards,
      Greg

  • Adam Czajczyk
    • Support Gorilla

    Hey Greg

    2) Here is the code they give me : (...)

    You don't have to do anything with this code :slight_smile: You only had to signup there with your site and Hustle has all that's necessary to work with this service already built-in.

    3) Actually, I cleared and changed caches and plug-in about a billion times.
    I first created the website under devblog.defi-ecologique.com, (...)

    I only asked before sometimes that's still necessary after any updates. And it's very strange - and also very "cache-like" - thing that all the posts (articles) are showing exactly the same data (or no data at all in some cases). Hustle itself caches those numbers but for no more than 6 hours and should only server cached data if either it's a bot (like e.g. search engine crawler) visiting the site or the numbers didn't change at all since last clear up.

    This would suggest one of three things happening:

    - either there is still some "stubborn" server-side cache (might be some db/object cache in fact that you might not even see in any hosting management panel - so it would be good if you could ask your host about that)

    - or "something" (may it be some plugin on site or some firewall or other security/"rate limiting" tool on server) is blocking connections to these services' APIs - so just in case please ask your host if the could check connections to FB/twitcount.com APIs from your site

    - or the db is getting "messed up" in some way.

    There's still a small chance that the fix didn't quite fix the issue but that would be something unexpected, in that sense that it would mean that the bug still reveals itself only in specific configuration/environment as it's been tested before release and was confirmed to solve the problem.

    I think then - please ask your host about these two things mentioned above and if it turns out it's nothing related to them, I'll talk to our developers again to see what/how else we could test it on your end to find out what's happening.

    Best regards,
    Adam

    • Greg
      • Syntax Hero

      Dear Adam Czajczyk ,

      Thank you for your help. I'll ask my host about all this stuff and keep you posted.

      - or the db is getting "messed up" in some way.

      Is there a particular table or option that I should look for ? What exactly could be messed up ?

      EDIT : as far as the twitter service is concerned, is there a way, in Hustle, to double-check that everything is as expected ?

      Regards,
      Greg

      • Greg
        • Syntax Hero

        Dear Adam Czajczyk ,

        I just received the answer from my hosting company.

        Currently, the only cache on the website is coming from our WPX Cloud and W3 Total Cache.

        In terms of server-side caching, we do use OP Cache for PHP processes, however that is cleared automatically every 90 seconds and should not affect anything.

        For your information, I cleared both WPX Cloud and W3TC on numerous occasions and none of them was active when the sharebar problem appeared.

        Regards,
        Greg

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    Thank you for checking with the host and letting me know.

    I did some additional "review" on my own setup but I must say, I'm a bit out of ideas. I've turned to our developers again, asking them for consultation on this. I assume that they might need to check that directly on your site so it would be great if you could provide me (just in case, so things would go faster in case they needed it) with full access credentials. Would that be possible?

    Note: Don't leave your login details in this ticket.
    Instead, you can send me your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Adam Czajczyk"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,
    Adam

  • Panos
    • SLS

    Hi Greg !

    Thanks for sending those in. Regarding the pages that do not show the counter at all, it still not clear why this is happening.

    When refreshing those articles with this issue, the counter starts appearing which is really weird and makes it harder to debug.

    I would need your permission to deactivate the W3 Total Cache plugin and see if that would change anything.

    Something else that I noticed is that the ajax call to action module_viewed returns a 403:
    https://blog.defi-ecologique.com/wp-admin/admin-ajax.php?action=module_viewed
    Something seems to be blocking it, I deactivated Defender but it doesn't change anything (I have reactivated it). This is for tracking when the Tracking option is active. I have de-activated that option for now. It's not related to this issue but you might want to ask your host about it.

    Kind regards!

    • Greg
      • Syntax Hero

      Dear Panos ,

      Here is the host answer :

      You can load the admin-ajax.php in the browser to see that we are not blocking it: https://blog.defi-ecologique.com/wp-admin/admin-ajax.php

      Also there is some errors that there is a block from the plugin wp-defender.

      You can check the error logs if it will help him with the issue: https://monosnap.com/file/Qcu6AhJ7UtpGaX5MXOYedmZ5vv4J8X

      Also there are some rules in the .htaccess set by the Defender even if it is disabled the .htaccess will pass those rules to block some connections to the server. You can check the file as well.

      Here is the error log the monospnat indicates :

      defi-ecologique.com error Logs
      [Tue Jun 04 23:46:26.445044 2019] [access_compat:error] [pid 23436:tid 140640235915008] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://blog.defi-ecologique.com/wp-content/plugins/wp-defender/changelog.txt
      [Tue Jun 04 23:46:26.469236 2019] [access_compat:error] [pid 23436:tid 140652089452288] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/uploads/wp-defender/index.php, referer: https://www.defi-ecologique.com/wp-content/uploads/wp-defender/index.php
      [Tue Jun 04 23:46:26.482014 2019] [access_compat:error] [pid 23436:tid 140650054420224] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://blog.defi-ecologique.com/wp-content/plugins/wp-defender/changelog.txt
      [Tue Jun 04 23:46:26.504690 2019] [access_compat:error] [pid 23436:tid 140646949422848] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/uploads/wp-defender/index.php, referer: https://www.defi-ecologique.com/wp-content/uploads/wp-defender/index.php
      [Tue Jun 04 23:52:26.020761 2019] [:error] [pid 6321:tid 140648816617216] [client 123.249.33.58:0] [client 123.249.33.58] ModSecurity: XML parser error: XML: Failed parsing document. [hostname "blog.defi-ecologique.com"] [uri "/xmlrpc.php"] [unique_id "XPb2Ko2mISP62ZQ1jnsKoQAAAgE"]
      [Tue Jun 04 23:52:26.022472 2019] [:error] [pid 6321:tid 140648816617216] [client 123.249.33.58:0] [client 123.249.33.58] ModSecurity: Access denied with code 400 (phase 2). Match of "eq 0" against "REQBODY_ERROR" required. [file "/opt/apache24/httpd/conf.d/mod_security.conf"] [line "23"] [id "200002"] [msg "Failed to parse request body."] [data "XML parser error: XML: Failed parsing document."] [severity "CRITICAL"] [hostname "blog.defi-ecologique.com"] [uri "/xmlrpc.php"] [unique_id "XPb2Ko2mISP62ZQ1jnsKoQAAAgE"]
      [Tue Jun 04 23:58:31.196066 2019] [access_compat:error] [pid 6321:tid 140640172975872] [client 66.249.79.92:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/ads.txt
      [Wed Jun 05 00:48:11.702148 2019] [access_compat:error] [pid 6321:tid 140640466691840] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-includes/theme-compat/embed.php, referer: https://blog.defi-ecologique.com/wp-includes/theme-compat/embed.php
      [Wed Jun 05 00:48:11.761105 2019] [access_compat:error] [pid 6321:tid 140647851550464] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://blog.defi-ecologique.com/wp-content/plugins/wp-defender/changelog.txt
      [Wed Jun 05 00:48:11.794265 2019] [access_compat:error] [pid 6321:tid 140640225425152] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/uploads/wp-defender/index.php, referer: https://www.defi-ecologique.com/wp-content/uploads/wp-defender/index.php
      [Wed Jun 05 00:48:11.822240 2019] [access_compat:error] [pid 6321:tid 140650809689856] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://blog.defi-ecologique.com/wp-content/plugins/wp-defender/changelog.txt
      [Wed Jun 05 00:48:11.848907 2019] [access_compat:error] [pid 6321:tid 140644043732736] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/uploads/wp-defender/index.php, referer: https://www.defi-ecologique.com/wp-content/uploads/wp-defender/index.php
      [Wed Jun 05 00:49:22.422729 2019] [access_compat:error] [pid 6321:tid 140640183465728] [client 66.249.79.189:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/ads.txt
      [Wed Jun 05 01:13:25.167890 2019] [lsapi:notice] [pid 6321:tid 140646036805376] [client 88.99.193.224:0] [host http://www.defi-ecologique.com Backend log: Erreur de la base de donn\xc3\xa9es WordPress Unknown column '1type' in 'where clause' pour la requ\xc3\xaate SELECT * FROM de_presse WHERE featured=1type='3' GROUP BY parution ORDER BY featured ASC faite par require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/defi-ecologique/page-presse-et-media.php'), do_shortcode, preg_replace_callback, do_shortcode_tag, display_revue_presse\n
      [Wed Jun 05 01:16:16.679746 2019] [access_compat:error] [pid 6321:tid 140653222356736] [client 69.194.143.140:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/ads.txt
      [Wed Jun 05 01:16:16.992753 2019] [access_compat:error] [pid 6321:tid 140653243336448] [client 69.194.143.140:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/ads.txt
      [Wed Jun 05 01:20:50.632927 2019] [:error] [pid 6321:tid 140652477576960] [client 198.178.126.47:0] [client 198.178.126.47] ModSecurity: Access denied with code 403 (phase 2). String match "site.ru" at REQUEST_HEADERS:Referer. [file "/opt/apache24/httpd/modsecurity.d/activated_rules/1_custom_global.conf"] [line "147"] [id "9812402"] [msg "malicious referer site.ru"] [hostname "www.defi-ecologique.com"] [uri "/services/eco-communication/creation-de-sites-internet/"] [unique_id "XPcK4o2mISP62ZQ1jnvrCwAAAJ4"], referer: http://site.ru
      [Wed Jun 05 01:52:34.548635 2019] [access_compat:error] [pid 18788:tid 140638819784448] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-includes/theme-compat/embed.php, referer: https://blog.defi-ecologique.com/wp-includes/theme-compat/embed.php
      [Wed Jun 05 01:52:34.610335 2019] [access_compat:error] [pid 18788:tid 140651407611648] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://blog.defi-ecologique.com/wp-content/plugins/wp-defender/changelog.txt
      [Wed Jun 05 01:52:34.633424 2019] [access_compat:error] [pid 18788:tid 140653180397312] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/uploads/wp-defender/index.php, referer: https://www.defi-ecologique.com/wp-content/uploads/wp-defender/index.php
      [Wed Jun 05 02:07:54.003765 2019] [access_compat:error] [pid 18788:tid 140652309739264] [client 66.249.79.215:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/ads.txt
      [Wed Jun 05 02:20:39.360875 2019] [access_compat:error] [pid 18788:tid 140648050857728] [client 69.194.143.140:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/ads.txt
      [Wed Jun 05 02:20:39.684405 2019] [access_compat:error] [pid 18788:tid 140646162683648] [client 69.194.143.140:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/ads.txt
      [Wed Jun 05 02:55:30.114343 2019] [access_compat:error] [pid 18788:tid 140644662634240] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-includes/theme-compat/embed.php, referer: https://blog.defi-ecologique.com/wp-includes/theme-compat/embed.php
      [Wed Jun 05 02:55:30.180941 2019] [access_compat:error] [pid 18788:tid 140653862237952] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://blog.defi-ecologique.com/wp-content/plugins/wp-defender/changelog.txt
      [Wed Jun 05 02:55:30.211682 2019] [access_compat:error] [pid 18788:tid 140650138339072] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://blog.defi-ecologique.com/wp-content/plugins/wp-defender/changelog.txt
      [Wed Jun 05 02:55:30.214979 2019] [access_compat:error] [pid 18788:tid 140639575054080] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/uploads/wp-defender/index.php, referer: https://www.defi-ecologique.com/wp-content/uploads/wp-defender/index.php
      [Wed Jun 05 02:55:30.233008 2019] [access_compat:error] [pid 18788:tid 140644379408128] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/uploads/wp-defender/index.php, referer: https://www.defi-ecologique.com/wp-content/uploads/wp-defender/index.php
      [Wed Jun 05 02:58:04.217082 2019] [access_compat:error] [pid 18788:tid 140647484405504] [client 66.249.79.74:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/ads.txt
      [Wed Jun 05 02:59:04.117326 2019] [:error] [pid 18788:tid 140641914291968] [client 64.90.48.189:0] [client 64.90.48.189] ModSecurity: Access denied with code 403 (phase 2). String match "site.ru" at REQUEST_HEADERS:Referer. [file "/opt/apache24/httpd/modsecurity.d/activated_rules/1_custom_global.conf"] [line "147"] [id "9812402"] [msg "malicious referer site.ru"] [hostname "defi-ecologique.com"] [uri "/cgi-bin/cgi-bin1.php"] [unique_id "XPch6IyeJoyUW1EPMrpDZQAABI8"], referer: http://site.ru
      [Wed Jun 05 03:03:49.258895 2019] [:error] [pid 18788:tid 140645386434304] [client 192.198.90.198:0] [client 192.198.90.198] ModSecurity: Access denied with code 403 (phase 2). String match "site.ru" at REQUEST_HEADERS:Referer. [file "/opt/apache24/httpd/modsecurity.d/activated_rules/1_custom_global.conf"] [line "147"] [id "9812402"] [msg "malicious referer site.ru"] [hostname "www.defi-ecologique.com"] [uri "/services/eco-communication/creation-de-sites-internet/"] [unique_id "XPcjBYyeJoyUW1EPMrpsCgAAA0E"], referer: http://site.ru
      [Wed Jun 05 03:10:02.026918 2019] [access_compat:error] [pid 18788:tid 140639459665664] [client 66.249.79.214:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/ads.txt
      [Wed Jun 05 03:34:43.668235 2019] [access_compat:error] [pid 18788:tid 140649288660736] [client 66.249.79.161:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/ads.txt
      [Wed Jun 05 03:52:50.768146 2019] [access_compat:error] [pid 9530:tid 140650967037696] [client 157.55.39.73:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php
      [Wed Jun 05 04:23:03.510919 2019] [access_compat:error] [pid 9530:tid 140642690541312] [client 40.77.167.20:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php
      [Wed Jun 05 04:23:10.166184 2019] [access_compat:error] [pid 9530:tid 140641148532480] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-includes/theme-compat/embed.php, referer: https://blog.defi-ecologique.com/wp-includes/theme-compat/embed.php
      [Wed Jun 05 04:23:10.230730 2019] [access_compat:error] [pid 9530:tid 140642438784768] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://blog.defi-ecologique.com/wp-content/plugins/wp-defender/changelog.txt
      [Wed Jun 05 04:23:10.256598 2019] [access_compat:error] [pid 9530:tid 140647578814208] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/uploads/wp-defender/index.php, referer: https://www.defi-ecologique.com/wp-content/uploads/wp-defender/index.php
      [Wed Jun 05 04:27:33.254211 2019] [core:error] [pid 9530:tid 140649425028864] [client 39.100.87.15:0] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
      [Wed Jun 05 04:47:24.458283 2019] [:error] [pid 9530:tid 140642228987648] [client 54.36.148.63:0] [client 54.36.148.63] ModSecurity: Warning. Matched phrase "m.js" at RESPONSE_BODY. [file "/opt/apache24/httpd/modsecurity.d/activated_rules/slr_rules.conf"] [line "248"] [id "2500005"] [rev "11272018"] [msg "SLR: Bomonero - Crypto-Mining Activity"] [severity "CRITICAL"] [tag "attack-crypto mining"] [tag "application-multi"] [tag "language-multi"] [tag "platform-multi"] [tag "https://www.trustwave.com/Resources/Trustwave-Blog/All-the-Ways-Cybercriminals-Are-Exploiting-the-Cryptocurrency-Boom/"] [hostname "www.defi-ecologique.com"] [uri "/wp-signup.php"] [unique_id "XPc7TBeIaVfAkbJTDSPTLwAABHA"]
      [Wed Jun 05 05:19:24.030816 2019] [:error] [pid 9530:tid 140638578517760] [client 64.90.34.104:0] [client 64.90.34.104] ModSecurity: Access denied with code 403 (phase 2). String match "site.ru" at REQUEST_HEADERS:Referer. [file "/opt/apache24/httpd/modsecurity.d/activated_rules/1_custom_global.conf"] [line "147"] [id "9812402"] [msg "malicious referer site.ru"] [hostname "defi-ecologique.com"] [uri "/readme.php"] [unique_id "XPdCzBeIaVfAkbJTDSPd6AAABc4"], referer: http://site.ru
      [Wed Jun 05 05:24:00.997958 2019] [access_compat:error] [pid 9530:tid 140646131214080] [client 185.5.172.154:53688] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-includes/theme-compat/embed.php, referer: https://boutique.defi-ecologique.com/wp-includes/theme-compat/embed.php
      [Wed Jun 05 05:24:01.052723 2019] [access_compat:error] [pid 9530:tid 140638641456896] [client 185.5.172.154:53692] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://boutique.defi-ecologique.com/wp-content/plugins/wp-defender/changelog.txt
      [Wed Jun 05 05:24:01.114096 2019] [access_compat:error] [pid 9530:tid 140646781585152] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/uploads/wp-defender/index.php, referer: https://www.defi-ecologique.com/wp-content/uploads/wp-defender/index.php
      [Wed Jun 05 05:26:59.506386 2019] [lsapi:notice] [pid 9530:tid 140643645118208] [client 34.74.71.251:0] [host http://www.defi-ecologique.com Backend log: Erreur de la base de donn\xc3\xa9es WordPress Unknown column '1type' in 'where clause' pour la requ\xc3\xaate SELECT * FROM de_presse WHERE featured=1type='3' GROUP BY parution ORDER BY featured ASC faite par require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/defi-ecologique/page-presse-et-media.php'), do_shortcode, preg_replace_callback, do_shortcode_tag, display_revue_presse\n
      [Wed Jun 05 06:24:16.944668 2019] [access_compat:error] [pid 735:tid 140652498556672] [client 185.5.172.154:52196] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-includes/theme-compat/embed.php, referer: https://boutique.defi-ecologique.com/wp-includes/theme-compat/embed.php
      [Wed Jun 05 06:24:16.996304 2019] [access_compat:error] [pid 735:tid 140639690442496] [client 185.5.172.154:52198] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://boutique.defi-ecologique.com/wp-content/plugins/wp-defender/changelog.txt
      [Wed Jun 05 06:24:17.019677 2019] [access_compat:error] [pid 735:tid 140642533193472] [client 185.5.172.154:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/uploads/wp-defender/index.php, referer: https://www.defi-ecologique.com/wp-content/uploads/wp-defender/index.php
      [Wed Jun 05 07:00:01.775033 2019] [access_compat:error] [pid 735:tid 140649697765120] [client 157.55.39.242:0] AH01797: client denied by server configuration: /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php
      [Wed Jun 05 07:10:49.728379 2019] [lsapi:notice] [pid 735:tid 140654040565504] [client 35.157.32.153:3159] [host administration.defi-ecologique.com] Backend log: PHP Warning: preg_match(): Compilation failed: quantifier does not follow a repeatable item at offset 0 in /home/pleagueo/domains/defi-ecologique.com/public_html/wp-content/plugins/w3-total-cache/PgCache_ContentGrabber.php on line 836\n

      Regards,
      Greg

  • Panos
    • SLS

    Hi Greg !

    The developer shared a patch which seems to work with the "Click" option. I have added the patched version on your site and checked thoroughly and didn't notice that issue with missing numbers. Please do have a look on your side and let us know :slight_smile:

    This issue should be fixed in upcoming version 4

    Kind regards!

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    Thanks for response!

    That's a bit strange, indeed. Just to test it, I check current numbers on both these pages and then shared one of them on Facebook (just some testing account). What happened was that the FB share count on the page that I shared was increased by one and that's fine.

    The other page, when reloaded, was still showing "original" share count for FB so that seemed to be fine but then it jumped up after 2 or 3 reloads to the same number as the shared one. I've passed that feedback to developers.

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello again Greg

    i'm sorry for bothering you again but I just realized that actually skipped something quite important, as I'm a bit confused (since this thread is already really lengthy).

    Can you tell me please if the share count is currently set to "click" or "native" after all? I just need to confirm that.

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Greg

    Thank you for your response!

    With "click" that's actually as it should be. "Click" counts how many times the given share button has been actually clicked and the number is common across entire site. Only "Native" is counting shares "per page".

    However, I admit I wasn't quite aware of that and also the "Native", if set, apparently still is causing some "missing numbers" there. I'll start an internal discussion about this as I think in this case this might need some re-factoring.

    Kind regards,
    Adam

  • Greg
    • Syntax Hero

    Dear Kasia Swiderska ,

    I've updated to the new version, but the count has not changed.

    Could it come from the fast that I'm calling the sharebar from the template ?

    <div id="share_bar" class="widget">
    								<div class="centre relative">
    									<?php
    									if( wp_is_mobile() )
    										echo '<div id="btt" class="absolute"><a href="#header_shadow"><i class="fas fa-chevron-up"></i></a></div>';
    									echo do_shortcode('[wd_hustle_ss id="social-bar"]'); ?>
    									<div id="comment_widget"><a href="#comments" class="center centre ssc ssc_border"><i class="far fa-comments ssc"></i><span><?php comments_number( '0', '1', '%' ); ?></span></a></div>
    								</div>
    							</div>

    Also, the update totally broke the layout.

    Here is my previous CSS. Could you please tell me how I may adapt it to Hustle's new version ?

    #share_bar .hustle_sshare_module_shortcode_wrap {
    	margin: 0;
    	overflow: auto;
    }
    #share_bar .hustle-shares-widget{
    	overflow: auto;
        margin: 0 auto;
    	background: transparent;
    	display:table;
    	padding: 0;
    }
    #share_bar .hustle-shares-widget .hustle-shares-wrap {
    	margin: 0;
    }
    #share_bar .hustle-shares-widget a {
    	display: inline-block;
    	vertical-align: middle;
    	min-height: 28px;
    	border-radius: 0.2em;
    	width:62px;
    	margin: 0.2em;
    }
    #share_bar .hustle-icon-squared .hustle-icon{
    	width: 13px;
    	height: 13px;
    }
    #share_bar .hustle-shares-widget a.hustle-social-icon > div {
    	width: 50%;
    	float: left;
    	padding: 0;
    }
    #share_bar .hustle-shares-widget a:hover,
    #share_bar .hustle-shares-widget a:hover > div{
    	color: #879a77;
    	background-color: #fff;
    	border-color: #879a77;
    	border-radius: 0;
    }
    #share_bar .hustle-shares-widget a:hover .hustle-icon-path{
    	fill: #879a77;
    }
    #share_bar .hustle-shares-widget a  .hustle-shares-counter{
    	color:#fff;
    	align-items: normal;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-facebook{
    	background-color: #2D5F9A;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-facebook:hover,
    #share_bar .hustle-shares-widget a.hustle-icon-facebook:hover  .hustle-shares-counter{
    	color: #2D5F9A;
    	border-color: #2D5F9A;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-facebook:hover  .hustle-icon-path{
    	fill: #2D5F9A;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-linkedin{
    	background-color: #0077B5;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-linkedin:hover,
    #share_bar .hustle-shares-widget a.hustle-icon-linkedin:hover  .hustle-shares-counter{
    	color: #0077B5;
    	border-color: #0077B5;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-linkedin:hover  .hustle-icon-path{
    	fill: #0077B5;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-twitter{
    	background-color: #00C3F3;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-twitter:hover,
    #share_bar .hustle-shares-widget a.hustle-icon-twitter:hover  .hustle-shares-counter{
    	color: #00C3F3;
    	border-color: #00C3F3;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-twitter:hover  .hustle-icon-path{
    	fill: #00C3F3;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-google{
    	background-color: #D73D32;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-google:hover,
    #share_bar .hustle-shares-widget a.hustle-icon-google:hover  .hustle-shares-counter{
    	color: #D73D32;
    	border-color: #D73D32;
    }
    #share_bar .hustle-shares-widget a.hustle-icon-google:hover  .hustle-icon-path{
    	fill: #D73D32;
    }

    And

    @media screen and (min-width: 45em) {
    	#share_bar .hustle-shares-widget  {
    		display: flex;
    		flex-wrap: wrap;
    		max-width: 72px;
    		margin-right: 0;
    		margin-left: auto
    	}
    	#share_bar .hustle-shares-widget  a {
    		margin: 0.2em auto;
    		display: flex;
    		width:72px;
    	}
    	#share_bar .hustle-icon-squared .hustle-icon{
    		width: 18px;
    		height: 18px;
    	}
    }

    Regards,
    Greg

  • Predrag Dubajic
    • Support

    Hi Greg,

    Apologies for the long wait time, we were short staffed for a couple of days.

    Are you still having issues with all of the counters? Because the Native counters should be fixed except for Facebook one which we noticed and our devs are working on it further for the next release.

    As for the CSS, I'm afraid that it will need to be redone because there were CSS and HTML changes in the 4.0 release.
    This might work for you:

    #share_bar .widget_hustle_module_widget {
    	margin: 0;
    	overflow: auto;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content{
    	overflow: auto;
        margin: 0 auto;
    	background: transparent;
    	display:table;
    	padding: 0;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content .hustle-social {
    	margin: 0;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a {
    	display: inline-block;
    	vertical-align: middle;
    	min-height: 28px;
    	border-radius: 0.2em;
    	width:62px;
    	margin: 0.2em;
    }
    #share_bar .hustle-icon-squared .hustle-icon{
    	width: 13px;
    	height: 13px;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-share-icon > div {
    	width: 50%;
    	float: left;
    	padding: 0;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a:hover,
    #share_bar .hustle-shares-widget .hustle-inline-content a:hover > div{
    	color: #879a77;
    	background-color: #fff;
    	border-color: #879a77;
    	border-radius: 0;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a:hover .hustle-icon-path{
    	fill: #879a77;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a  .hustle-shares-counter{
    	color:#fff;
    	align-items: normal;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-facebook{
    	background-color: #2D5F9A;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-facebook:hover,
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-facebook:hover  .hustle-shares-counter{
    	color: #2D5F9A;
    	border-color: #2D5F9A;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-facebook:hover  .hustle-icon-path{
    	fill: #2D5F9A;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-linkedin{
    	background-color: #0077B5;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-linkedin:hover,
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-linkedin:hover  .hustle-shares-counter{
    	color: #0077B5;
    	border-color: #0077B5;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-linkedin:hover  .hustle-icon-path{
    	fill: #0077B5;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-twitter{
    	background-color: #00C3F3;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-twitter:hover,
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-twitter:hover  .hustle-shares-counter{
    	color: #00C3F3;
    	border-color: #00C3F3;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-twitter:hover  .hustle-icon-path{
    	fill: #00C3F3;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-google{
    	background-color: #D73D32;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-google:hover,
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-google:hover  .hustle-shares-counter{
    	color: #D73D32;
    	border-color: #D73D32;
    }
    #share_bar .hustle-shares-widget .hustle-inline-content a.hustle-icon-google:hover  .hustle-icon-path{
    	fill: #D73D32;
    }

    Best regards,
    Predrag

    • Greg
      • Syntax Hero

      Dear Predrag,

      Thank you for your help, but unfortunately, this code is invalid.

      For instance, there is no more .hustle-shares-widget :

      I tried to tweak this code into something that works, but I couldn't manage to do so. At the moment, the share buttons aren't even displayed :s

      https://blog.defi-ecologique.com/opposition-homme-nature/

      Here is my current CSS :

      #share_bar .widget_hustle_module_widget {
      	margin: 0;
      	overflow: auto;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content{
      	overflow: auto;
          margin: 0 auto;
      	background: transparent;
      	display:table;
      	padding: 0;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content .hustle-social {
      	margin: 0;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a {
      	display: inline-block;
      	vertical-align: middle;
      	min-height: 28px;
      	border-radius: 0.2em !important;
      	width:62px;
      	margin: 0.2em;
      }
      #share_bar .hustle-social--squared .hustle-share-icon{
      	width: 13px;
      	height: 13px;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share-icon > div {
      	width: 50%;
      	float: left;
      	padding: 0;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a i{
      	margin: 0;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a:hover,
      #share_bar .hustle_module_id_1 .hustle-inline-content a:hover > div{
      	color: #879a77;
      	background-color: #fff;
      	border-color: #879a77;
      	border-radius: 0;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a:hover .hustle-icon-path{
      	fill: #879a77;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a  .hustle-counter{
      	color:#fff;
      	align-items: normal;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--facebook{
      	background-color: #2D5F9A;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--facebook:hover,
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--facebook:hover  .hustle-counter{
      	color: #2D5F9A;
      	border-color: #2D5F9A;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--facebook:hover  .hustle-icon-path{
      	fill: #2D5F9A;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--linkedin{
      	background-color: #0077B5;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--linkedin:hover,
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--linkedin:hover  .hustle-counter{
      	color: #0077B5;
      	border-color: #0077B5;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--linkedin:hover  .hustle-icon-path{
      	fill: #0077B5;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--twitter{
      	background-color: #00C3F3;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--twitter:hover,
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--twitter:hover  .hustle-counter{
      	color: #00C3F3;
      	border-color: #00C3F3;
      }
      #share_bar .hustle_module_id_1 .hustle-inline-content a.hustle-share--twitter:hover  .hustle-icon-path{
      	fill: #00C3F3;
      }

      @media screen and (min-width: 45em)

      #share_bar .hustle_module_id_1 .hustle-inline-content  {
      		display: flex;
      		flex-wrap: wrap;
      		max-width: 72px;
      		margin-right: 0;
      		margin-left: auto
      	}
      	#share_bar .hustle_module_id_1 .hustle-inline-content  a {
      		margin: 0.2em auto;
      		display: flex;
      		width:72px;
      	}
      	#share_bar .hustle-social--squared .hustle-share-icon{
      		width: 18px;
      		height: 18px;
      	}

      Could you help me solve this, please ?

      Regards,
      Greg

  • Adam Czajczyk
    • Support Gorilla

    Hello Greg

    I can see entire share block on the page (it shows on the left right where the article text starts) but it's not looking fine, indeed. Let's try to adjust your CSS again so could you please actually remove the current one first?

    I mean: remove the CSS that you shared above (in your most recent post) from the site completely. This will "clear it up" and give me a "starting point" to work with - I'll then try to create new CSS based on what you had there. Hopefully this will work as expected :slight_smile:

    Best regards,
    Adam

    • Greg
      • Syntax Hero

      Dear Adam Czajczyk ,

      I commented out the CSS out.

      On mobile, the sharebar used to be aligned with the little comment button I created on the right.

      Obviously, the counter was white and the whole button shape was neat (they used to look like the comment custom button, except that they each had the dedicated social network color too).

      On desktop, sharebar buttons had the same design and where vertically aligned with the comment button, in a symetrical fashion.

      Could you please hurry with this ? I really don't like leaving this feature all messed-up.

      Regards,
      Greg

  • Kasia Swiderska
    • Support nomad

    Hello Greg ,

    On desktop, sharebar buttons had the same design and where vertically aligned with the comment button, in a symetrical fashion.

    Can you check this CSS:

    .hustle-social.hustle-social--squared {
    float: right;
    padding: 20px 0;
    }
    
    .hustle-counter--inline {
    max-width: 121px;
    float: right;
    justify-content: flex-end;
    }

    On mobile, the sharebar used to be aligned with the little comment button I created on the right.

    Were they aligned in that icon horizontally in one line? Like that:

    If yes, please try this CSS:

    @media screen and (max-width: 769px) {
    .hustle-ui .hustle-social ul.hustle-counter--inline a[class*="hustle-share-"] {height: 29px;}
    .hustle-ui .hustle-social[data-grid-mobiles="inline"] ul li {padding: 4px;}
    #comment_widget {float: right;
        margin-top: -50px;
    }
    .hustle-ui .hustle-social {width: 100%;}
    .hustle-ui.hustle-inline.hustle_module_id_1.hustle-show {
    display: block;
    max-width: 266px;
    }
    }

    kind regards,
    Kasia

    • Greg
      • Syntax Hero

      Dear Kasia,

      I tried it and it didn't work.

      There are a few things I'd like to point out, if you don't mind :
      1) The CSS is built the other way around. First, I define the mobile version, then I use media queries to adjust to wider screens.

      2) The whole shape of the buttons was different. The comment button I created was shaped after the share buttons. There were rounded corners and the height was a also different.

      Thank you very much for your help.

      Regards,
      Greg

  • Adam Czajczyk
    • Support Gorilla

    Hello Greg

    I apologize for keeping you waiting!

    I gave it a go but I'm afraid it's a bit too much into customization to be rewritten by us. I understand that this all happened after the changes that were made to the plugin but it's still about the custom code. The plugin bug's, as discussed earlier, are at developers' hands and they're dealing with it to provide full performance. This, as well as providing new features, might sometimes mean also some more serious changes in the markup/CSS structure generated by the plugin but the customization added to it is a bit different thing and while I'd love to be able to give you "ready to use code", this CSS would have to be rebuilt for this new structure and classes and that's at this state a custom development that goes too much outside the scope of the support, I'm afraid.

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Greg

    What about the issue with the wrong share count ? Have you had any updates on this one ?

    Yes, I just got some information. Developers are still looking into this and while I don't have an ETA, it seems that further fixes are scheduled for 4.0.3 release. Please note though: it's "targeted" at that update but it'll still need to undergo some tests and pass them so I'd rather not promise yet - it should be included in that release but it's better to assume that a slight (1-3 minor updates) delay might happen in case some test failed. Hopefully though it will be finally fixed by that version.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.