Hutle stopped working - 500 errors

Seems that Hustle stopped working on one of our sites. We click main hustle left menu and we get 500 error.

We just tried to uninstallit and install it again from the hub and it was installed but can't activate it.

Plz help !


  • Adam Czajczyk

    Hello Jordi,

    I hope you're well today and thank you for your question!

    I have accessed your site using support access that you granted and I can see that currently Hummingbird is not active. I didn't try to activate it as I didn't want to risk breaking the site.

    That said, please:

    1. Try first clearing and then disabling cache on site (I see that WP Rocket) is installed there and then enabling the plugin. If that results in the issue again, follow next step

    2. Enable WP debugging by adding following lines to the wp-config.php file

    define('WP_DEBUG', true);
    define('WP_DEBUG_DISPLAY', false);
    define('WP_DEBUG_LOG', true);

    Make sure please that these lines are above the "/* That's all, stop editing */" line and then try enabling Hummingbird again. After it fails, download the "debug.log" file from inside the "wp-content" folder on your server, rename it to debug.txt and attach to you replay here.

    Hopefully that will show me what is the main culprit here.

    Best regards,

  • Jordi

    Helo, problem is with Hustle, but I had to choose Hummingbird plugin coz I couldn't check a plugin that I couldn't enable previously :wink:

    Said this, just want you to know that I could enable this time the plugin and I also added the config files at the beginning of wp-config.phpthe lines in the config file:


    define('WP_CACHE', false); // Added by WP Rocket

    * The base configuration for WordPress
    * The wp-config.php creation script uses this file during the
    * installation. You don't have to use the web site, you can
    * copy this file to "wp-config.php" and fill in the values.
    * This file contains the following configurations:
    * * MySQL settings
    * * Secret keys
    * * Database table prefix
    * * ABSPATH
    * obito
    * @package WordPress

    define( 'WP_MEMORY_LIMIT', '1024M' );
    define( 'WP_MAX_MEMORY_LIMIT', '1024M' );

    define('WP_DEBUG', true);
    define('WP_DEBUG_DISPLAY', false);
    define('WP_DEBUG_LOG', true);

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */

    But no debug.log is being generated :disappointed:

  • Adam Czajczyk

    Hello Jordi!

    Helo, problem is with Hustle, but I had to choose Hummingbird plugin coz I couldn't check a plugin that I couldn't enable previousl

    I'm sorry, you're right. You have clearly stated in your post that it's about Hustle. I guess that when checking your site I just had the big "Hummingbird" name right in front of my eyes as the post was assigned to Hummingbird, hence my mistake. I apologize for it.

    As for the issue. You were able to enable it so it's active now, right? Are you able to disable/enable it again or does it bring 500 errors again?

    If no "debug.log" was created that usually means that there was... no errors but it might be worth checking if they come back. The 500 error might have been caused, in this case, e.g. by server hitting resource limits temporarily or site site getting a bit "clogged" due to a sudden spike of traffic (e.g. from human visitors or even from bots).

    Best regards,

  • Jordi

    Dear Adam, this is our dedicated server, where there are no traffic spikes and the limits per account are pretty generous. I do monitor server every day and it's pretty idle, with 32GBs and 12 cores.

    See that account stats here -->

    See server stats here -->

    I ask you to please check, since we don't know what's going on and really need to get it working ASAP.


  • Predrag Dubajic

    Hi Jordi,

    500 error usually means there's fatal error going on somewhere and when debug is enabled it should catch what it is and tell us what's causing it, it's really strange that it doesn't create log file for you.

    Could you provide us with FTP or cPanel access so we could investigate this further?

    You can send us your details using our contact form and the template below:

    Subject: "Attn: Predrag Dubajic"
    - Site login url
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls

    Best regards,

  • Predrag Dubajic

    Hi Jordi,

    Thanks for sending those in, I had a look at your wp-config.php and saw that you had added Adam's code above the line where debug was disabled so it didn't work because of that.

    I have moved it correct position and after debug log was created we were able to pinpoint the issue, it was caused by the name of your Custom Content, it was named "1" and that caused issue with Hustle > Dashboard stats which thrown fatal error.

    As a quick fix we renamed that Custom Content to One and now it loads properly.

    I have notified the developers about this issue and created a bug report so they can fix this in future release and allow use of numbers as Custom Content name.

    Best regards,