Hyperlink button not working in visual mode

I have a multi-site setup and am using Genesis themes. When editing the body of a blog post in visual mode and trying to add a hyperlink, it does not work properly. The hyperlink pop-up window appears, although it looks a little strange with a double X in the upper right corner of the pop-up. I can fill in the fields, but when I try to UPDATE, it simply refreshes the page and does not insert the hyperlink.

I checked for conflicts with other plugins by deactivating every plug-in and activating only easy blogging. The issue remains. I also checked for Genesis theme conflicts by switching to the Twenty-Eleven theme and running the same test. Still no luck.

Also, another thing I noticed is that when the edit post page first loads, the toolbar displays both the html toolbar and the visual toolbar. If I switch to html and back to visual, sometimes it reverts to showing only the visual toolbar. I tested the hyperlinks in both cases and still no luck.

Please help!