i added the api for google twitter and Facebook followed

i added the api for google twitter and Facebook followed everything i was supposed to but when i click on fb or twitter button to leave comment nothing happens.. and i don't even see GOOGL + show up can you please come into my site to fix this for me? thank you

  • Michael Bissett
    • Recruit

    Hey @Rana Abou-Nassaar, hope you're doing well today! :slight_smile:

    I'm not seeing that the Facebook, Twitter, or Google+ comment buttons are showing up for your posts (though looking at one of your posts, I see that there's two Facebook comment forms?), which post were you testing this with?

    There's quite a lot active on your site, have you tried going through out basic troubleshooting flowchart, found at the bottom of our Getting Support page:

    https://premium.wpmudev.org/manuals/getting-support/

    We'll want to narrow down the cause of the form not showing up, and you'll want to make sure to uncheck the boxes for:

    - "Pages on my website already use javascript from Facebook"
    - "Pages on my website already use javascript from Twitter"

    When you have all of the other plugins disabled on your site, and the theme switched to a default theme (like Twenty Fourteen).

    Please advise,
    Michael

  • Michael Bissett
    • Recruit

    Hey @Rana Abou-Nassaar,

    why do i get this error with GOOGLE ?
    400. That’s an error.

    Error: origin_mismatch

    Application: commentsranaandjoey

    You can email the developer of this application at: ranaandjoey@gmail.com

    Request Details
    That’s all we know.

    It sounds like the Origin URL (the URL for your site) may not have been entered correctly. In step 7 of the Google+ auth instructions, it has this to say:

    In the Authorized JavaScript origins field, enter the origin for your app. You can enter multiple origins to allow for your app to run on different protocols, domains, or subdomains.

    What did you enter there when you set this up?

    As for the comment forms being hidden, it looks like there's some CSS code hiding the comment form on the home page, could you re-enable Support Access to your site, so that I can have another look at your settings?

    Also, the blog post that you linked to doesn't seem to be valid anymore, I'm getting a Cloudflare page when I visit it?

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.