I added the archive, calendar and tag cloud widgets on my

Hello,

I added the archive, calendar and tag cloud widgets on my sidebar and they ropily work.

But when I select one of the elements I get an empty page of posts (even if the count of posts made by the above widget is correct).

I run a dev local multisite environment based on wordpress 3.7.1.

Any suggestion is welcome.

Thank you!

  • Alexander
    • DEV MAN’s Mascot

    Hi @Thermolis,

    This could be a permalink issue. Can you try resetting your Permalinks? You can do this by going to "Settings -> Permalinks" and clicking "save" WordPress caches it's permalink rules for performance, and some events may cause them to become corrupt. This action will clear the cache and allow them to rebuild.

    It could also be related to the settings of the plugin's you're using. Would you happen to be using any of our global site plugins? (recent network posts, global tag widget, etc.) If so, do you have Post Indexer installed? This is required to display the posts. It will create a network wide index for you first.

    Best regards,

  • Alexander
    • DEV MAN’s Mascot

    Ok, good to hear you narrowed that down.

    I see you marked this resolved, but if still want to look into it let me know.

    One thing you could do is check to see if you're getting any error messages while that theme is active

    Try enabling WP_DEBUG mode and debug logging/ To do this, just go to wp-config.php include this:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);

    You might already have a line for WP_DEBUG, so just make sure it's set to true. This will create a log file under wp-content/debug.log with detailed information.

    Best regards,

  • Alexander
    • DEV MAN’s Mascot

    @Thermolis,

    Normally I'd request FTP + login info, but I see this is a local site. I'm not quite sure what else this could be regarding your theme. Did you test for errors with the original theme activated? Did you also try switching back? It might have also been that the posts didn't have time to index, and they are working now.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.