Getting Error During Backup

I am am getting the following error on a few of my sites when I attempt to backup.

"Aw shucks, something went wrong :slight_frown: Instead of the beautiful response we expected, we got this: Other kind of backup error".

Any idea what this means? Thanks

  • Adam Czajczyk
    • Support Gorilla

    Hello Cedric,

    I hope you're well today and thank you for your question!

    I assume this message comes up when you try to manually perform Managed Backup on site, is that correct?

    If yes, I'd like to start with setting WP Smush Pro to use smaller "chunks" of data during backup operation. To do this, please add following lines to the "wp-config.php" file of your site:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);

    Make sure that these lines are located above the "/* That's all, stop editing line */". Once they are there please go to the "Managed Backups" page of Snapshot plugin, deactivate scheduled backups (if they are active), change error reporting level (for all available options) to "Info", save settings and try to run managed backup manually again.

    Let me know please if that helped. If not, please grant me a support access to the site so I could take a closer look. Here's a guide on enabling support access (let me know when it's open):

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Cedric!

    Thank you for granting access and adding those definitions to wp-config.php.

    The Snapshot log shows that it processed up to 324 chunks of file data and I guess it then stopped again with an error, is that correct?

    Let's then please try one more thing. First, let's raise WP memory limit as it's set to only 40M. To do this, add following line to the "wp-config.php" file:

    define('WP_MEMORY_LIMIT', '256M');

    Then, let's also make Snapshot stop processing backup and log the name of the file that caused it stop, by adding yet another line to the "wp-config.php" file:

    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);

    Both these lines should also be located above the "/* That's all, stop editing */" line. Then please try to run backup again. Let me know if it worked or failed again (if it failed, make sure please that support access is still granted).

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.