I am building a site locally and when I updated

I am building a site locally and when I updated to Wordpress 4.5.2 I received the following error message: ''Fatal error: Maximum function nesting level of '500' reached, aborting! in /Users/DaveKriebel/Dropbox/Websites/eight26dc-20160426.dev/wp-includes/cache.php on line 724'. (I've also attempted to increase this nesting level limit and it does not fix the problem.)

After troubleshooting the issue (deactivating my theme and all plugins and slowly adding them back) it appears that 'Events+' is causing this error.

My site is now corrected, but if I reactivate Events+ the error message returns. Are other customers experiencing this problem as well? Is their a fix coming in a future update? If not, do you have any recommendations or advice for how to remedy?

Thank you!