I am building new community website that includes forums

Hi,
I am building new community website that includes forums and articles and i need help as i am going through some issues regarding Visual composer it is not working.

i have contacted the support of Visual Composer and they ask me to deactivate all other plugins and see if it work but it does not. and they say then i have problem in my wordpress.

i have deactivate even the themes and everything but it is still not working

now i need your help regarding this. i granted access to the support so you can access my website and do what ever you need to do to fix for me this issue

Thanks so much in advance

  • Vaughan

    Hi Ammar,

    Hope you're well?

    I have no experience with this plugin at all, i've never ever used it before, so i'm not sure what i'm actually meant to be doing with it.

    What exactly isn't working, you will need to describe the exact problems you're having and what isn't working, because with no experience of the plugin at all, I have no idea what it's meant to do and what it's not meant to do.

    If you could elaborate a bit more on what the problems are, I can perhaps take a look, but overall, the developer of the plugin will know far more about it.

    Thanks

  • Ammar

    Thanks for the reply :slight_smile:

    The problem in the plugin as the following,

    Try to make new post or page.
    You will see Visual Composer is loading
    1st problem is slow
    2nd try to pres + on the VC menu and add what ever you like
    Then publish. After that go back to the page or post list and try to edit it
    You will not find the contents you have add before while it is showing on the website

    Hope this explain it for you.

  • Vaughan

    hi,

    Ok, I see what you mean.

    I tried to add a template in the VC templates, clicked +

    entered the text I wanted. I then published.

    Now tried to edit, but there's nothing in the composer window to edit.

    I do see the following errors in the console though.

    Uncaught SyntaxError: Invalid regular expression: /^\[(\[?)vc_row|vc_row_inner|vc_column|vc_column_inner|vc_column_text|vc_separator|vc_text_separator|vc_message|vc_facebook|vc_tweetmeme|vc_googleplus|vc_pinterest|vc_toggle|vc_single_image|vc_gallery|vc_images_carousel|vc_tabs|vc_tour|vc_tab|vc_accordion|vc_accordion_tab|vc_teaser_grid|vc_posts_grid|vc_carousel|vc_posts_slider|vc_widget_sidebar|vc_button|vc_button2|vc_cta_button|vc_cta_button2|vc_video|vc_gmaps|vc_raw_html|vc_raw_js|vc_flickr|vc_progress_bar|vc_pie|vc_wp_search|vc_wp_meta|vc_wp_recentcomments|vc_wp_calendar|vc_wp_pages|vc_wp_tagcloud|vc_wp_custommenu|vc_wp_text|vc_wp_posts|vc_wp_links|vc_wp_categories|vc_wp_archives|vc_wp_rss|vc_empty_space|vc_custom_heading|[bbp-forum-index]|[bbp-forum-form]|[bbp-reply-form]|baslider|cq_vc_animationfw|cq_vc_dagallery|cq_vc_fluidbox|cq_vc_appmockup|cq_vc_modal|cq_vc_notify|cq_vc_gallery|cq_vc_ihover|cq_vc_profilecard|cq_vc_testimonialcarousel|cq_vc_stackgallery|cq_vc_figurenav|cq_vc_ribbon|cq_vc_mediumgallery|cq_vc_productcover|cq_vc_imagewitharrow|cq_vc_parallax|cq_vc_cqbutton|cq_vc_hotspot|cq_vc_todolist|cq_vc_accordion|cq_vc_tabs|cq_vc_cqcarousel|cq_vc_zoomimage|cq_vc_metrocarousel|cq_vc_draggabletimeline|cq_vc_thumbnailcaption|cq_vc_fullscreenintro|cq_vc_pagetransition|cq_vc_separator|cq_vc_materialcard|TS-VCSC-Font-Icons|TS-VCSC-Icon-Box-Tiny|TS_VCSC_Info_Notice|TS-VCSC-Icon-Counter|TS-VCSC-Circliful|TS-VCSC-Countdown|TS-VCSC-Content-Flip|TS_VCSC_Title_Typed|TS-VCSC-Textillate|TS-VCSC-Image-Adipoli|TS-VCSC-Image-Picstrips|TS-VCSC-Image-Caman|TS-VCSC-Image-Switch|TS_VCSC_Image_SVG|TS_VCSC_Image_Full|TS-VCSC-Image-Overlay|TS-VCSC-Lightbox-Image|TS_VCSC_Amaran_Popup|TS-VCSC-IFrame|TS-VCSC-Youtube|bbp-forum-index|bbp-forum-form|bbp-single-forum|bbp-topic-index|bbp-topic-form|bbp-single-topic|bbp-reply-form|bbp-single-reply|bbp-topic-tags|bbp-single-tag|bbp-single-view|bbp-search|bbp-search-form|bbp-login|bbp-register|bbp-lost-pass|bbp-stats|ult_animation_block|ult_buttons|ultimate_carousel|ult_countdown|ultimate_fancytext|icon_counter|ultimate_google_map|ultimate_google_trends|ultimate_heading|ultimate_ctation|icon_timeline|icon_timeline_sep|icon_timeline_item|icon_timeline_feat|ultimate_icons|single_icon|ultimate_info_banner|bsf-info-box|info_circle|info_circle_item|info_list|info_list_item|ultimate_info_table|interactive_banner_2|interactive_banner|just_icon|ultimate_icon_list|ultimate_icon_list_item|ultimate_modal|ultimate_pricing|ultimate_spacer|stat_counter|swatch_container|swatch_item|ult_ihover|ult_ihover_item|TS_VCSC_Teaser_Block_Standalone|TS_VCSC_Teaser_Block_Single|TS_VCSC_Teaser_Block_Slider_Custom|TS_VCSC_Image_Hotspot_Single|TS_VCSC_Image_Hotspot_Container|TS_VCSC_Lightbox_Gallery|TS_VCSC_iPresenter_Item|TS_VCSC_iPresenter_Container|TS_VCSC_Anything_Slider|TS_VCSC_Figure_Navigation_Item|TS_VCSC_Figure_Navigation_Container/: Range out of order in character class

    seems to be with the composer_storage.js file line 300

    starts_with_shortcode = new RegExp('^\\[(\\[?)' + tags, 'g'); //'^\\[(\\[?)\s*'

    This is what I suspect is causing this, and I would say this is an issue with the plugin itself & not wordpress.

    If you have disabled all other plugins & changed the theme too and this still happens, then it has to be the plugin itself.

    I'm not sure how to fix this though, but maybe if you pass the developers the above, they might know what to look at.

    Hope this helps at least.

  • Ammar

    Hi, i solve it by changing the hosting.

    Now i am on new fresh server :wink:

    I need help with installing USERPRO with Budypress and bbpress.

    can you help me on that ? as the userpro is conflicting with the user management of buddypress and bbpress

    The plugin i am talking about is :

    http://codecanyon.net/item/userpro-user-profiles-with-social-login/5958681?WT.ac=weekly_feature&WT.z_author=DeluxeThemes

    if you know any other plugin for user management with social Register that is reliable please advice me.

  • Vinod Dalvi

    Hi @Ammar,

    can you help me on that ? as the userpro is conflicting with the user management of buddypress and bbpress

    Could you please tell me a bit more in detail how it is conflicting with them so that i can help you?

    if you know any other plugin for user management with social Register that is reliable please advice me.

    You can try using following plugins to achieve it.

    https://wordpress.org/plugins/profile-builder/
    https://wordpress.org/plugins/wp-user-frontend/

    https://wordpress.org/plugins/wordpress-social-login/
    https://wordpress.org/plugins/oa-social-login/

    https://premium.wpmudev.org/project/protected-content/

    https://premium.wpmudev.org/project/members-directory/

    Regards,
    Vinod Dalvi

  • Jack Kitterhing

    Hi there @Ammar,

    Hope you're well today and thanks for your question! :slight_smile:

    I think if you are happy with "User Pro" continue using that, especially if the developer resolved a conflict, as it shows it's in active development and they do care about resolving issues.

    The plugins Vinod's suggested are alternatives which you may wish to try, but if it's all working now, you may wish to stick to User Pro.

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.