I am getting the following error in the WPMUDev Dashboard:

Hi, I am getting the following error in the WPMUDev Dashboard:

Warning: Invalid argument supplied for foreach() in D:wampwwwwikiwp-contentpluginswpmudev-updatesupdate-notifications.php on line 1624

Call Stack

# Time Memory Function Location

1 0.0000 186000 {main}( ) ..admin.php:0

2 0.7500 18861240 do_action( ) ..admin.php:217

3 0.7500 18862160 call_user_func_array ( ) ..plugin.php:429

4 0.7500 18862208 WPMUDEV_Dashboard->dashboard_output( ) ..plugin.php:429

Also using the wiki plugin which is no displaying correctly. Something is broke, is there an easy to fix it (I have tried removing and reinstalling the WPMUDev plugin)?

  • aristath
    • Recruit

    Hello there Paul, I hope you’re well today!

    That is a simple PHP Warning, nothing to worry about.

    Warning are displayed for debugging purposes and should always be disabled in production sites.

    Try setting WP_DEBUG to false in your wp-config.php file and that error will go away.

    However I have notified the plugin developer about it so that he may take a closer look at that.

    As for your wiki issue, could you please post a link to your website so that I may see this in action and understand what goes on?

    Cheers,

    Ari.

  • Paul
    • WPMU DEV Initiate

    HI Chris,

    Unfortunately this is an internal site so not accessible from outside our network.

    I have attached a screenshot if that helps. The problem is that the main body text field is missing and the text formatting menu icons are missing. This is the same in Text and Visual tabs (although in the Visual tab the icons do show). Very odd as worked fine two days ago and no changes on the server or WordPress install (unless it has auto updated recently).

    Cheers,

    Paul

  • Paul
    • WPMU DEV Initiate

    Hi Ari,

    Fixed the missing buttons by remove some plug ins – WooDoJo and Jetpack (didn't use them anyway).

    Tried the CSS to make the "Add Media" button text show but it didn't make a difference, sorry.

    The php error still happens in the WPMUDEV Dashboard so for now I have disabled it.

    The dashboard display is @all over the place' (shows me as a member since Jan 1 1970) so I wonder if it is because it is behind my firewall?

    Cheers,

    Paul

  • aristath
    • Recruit

    Hello again @paul, I’m sorry for the delay, I was sick for a few days and was unable to work.

    Do you still require assistance on this issue or have you already managed to resolve it?

    The error depicted in the screenshot above is a simple PHP warning, nothing to worry about.

    PHP warnings should be hidden in a production server and are only used by developers for debugging.

    You should turn these off by setting WP_DEBUG to false in your wp-config.php file.

    I hope that helps!

    Cheers,

    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.