I am getting this when trying to install the pop up plug

I am getting this when trying to install the pop up plug in:

http://i.imgur.com/XiQlv50.jpg

Install package not available.

My site is listed in https://premium.wpmudev.org/wp-admin/users.php?page=wdpun