I am having an issue with my Multi- Site Blogging

I am having an issue with my Multi- Site Blogging Platform. For some reason users are getting added to other people’s sites and then getting error messages that they don’t have sufficient rights to access that blog.

I am also having an issue with the Site Copier. For some reason when I copy a post now to all the sites on my network, it’s not copying the images and it used to.

Can someone please contact me to help me please?

  • Vinod Dalvi
    • WP Unicorn

    Hi Wendy,

    Welcome to the WPMU Dev community and thanks for posting on the forum.

    I am having an issue with my Multi- Site Blogging Platform. For some reason users are getting added to other people’s sites and then getting error messages that they don’t have sufficient rights to access that blog.

    Do you mean on your multisite network if anybody registers on it then it also gets added to all the sub sites of the network?

    Do you want to not add the registered users on those sites or do you want to fix the error message “you don’t have sufficient rights to access that blog” and allow them to access those sites?

    I am also having an issue with the Site Copier. For some reason when I copy a post now to all the sites on my network, it’s not copying the images and it used to.

    Make sure you have selected the option “Copy images (required for featured images)” in the Additional Options settings when copying the posts.

    Would you mind if i test it on your site by copying any test post?

    Can someone please contact me to help me please?

    Yes sure we will help you on this forum.

    Kind Regards,

    Vinod Dalvi

  • Wendy Bongalis Royer
    • Flash Drive

    Sorry, I wasn’t logged in which is why I could not reply.. You can delete my other open topic.

    Do you mean on your multisite network if anybody registers on it then it also gets added to all the sub sites of the network?

    Do you want to not add the registered users on those sites or do you want to fix the error message “you don’t have sufficient rights to access that blog” and allow them to access those sites?

    No they are not registering and getting added to other people’s sites, I have no idea why they are getting added it just seems to happen randomly. It could be possible they are visiting that persons site and it adds them as a user with no role.

    I do not want to add them as users.

    Make sure you have selected the option “Copy images (required for featured images)” in the Additional Options settings when copying the posts.

    Yes the I have previously been using the site copier with no issues and now I am having these issues with the images.

    Would you mind if i test it on your site by copying any test post?

    Yes I believe I have given access to the site. I had someone develop this site for me WpDude, but he will no longer answer my messages or support requests which is why I paid for your service so that you can help me if I have any issues.

  • Wendy Bongalis Royer
    • Flash Drive

    This is Michelle Cases’ blog. She should be the only person assigned to the blog as you can see from the image above, she is the administrator. But for some reason it is putting this woman Linda as a user of her blog with No Role. Then when Linda tries to login it tells her she has insufficient rights to access (Michelle’s Blog). I do not know if Linda is visiting Michelle’s blog and for some reason automatically getting added as a user to Michelle’s blog but this did not happen before and these blogs have been up for almost a year.

  • Vinod Dalvi
    • WP Unicorn

    Hi Wendy,

    Thank you for your replies.

    It seems the support staff access is revoked on your site so could you please regrant it?

    I keep getting more users who are getting assigned to other people’s blogs.

    Was it working fine for you before?

    If yes then have added/updated/deleted anything that caused this issue?

    Are you using any of the following plugins?

    https://wordpress.org/plugins/multisite-user-management/

    https://wordpress.org/plugins/join-my-multisite

    If yes try deactivating them.

    This can be due to plugin/theme conflict on your site.

    You can just try on your development site using default WordPress theme like Twenty Fifteen and deactivating all other plugins as displayed in the following flowchart to know which theme/plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Regards,

    Vinod Dalvi

  • Wendy Bongalis Royer
    • Flash Drive

    Although my issues with the images not displaying is resolved, I am still having the issue with users getting added to other people’s blogs and then getting an error message that they don’t have sufficient rights to login. I have sent several emails and screen shots along with this post.

  • Jose
    • Bruno Diaz

    Hi Wendy,

    As we discussed via email, this is a separate issue and is not related to the images problem.

    As per your answer above, you can’t relate this problem with any update/installation of plugins, themes, or custom code, right?

    Wondering if the problem started after you migrated to a new host, could you relate the problem with this?

    Last, did you try the plugin/theme conflict test suggested by Vinod above?

    Please advise.

    Cheers,

    Jose

  • Wendy Bongalis Royer
    • Flash Drive

    Yes I did and I have no issues with other plug ins. I actually created a 2nd ticket here for the images which I have marked as resolved. This ticket is still open for the user issue getting added to blogs.

    if the user dlvalentine tries to login at http://www.trimdownglobal.com/wp-login.php she keeps getting added as a user to the main blog. Then she gets an error that she has insufficient rights to access that blog.

    Is there some setting that was changed to point a user to their own blog when they login? Something on the login settings

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.