I am having intermittent caching problems with Upfront that I have not had with X-Theme

Let me start off with congratulating you on a vastly improved "IDE" with Upfront and the dramatically improved load times. I purchased X-Themes as I didn't feel your then version of Upfront was ready for prime time. After once again testing it a few days ago, I decided to once again try it as I do think it is a better environment for developers than X, which I believe is more geared to light users and designers. As a major part of my almost 40 years as a CS was geared to writing IDE's and their components, I believe that is a good endorsement, and well deserved.

However, I believe some of your caching algorithms are causing problems with my cache, which is somewhat advanced. I use TotalCache, MaxCDN, CloudFlair, with disk-enhanced page caching, auto minify mode, object caching with APC and Browser caching,

The system is very fast and has been fine tuned over time. As you would expect, it has to be purged or turned off during development. I always purge cache (except CDN) and things have always worked fine (with X-Theme).

I am using your Scribe Theme at http://hosts.rvhobo.net and your Jobs/Experts plugin. The first thing I noticed is that the first main page text was not showing up 50% of the time. I purged my cache, including disk and optcode cache and page and optcode modules. No luck. I then did a ipconfig /flushdns to be sure nothing was being held on to by Windows 10. No luck.

I needed to change the text in Jobs/Experts to Positions/Hosts (for the U.S. Forest Service). I made the changes and they didn't show up for hours (I did the same flushing as described earlier).

To me it looks like something you did to optimize speed (a cdn?) is causing this as it does not happen on your other themes nor with X. I have given you access to the main MU site at rvhobo.net. The sub-domain that contains the Upfront Theme is hosts.rvhobo.net.

I was pretty cautious in testing this. as I am getting older, but was the Senior CS at a Los Alamos Think Tank so I think I can still remember how. :slight_smile:

Please let me know if you have any ideas, or if I can assist in any way to solve this.

Thanks, Jesse

  • jetiii

    I'm sorry, I have two posts going that ended up pointing to the same problem. I was actually going to the site to write you an update when I spotted your email. The problem appears to be when TotalCache is set to handle CloudFlair. However, it does appear to have something to do with Upfront. You have to go to the CloudFlair dashboard and set dev mode. You can't rely on the interface in the TotalCache dashboard. It appears to be working with just a refresh now.

    I will open up the site to you as soon as I post this.

  • Rupok

    Hi Jesse

    I hope you had a wonderful day.

    Just to make sure we are on the same page, the problem doesn't appear when you put your CloudFlare to Dev Mode, right?

    In my understanding, Upfront doesn't have any caching system of it's own. Most probably you already know this, but your users get data from Cloudflare as you are using it as CDN. So, when all your caching plugins are turned off, and cloudflare is on, cloudflare is still serving from different geolocations. And whenever you make a change in your site, it needs time to propagate the new data to cloudflare servers at different geo-locations. But when you turn on the "Dev" mode in CF, it directly server from your main hosting server, so you get real time update.

    So do you consider this issue to be resolved? Or I missed something? Please let us know if you have any further confusion. We will be glad to help.

    Have a nice day. Cheers!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.