I am having problems with a plugin

Whenever i add <form> ....... </form> code to my page -- it looks fine in visual -- but as soon as I update it -- it strips half of the code out --- so I am trying to figure out why and what is causing it --

in firebug --- I have an error on the following code --

_gaq undefined --

Does anyone know where this code is from ---
I disabled all my google analytics and it is still there ---

Any help would be appreciated

(function (tos) {
window.setInterval(function () {
tos = (function (t) {
return t[0] == 50 ? (parseInt(t[1]) + 1) + ':00' : (t[1] || '0') + ':' + (parseInt(t[0]) + 10);
})(tos.split(':').reverse());
window.pageTracker ? pageTracker._trackEvent('Time', 'Log', tos) : _gaq.push(['_trackEvent', 'Time', 'Log', tos]);
}, 10000);
})('00');
</script>

  • mindset

    the form code is as follows

    Adding a New page ---
    Page width – full width

    <form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top">
    <input type="hidden" name="cmd" value="_s-xclick">
    <input type="hidden" name="hosted_button_id" value="CFMM8R9EN755N">
    <input type="image" src="https://www.paypalobjects.com/en_US/i/btn/btn_subscribeCC_LG.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!">
    <img alt="" border="0" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" width="1" height="1">
    </form>

    I update ---

    Then it changes it – this is what is left

    <form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><img alt="" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" width="1" height="1" border="0" /></form>
    See images

    http://businessv1.actionindavid.com/test-page/

    Now I am trying to disable all plugins to determine what is causing it -- but some of them will not deactivate -- I have pro-sites -- not network activated -- yet it still tells

    As a The Action Society Pro Site, you now have access to all our premium plugins!
    on the sub-site -----

    I had the same problem with buddy press, ultimate facebook, and gd star rating -- I finally got the buddypress, facebook and star rating to disappear somehow --- I just am not grasping how to control these plugins ---

    and then I can't seem to turn w3 cache off either even though it is not network activated -- it still shows up in the sub-site

    so anyhow -- from what I can tell all plugins are deactivated besides pro-sites and w3 cache -- and it is still happening

  • mindset

    Well, here is what I have uncovered --- and it is certainly news to me -- and it makes sense --

    I was under the assumption that superadmin and site admin basically had the same permissions - other than the fact that superadmin could admin all the sites --- and site admin could only administer the sites they owned --

    But that is far from the truth ---- MU rrestricts site admins from putting in html that can manipulate the system --- only superadmin can put in what is considered "evil tags" -- such as some form code, embed, iframe tags, things like javascript - and strips it out when the attempt is made

    The reason is that these features are a very dangerous, if you have untrusted users on your site. Any user could add Javascript code to steal the login cookies of any visitor who runs a blog on the same site. The rogue user can then inpersonate any of those users and wreak havoc. If all you want is to display videos on your WordPress MU blogs, use the native Embed Support, Viper's Video Quicktags or any of the other video plugins on WordPress.org.

    So -- I will want to allow some of my site admins to do this ---- so using role editor -- do you know what special permissions I would set for a new role of "site super admin"????

  • Jack Kitterhing

    Hi there @mindset,

    Hope you're well today and thanks for your question.

    That's correct, that's the unfiltered HTML capability, I would strongly recommend not giving this capability to all other admins, but if you want to this still worked last time I tested it http://wordpress.org/plugins/unfiltered-mu/ (that was about 5 months ago, it hasn't been updated in a while).

    Alternatively user role editor should allow you to do the same :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • mindset

    I can not figure out the options to give site admin the privileges in role editor.

    I still can't figure out this plugin control -- no combinations of plugins seem to work --

    I would like to setup role editor for all blogs - but I don't want them to have access to the settings because then their is no purpose --

    The multisite management plugin is suppossed to be compatable to pro-sites -- but it tells me that the multisite management plugin is not compatible with premium plugins -- I am assuming premium plugins are part of pro-sites ---

    I have spent days and days -- trying to find combinations to control use and access to plugins

  • mindset

    Jack,

    I get a message that says Premium plugins is not compatible with Multi-site Plugin Manager please remove teh Multi-site plugins manager -

    One of the other support guys says they do not work together and are the same thing -- yet everywhere I read -- it says they are compatible -- so I have no idea --

    I want my sub-site admins --- on my 100 action in sites -- to have full site admin permissions but no one else on the network -- to resolve the mu- html filtering -- (which in my opinion is a pretty big deal -- yet I have not seen one word metioned about the reduced functionality of site admins) ---

    But I dont want the admins to have access to the role editor settings -- which I can't seem to make happen ---

    I think I have most of the other issues worked out to an acceptable level so far -- One of the problems is somehow pro-sites lost my settings for plugins -- so I was testing and testing and pro-sites plugins were all set to none -- even though I had them all setup at one time ----

    I have three sets of users -- my action in sites, clients, random users who sign up for blogs and social network ---

    action in sites -- I have set to the highest pro-sites level, clients next, then 3 levels of random user levels ---

  • Jack Kitterhing

    Hi there @mindset,

    Hope you're well today, I've responded to your other post here https://premium.wpmudev.org/forums/topic/best-strategy-to-control-plugin-usage :slight_smile:

    Also, how do I configure the system so my site admins of my core sites have access to the MU unfiltered yet no one else does ---.

    I'd recommend using the module in Pro sites for the unfiltered HTML, then assigning those sites that Pro site level :slight_smile:

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.