I am having problems with WP Smush Pro continually freezing

I am having problems with WP Smush Pro continually freezing after a few images. I have several hundred images on the site and so am constantly having to come back and refresh the page to restart the process. This has ment that I have been trying to get the images smushed for over a week.

  • Rupok
    • Support Ninja

    Hi Josh

    Hope you had a wonderful day.

    Memory deficit could be an issue as Alex suggested above. Can you try what he suggested there?

    But it can happen for other reasons too. I could tell you better if I could have a look inside your site configuration and make some tests. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!

    Rupok

  • Josh
    • Flash Drive

    Hi. I am doing the work on a clients clients website so can’t share access with you.

    I am having the issue on multiple websites on different servers. I finally managed to get it finished.

    I was finding that it would sometimes go a few images and other times 10’s of images.

    I think I might have to experiment with your suggestions on my own sites.

    Thanks

  • Josh
    • Flash Drive

    So I have been doing some more smushing and it looks like the CPU time was not the issue. I have tried boosting the WordPress memory limit to 512 and that seemed to help bust has not resolved the issue. I have found that it seems to freeze less when the window has the focus but this is impractical at times.

    Any more suggestions?

    Anyone else having this problem?

  • Kasia Swiderska
    • Support nomad

    Hello Josh,

    Could you try adding following code to your themes functions.php file:

    add_filter ('WP_SMUSH_API_TIMEOUT', 'wpmudev_increase_timeout');

    function wpmudev_increase_timeout ($timeout) {
    return 180; // the timeout’s measured in seconds, so 180 = 3 minutes
    }

    and see if this will help with the freezing?

    kind regards,

    Kasia

  • Josh
    • Flash Drive

    I have tried adding Kasia’s suggestion and it did not work at all.

    I have also completed a smush on another server (same server company as the one that worked last time) and it worked fine

    I am guessing that it is a sever configuration problem on the main server that I do work on.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.