I am not able to add service provider


and try to add service provider its giving "* You must select at least one service, otherwise provider will not be saved!" this error. Even i select service but still getting error. Please help asap.

Also I need one more information. we have multiple service provider in site. Can we set separate google calendar for them?

  • Patrick
    • Support Monkey

    Hi there @Morpheme Webnexus Pvt. Ltd.

    Welcome to WPMU DEV, glad to have you aboard!

    That is not an error message. That is simply a reminder that appears there so you don't forget to select services when you add a provider.

    Simply click the Add New Service Provider button, and you'll see the form pop open where you can configure a service provider (1st screenshot below).

    If you want to add more than one provider, simply click the button again.

    To enable your service providers to connect to their own Google calendars, set Allow Service Providers for Google Calendar API Integration to Yes under the Google Calendar tab. They will then be able to set things up for themselves in their wp-admin/profile page.

    I hope this helps! And thanks for being a member :slight_smile:

  • Ash
    • WordPress Hacker

    Hello @Morpheme Webnexus Pvt. Ltd.

    I hope you are well today.

    Would you please go to phpmyadmin and check if there is any table in your database called wp_app_workers where wp_ is your prefix, and if there is any data in that table.

    If there is no data in the table, would you please run a plugin conflict test? Please deactivate all plugins except this one and check if you still face the problem. If not, then enable one by one and check which one is causing the problem. You can see the flowchart here: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let me know what you get.


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.