I am not able to save Units within courses I've created.

I am not able to save Units within courses I've created. When I enter information for the unit and click save, the unit is in fact NOT saved, and the content disappears.

This function was working earlier today, and there have been no changes to the site other than adding new content via CoursePress.

  • Adam Czajczyk
    • Support Gorilla

    Hello Jason,

    I hope you're having a nice day!

    I noticed that you're using a Zen Cache plugin. Although I understand that this was working fine along earlier today, could you please just empty all caches, disable the plugin for a moment and see if it solved the issue? It would confirm if there's a conflict or not and help me further investigate it.

    Let me know please!

    Best regards,
    Adam

  • Jason
    • Design Lord, Child of Thor

    Update: Still not working, but I inquired to my server admin about it. He had this to say:

    "Ask their team if it requires cURL or a special PHP module, or, possibly there is a JS conflict with another plugin?"

  • Rupok
    • Support Ninja

    Hi Jason

    I hope you had a wonderful day.

    I just checked and found that this is a known bug and our developers are already aware of it and working on this. This is not fixed yet but I believe, our developers will provide a solution very soon.

    However, one of our members found a workaround and seems like its working for him. He said:

    Units are saved successfully if I toggle the switch from "Draft" to "Live" before clicking "Save". After the unit is saved in this way, I can toggle it back to "Draft", and it will survive.

    Can you please try this and confirm if it's working for you or not? If it works, can you please work with this and wait until our developer releases the fix? I do apologize for the inconvenience.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.