I am not getting a copy of the confirmation email. I used to receive them previously.

Hello. People are making appointments, yet I am not receiving a copy of the confirmation email sent to the client. I used to receive these copies and would like to be able to continue receiving them. Can you please help me solve this issue?

Thank you!

  • Alexandre

    I seem to have found what appeared to be causing the issue: My translation .mo file has been replaced by another. I had made that translation and thought it should never be automatically replaced via a plugin update. But it has. Even the backend (Admin) has been (badly) translated. Luckily, I had a backup of the original .mo file I had created. As soon as I uploaded it via FTP back to wp-content > languages > plugins, I created an appointment and received a confirmation email as Client, and a copy to Provider, as expected.

    The issue now seems to be gone. I don't know how this might have caused the malfunction of the confirmation email, but what I need now is that translation file to stay put, since I haven't kept a backup of the original .po file.

    I need you to tell me what made my translation file be replaced, and how to prevent this from happening again.

  • Predrag Dubajic

    Hi Alexandre,

    Hope you're doing well.

    Glad to hear that you managed to find the issue in the meantime, but I must say that this is really strange one.

    When you update the plugin it will only affect plugin files, in this case wp-content/plugins/appointments/.
    It doesn't make any changes to wp-content/languages/plugins/ folder as one of the purposes of this folder is to keep the translations untouched during the update process.
    To be sure about this I just tested update of both WordPress and Appointments+ on my site and my custom translation files were untouched.
    I'm afraid that something else made this change on your site and replaced the translation files, does anyone else except you have access to your WP files?

    Regardless of that, the translation files shouldn't be affecting any site functionality so that's even more surprising.
    Do you have the .po or .mo file that you had issues with so we can do some tests with it on our end and check what happened?
    If you do can upload it to any file sharing service like DropBox or GDrive and share the download link here?

    Best regards,

  • Alexandre

    Hello Predrag,

    In answer to your first question, I am the only person with access to my WP files.

    I is, indeed, surprising that a change in my translation file (an unwanted and unforseen one at that) could somehow break my previously working confirmation email settings. But no sooner did I replace my original .mo customized translation, than the confirmation email issue was gone.

    What led me to find an issue with my translation was the following. Maybe it would help clarify what is happening, since right now we have no idea if it might happen again.

    Weeks ago (last update?), I noticed that I wasn't receiving copies of the confirmation emails. I would only able to check for new appointments in my Admin page. Since this wasn't an urgent issue during the holidays, I thought I'd wait till I had more time to look into this. Finally, yesterday, as I requested this Support, I also took notice of another fact: that my Appointments' Admin interface, which I had left untranslated (I prefer so), was showing up translated into the default language specified in Wordpress WP-config, and very poorly at that. I then accessed my files via FTP and changed the name of the .mo translation in question. All went back to English, back end and front end.

    But this couldn't be! I hadn't touched that file since 2016, let alone adding bad translations to the Appointments Admin interface.

    I looked for a backup and, fortunately, had one .mo translation deeply hidden in my Dropbox. I uploaded it. And all went back to normal.

    I'm uploading the problematic .mo file as you requested. It's marked as INACTIVE. I am also attaching the desired .mo translation file, which I retrieved and made my issue disappear.

    Please don't mark this as resolved until we know this won't happen again?

    Thank you.

  • Predrag Dubajic

    Hi Alexandre,

    Unfortunately we can't guarantee that this will not happen again as it seems there's something strange going on your installation.
    As I mentioned above I tested update of both Appointments+ and WordPress and that didn't affect my translation files from wp-content/languages/plugins/.
    Also, Appointments+ files only have appointments.pot file in its translation folder so even if something weird happened and translation files from plugin were added to your languages folder there's nothing that could replace existing .mo file.

    What we can do is check why the translation files messed up the emails in the first place so that doesn't happen in future even if somehow you do get your translation files replaced.
    Unfortunately I don't see anything attached in the above comment, if you tried to attach them to your comment directly I'm afraid that this is not possible as members can only attach txt and image files due to security reasons.

    Could you please use DropBox or Gdrive, as mentioned above, and send the download link so we can investigate this further.

    Best regards,

  • Dimitris

    Hello there Alexandre,

    hope you're doing good today and don't mind me jump in here! :slight_smile:

    I've just made couple of tests with both translation files and both member and admin users received their confirmation emails.
    I wonder if this has to do with any changes/settings you've made, so could you please grant support access to your website to have a better look? You can do so via WPMUDEV Dashboard plugin, here's how in case you don't know already:
    Just let us know here in your next reply that access has been granted, as we don't get any notifications about it.

    Warm regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.