I am probably not understanding the protected content

I am probably not understanding the protected content situation. When I try and access my site http::onestoplearningcenter.com I reach a page that says: "The content you are trying to access is only available to members. Sorry."

None of the menu items will work on the page. If I try to log out I am returned to the same listing above. I can no longer log inyto the site as admin. My last login was as a newly registered "free: member and I seem to be stuck at that level. In essence, my site is no longer accessible to the admin panel except as this free visitor. When I attempt to go to the site as: onestoplearningcenter.com/wp-admin I only get the "Dashboars" and "Profile" in the left side menu. If I try and logout as this free member I am returned to a page: "http://onestoplearningcenter.com/protected-2/" with the above message.
------------------------------------------------
Additionally, I still am unable to access the support facility. You said I had three accounts active. One is a Premium monthly paid subscription nd the other two are not. No matter how I try and get to support I am treated as a free member. Is it possible to delete the two free accounts? I will need the login credentials for the paid account!
My WPMU DEV dashboard seems to be set to log me in as one of the free accounts. How do I reset this for future?
-------------------------------------------------
I desperately need support with this plugin. Promised 24/7 support. Is that only through the forum or is there a support facility I can contact directly and how?
---------------------------------------------------
I am struggling with the plugin to date without any meaningful help. While I do NOT wish to cancel or request a refund (still within the 30 day period), without support and assistance to get the program up and running properly and quickly it is of no use to us.
--------------------------------------------------
Please respond with some answers.

Thanks
logged in as lastdrifter
cannot reach forum or support

  • PC

    Hello @lastdrifter

    Greetings and thanks for posting on the forums.

    first of all, this is the right account you need to be logged in to access support.

    I am probably not understanding the protected content situation. When I try and access my site http::onestoplearningcenter.com I reach a page that says: "The content you are trying to access is only available to members. Sorry."

    On the top in the admin bar, you should see View site as >> Select Membership admin and it should be fine.

    Additionally, I still am unable to access the support facility. You said I had three accounts active. One is a Premium monthly paid subscription nd the other two are not. No matter how I try and get to support I am treated as a free member. Is it possible to delete the two free accounts? I will need the login credentials for the paid account!
    My WPMU DEV dashboard seems to be set to log me in as one of the free accounts. How do I reset this for future?

    Just go to WPMU DEV Dashboard >> Manage >> Click Edit on the API key field and you will be logged out of the Dashboard plugin. Just login with the new credentials and it should work fine after that.

    I desperately need support with this plugin. Promised 24/7 support. Is that only through the forum or is there a support facility I can contact directly and how?

    You just contacted them :slight_smile:

    I am struggling with the plugin to date without any meaningful help. While I do NOT wish to cancel or request a refund (still within the 30 day period), without support and assistance to get the program up and running properly and quickly it is of no use to us.

    Did that happen before ? I mean you created a thread and no one responded ? I would certainly like to know if that happened so that we can take care of it.

    Please feel free to ask if you have more questions.

    Cheers, PC

  • lastdrifter

    OK...Thanks for your reply. Here are the remaining issues:

    1. I tries your suggestion with the WPMU DEV Dashboard and Manage and Edit the key...I am taken to a login page and I enter the credential username=lastdrifter and password. I am then shown a page that list my login as onestopl...but according to a message received that is one of those free accounts. I can reach the proper page only by going to WPMU in google and clicking on the website. Then I am logged into my lastdrifter account and can reach this support facility.

    2. I have uninstalled the plugin and reinstalled it...It now seems to be working much better...However, I don't seem to understand the "protected" stuff and how to accomplish it...I have used the [not-level visitors] and [level-visitors] tags in both the visual and text editor on the page "Account" as I do not want that page to show up when a visitor is on the site...realizing if they click on that link in the menu it should give the not authorized to....verbage in the return...However, the page actually comes up...but...with the shortcode listed next to nothing since a visitor has no account yet...I have a page for free members and another for paid members...both are identical except that on the paid members page there exists a download link...I have used the shortcodes to distinguish the pages of [level-free members] and [level-not-free members] and also [level-paid members] and [level-not-paid-members] but it seems to have no significance...I seem to understand that a paid member shoulkd be able to view the free members page but the free member should not be able to view the paid members page...However, this is not happening...the free member i able to view the paid member page. Of course it would be much better if I could just create the one page (say the paid member page) and hide the link to the free member...But I can not figure out how to get this to work. As I thought I understood things, the shortcodes should hide the link...but they do not which caused me to create both pages...and I also do not understand why the shortcode itself is showing up on the rendered page.

    I am currently working on a localhost site with the apache server. I thought that could be the problem...so I took the site live...but all is as reported above...no change.

    3. I have also found no way to assign menu items to different membership levels. The same menus appear on every page...Within the access levels there is a menu item but nothing comes up within it so that I can make the assignments...it says to check the pages to be shown to that level by checking the boxes....the pages are not listed and there are no boxes to check.

    I'm sure I have missed or misinterpreted something, but I have no idea what!..or how to correct these things...could someone shed some light on these matters please.

    Thanks

  • lastdrifter

    Additionally:

    Since attempting to get the WPMU DEV dashboard to log me in as a paid member, since then it will not let me login at all....Under "manage" it is asking me to set-up another free account saying only lastdrifter can use the admin panel...What do I do Now?

    I have tried disabling and reenabling without any success...took it out and reinstalled, no success...not sure what to do now...help!

  • PC

    Hello @lastdrifter

    Greeting and thanks for your post.

    Regarding the membership plugin issue, in order to configure it you will need to follow the guide here closely : https://premium.wpmudev.org/wp-content/uploads/2010/05/Membership3440-Docs.pdf

    For the Dashboard plugin issue, it seems that there is some issue with the configuration. I can try and fix that for you but you will need to send me a few details.

    Can you send me your login creds via our secure contact form here : contact form

    Subject : Attn: PC
    Question Type : I have a different Question
    Please include a link to this thread, and include your WordPress admin and WPMU DEV login details so that I can have a closer look.

    Cheers, PC

  • PC

    Hello @lastdrifter

    Thanks for standing by.

    Since attempting to get the WPMU DEV dashboard to log me in as a paid member, since then it will not let me login at all....Under "manage" it is asking me to set-up another free account saying only lastdrifter can use the admin panel...What do I do Now?

    That has been fixed. You were not logged in to your WPMU DEV Dashboard plugin using the right credentials.

    1. I have read the manual again several times and still apparently do NOT understand. To review below identified for clarity see pages:

    http://onestoplearningcenter.com/cpanel-autoresponse-email-paid-members/

    Near the bottom of the page is a link for the paid member to download the video package. No other members (not visitors or free members) should see this download link. Visitors need to be baned from arriving on the page completely. Free members may view the video, bit not be able to download it.

    Around the download link I have placed the code as below:

    [level-Paid-Members]
    <p>Click Here to Download Video.</p>
    [/level-Paid-Members]

    When I pull up the page this is what I see:

    [level-Paid-Members]
    Click Here to Download Video.

    [/level-Paid-Members]

    If I understand the manual correctly, which obviously I do not, the shortcode should not be listed at all and the link should only appear to those on the level paid members.

    I need some advise on why this is happening and exactly what I am doing incorrectly. The proper code would be helpful.

    That is not the right code to be used. The correct shortcode will be

    [level-paid-members]
    [/level-paid-members]

    I tried to correct that and even created a test post but shortcodes are not working. Perhaps there is a theme/plugin conflict on your site. Is that okay if I can switch the site to default theme and disable other plugins so that we can test what is wrong ?

    2. I can find nothing in the manual that deals with menus.

    I wish to show a different set of menus to each of these member groups. For instance, there is no need to display \"accounts\" on the visitors menu as obviously they do not have an account.
    They only need registration and sign-up criteria in their menu and be able to see the Sample Video. Therefore, insuring other items do not appear on their menu guarantees their inability to access pages missing menu items lead them to.

    Likewise, free members only have limited access to the website. Therefore, they should also have a limited menu selection.

    Paid members have full access to the website and should have all menu items available to them, as well as all benefits.

    Back to item 1 above for a moment.

    If you view the page:

    http://onestoplearningcenter.com/cpanel-autoresponse-email-free-members/

    You will find it is identical to the same page sited above for paid members. That is its content is the same except that the download link has not been included.

    This creates a situation where we must code two pages identically except for the included link. Obviously, it would be much more productive and less time consuming to only have to make the page for the paid member and hide the access to the download link when viewed by the free member. Additionally, we had to make two separate pages to bring members to the pages - one for the free members to their pages and one for the paid member to bring them to their pages. Besides the additional time in construction there is also the issue of additional disk space to hold all the extra pages.

    As of this date we have uploaded 36 videos to the website which made us create 74 pages instead of 37 (one for each video and an index page). Since we are attempting to place some 456 videos on our site, continuing this method of development would take months. To be able to simply create one page for each video and an index page for the lot would greatly simplify our task. Consequently, assistance is greatly needed in this matter on an immediate basis.

    Please do NOT refer me back to the manual since it is obvious I do not comprehend what is written and can not on my own duplicate what is being offered there. A few examples of the proper coding and an in depth explanation of why and how to implement would be very helpful.

    That is not how it should work. The Membership plugin is designed to be able to handle these things so we first need to identify why the shortcodes are not working.

    As far as the details about menu is concerned, the manual covers it on Documentation Page 47 Of 70

    I am not referring you to the manual again but personally I suggest you to set the website up according to the manual. It helps a lot in understanding how things work. You setup the shortcodes right but its something on the site which is keeping things from working properly.

    So, would that be okay if you can switch to the default theme (2012) with other plugins disabled so that we can find out what is going on ?

    Please advise.

    Cheers, PC

  • lastdrifter

    Hello,

    Thanks and forgive me for the delay in responding...We have been experiencing power outages throughout the day.

    1. Yes...You may change the theme if required and disable whatever is necessary to correct the problem with the shortcodes. I am working on a localhost apache server and once I understand what is required I will correct my version and upload it back to the server. Please do inform me of the results in an understandable fashion so that I will be able to use the shortcode method in other pages. I did also try the non-capitalized method but now understand why nothing seemed to work.

    2. I have read through the manual (every page) more than 6 times, but thick me is not understanding something...I will go again and review page 47 and try again with getting the menus right...If I continue to have the problem I will get back to you with details of that failure.

    Thanks again!

  • lastdrifter

    I think we may be looking at the incorrect manual...My manual contains 79 pages and page 47 is part of the "Communications Dashboard".

    Where can I get the manual you are referring to or where in my manual is located te page you mention. I can find nothing that appears to talk about menus.

    Additionally: I think I am correct in this...Any corrections you have made on the live site would be overwritten if I employ my localhost site over it...To me that means that I should get you to send me the exact changes made...how and where they were made...so that I can employ them on my localhost site...This would insure that when I upload (using: Duplicator: - which clones my localhost site and redeploys it to my live server) changes would remain intact. If I am correct, I need specific instruction on what to do to get the localhost site corrected.

    Thanks!

  • PC

    Hello @lastdrifter

    Thanks for posting back.'

    The manual I am referring to is here : https://premium.wpmudev.org/wp-content/uploads/2010/05/Membership3440-Docs.pdf

    1. Yes...You may change the theme if required and disable whatever is necessary to correct the problem with the shortcodes. I am working on a localhost apache server and once I understand what is required I will correct my version and upload it back to the server. Please do inform me of the results in an understandable fashion so that I will be able to use the shortcode method in other pages. I did also try the non-capitalized method but now understand why nothing seemed to work.

    I disabled all the plugins which were active but the issue was still there
    I switched to default theme but the issue was still there
    I created a new page and the issue was not there. I was able to use the shortcodes with out any problem

    You can test it here : http://onestoplearningcenter.com/testingashortcode/

    Test it by viewing as a admin - You will see the shortcodes on the page as you are logged in as a membership admin

    Then open the page in a incognito browser and you will see that the video download link is not visible which clearly indicates that the Membership plugin is working absolutely fine. The problem is how you have created a page and put the content in.

    Perhaps you copied and pasted the content with some bad piece of code. There are javascript errors on the page here :

    http://onestoplearningcenter.com/wp-admin/post.php?post=1133&action=edit

    As compared to the above

    http://onestoplearningcenter.com/wp-admin/post.php?post=1219&action=edit does not have any error messages which shows that it's a problem with how you have added the content to the page.

    You will also notice that on the page with errors, you can not access the text editor tab but on the page I created you can access the text editor as well as the visual editor.

    I will suggest you to create the page properly and then try again. Do not copy and paste the content from anywhere as you might end up pasting some useless code which causes all the mess.

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers
    PC

  • lastdrifter

    Thank you very much...

    I have found the problem with not being able to switch between the video and text editor. Once that was sorted the shortcodes started working fine. The problem was in the coding to show the video on the page. I never would have independently been able to sort that out...so...Thank you very, very much!

    I have downloaded the recommended tutorial listed above and will go about trying to understand and sort out the menu configuration for different levels. It seems there are so many different manuals for the program. I hope this one I can understand better. If I have any further problems I will submit a new support ticket.

    If you made any changes - such as changing any configuration in the WPMU DEV Dashboard, please let me know what they are so I can duplicate them on my localhost website. At some point this week I will be cloning and uploading my localhost version of the site to the live hosting account and it will overwrite any changes that may have been made, including any to the WPMU DEV Dashboard.

    Again...Thanks so much for your assistance!

  • PC

    Hiya,

    I have found the problem with not being able to switch between the video and text editor. Once that was sorted the shortcodes started working fine. The problem was in the coding to show the video on the page. I never would have independently been able to sort that out...so...Thank you very, very much!

    You are most certainly welcome :slight_smile: Glad that its sorted out now !

    I have downloaded the recommended tutorial listed above and will go about trying to understand and sort out the menu configuration for different levels. It seems there are so many different manuals for the program. I hope this one I can understand better. If I have any further problems I will submit a new support ticket.

    Sure thing :slight_smile: Please create a ticket so that we can assist you accordingly. We are currently in the process to make usage guides more user friendly and we will get there soon !

    If you made any changes - such as changing any configuration in the WPMU DEV Dashboard, please let me know what they are so I can duplicate them on my localhost website. At some point this week I will be cloning and uploading my localhost version of the site to the live hosting account and it will overwrite any changes that may have been made, including any to the WPMU DEV Dashboard.

    Nothing has been changed in the configuration. It was working fine when I checked it out. You just need to make sure that when you login to the Dashboard plugin, you use the right username and password.

    I am happy that we were able to help you for your issues. Thanks for being a WPMU DEV member and have a nice day !

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.